aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-07-28 03:24:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-07-28 03:24:55 +0800
commitcd87ac168bf67f14a7a88106b0d3e5c6a140fff5 (patch)
tree848668de412233ba5ca7c5c2a1150ba09f200081 /devel
parentae337b81966db5cc7f53c378f5acc885f0307de7 (diff)
downloadfreebsd-ports-gnome-cd87ac168bf67f14a7a88106b0d3e5c6a140fff5.tar.gz
freebsd-ports-gnome-cd87ac168bf67f14a7a88106b0d3e5c6a140fff5.tar.zst
freebsd-ports-gnome-cd87ac168bf67f14a7a88106b0d3e5c6a140fff5.zip
- Add p5-Mixin-Event-Dispatch 1.006
Add Mixin::Event::Dispatch in as a parent to your class, and it'll provide some methods for defining event handlers ("subscribe_to_event" or "add_handler_for_event") and calling them ("invoke_event"). Note that handlers should return 0 for a one-off handler, and 1 if it should be called again on the next event. WWW: http://search.cpan.org/dist/Mixin-Event-Dispatch/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Mixin-Event-Dispatch/Makefile27
-rw-r--r--devel/p5-Mixin-Event-Dispatch/distinfo2
-rw-r--r--devel/p5-Mixin-Event-Dispatch/pkg-descr8
-rw-r--r--devel/p5-Mixin-Event-Dispatch/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ba324222fbc1..4de6acad32c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2499,6 +2499,7 @@
SUBDIR += p5-Method-Signatures-Simple
SUBDIR += p5-Minilla
SUBDIR += p5-Minion
+ SUBDIR += p5-Mixin-Event-Dispatch
SUBDIR += p5-Mixin-Linewise
SUBDIR += p5-Mknod
SUBDIR += p5-Mo
diff --git a/devel/p5-Mixin-Event-Dispatch/Makefile b/devel/p5-Mixin-Event-Dispatch/Makefile
new file mode 100644
index 000000000000..f5766f1039c8
--- /dev/null
+++ b/devel/p5-Mixin-Event-Dispatch/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Mixin-Event-Dispatch
+PORTVERSION= 1.006
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TEAM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Mixin methods for simple event/message dispatch framework
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-List-UtilsBy>=0:${PORTSDIR}/devel/p5-List-UtilsBy
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-CheckDeps>=0.010:${PORTSDIR}/devel/p5-Test-CheckDeps \
+ p5-Test-Fatal>=0.010:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-Refcount>=0.07:${PORTSDIR}/devel/p5-Test-Refcount
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Mixin-Event-Dispatch/distinfo b/devel/p5-Mixin-Event-Dispatch/distinfo
new file mode 100644
index 000000000000..cac2fbb8572f
--- /dev/null
+++ b/devel/p5-Mixin-Event-Dispatch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Mixin-Event-Dispatch-1.006.tar.gz) = a571146d17c0c4eccec3f155b18e746d7e1e31599862810df554ac531b240dcb
+SIZE (Mixin-Event-Dispatch-1.006.tar.gz) = 22384
diff --git a/devel/p5-Mixin-Event-Dispatch/pkg-descr b/devel/p5-Mixin-Event-Dispatch/pkg-descr
new file mode 100644
index 000000000000..ed63088f2e43
--- /dev/null
+++ b/devel/p5-Mixin-Event-Dispatch/pkg-descr
@@ -0,0 +1,8 @@
+Add Mixin::Event::Dispatch in as a parent to your class, and it'll provide some
+methods for defining event handlers ("subscribe_to_event" or
+"add_handler_for_event") and calling them ("invoke_event").
+
+Note that handlers should return 0 for a one-off handler, and 1 if it should be
+called again on the next event.
+
+WWW: http://search.cpan.org/dist/Mixin-Event-Dispatch/
diff --git a/devel/p5-Mixin-Event-Dispatch/pkg-plist b/devel/p5-Mixin-Event-Dispatch/pkg-plist
new file mode 100644
index 000000000000..ca4c6a7ddd30
--- /dev/null
+++ b/devel/p5-Mixin-Event-Dispatch/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Mixin/Event/Dispatch.pm
+%%SITE_PERL%%/Mixin/Event/Dispatch/Bus.pm
+%%SITE_PERL%%/Mixin/Event/Dispatch/Bus.pod
+%%SITE_PERL%%/Mixin/Event/Dispatch/Event.pm
+%%PERL5_MAN3%%/Mixin::Event::Dispatch.3.gz
+%%PERL5_MAN3%%/Mixin::Event::Dispatch::Bus.3.gz
+%%PERL5_MAN3%%/Mixin::Event::Dispatch::Event.3.gz