aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2012-08-19 19:29:30 +0800
committerrafan <rafan@FreeBSD.org>2012-08-19 19:29:30 +0800
commitcfb1fbad433520af6cf867c06083eab02ad385f6 (patch)
tree73f1fefb6a6293c866a96be77804d4d401ad4b9a /devel
parentaebbdb711f5ba1a636c5819cd786ec988ec4e60f (diff)
downloadfreebsd-ports-gnome-cfb1fbad433520af6cf867c06083eab02ad385f6.tar.gz
freebsd-ports-gnome-cfb1fbad433520af6cf867c06083eab02ad385f6.tar.zst
freebsd-ports-gnome-cfb1fbad433520af6cf867c06083eab02ad385f6.zip
- Don't use implicitly declared dependency, use OPTIONS to declare it
- While I'm here, give up for adoption as I no longer use it in my daily life Submitted by: A.J. Kehoe IV (Nanoman) <nanoman at nanoman.ca> (via email)
Diffstat (limited to 'devel')
-rw-r--r--devel/swig13/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 945616e6bbca..aa82c79c697e 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.3.40
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= rafan@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Simplified Wrapper and Interface Generator
USE_AUTOTOOLS= autoconf:env libtool
@@ -28,17 +28,19 @@ CFLAGS+= -fPIC -DPIC
ALL_TARGET= swig
PLIST_SUB+= VER="${VER}"
-WANT_LUA= yes
-WANT_LUA_VER= 5.0+
+OPTIONS_DEFINE= LUA
+LUA_DESC= Enable Lua support
.include <bsd.port.pre.mk>
-.if ${HAVE_LUA:Mlua-5.*} != ""
-USE_LUA= yes
+.if ${PORT_OPTIONS:MLUA}
+USE_LUA= 5.0+
LUA_COMPS= lua:build
CONFIGURE_ARGS+=--with-lua=${LUA_BINDIR}/lua \
--with-luaincl=${LUA_INCDIR} \
--with-lualib=${LUA_LIBDIR}
+.else
+CONFIGURE_ARGS+=--without-lua
.endif
OCTAVE_VER_CMD= ${LOCALBASE}/bin/octave-config -v 2>/dev/null || ${TRUE}