aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2005-10-19 01:29:19 +0800
committersergei <sergei@FreeBSD.org>2005-10-19 01:29:19 +0800
commitcfc153d2c8e7e139ed57d1b0e0f3b85cb1273c06 (patch)
treeacde5ec54c2a838cb5649485a31ff3ec740f60ca /devel
parent7991af93991beb6886ad8676a814a236042c735a (diff)
downloadfreebsd-ports-gnome-cfc153d2c8e7e139ed57d1b0e0f3b85cb1273c06.tar.gz
freebsd-ports-gnome-cfc153d2c8e7e139ed57d1b0e0f3b85cb1273c06.tar.zst
freebsd-ports-gnome-cfc153d2c8e7e139ed57d1b0e0f3b85cb1273c06.zip
- Attempt to fix the build on 4.x:
- add patch for <time.h> that should be <sys/time.h> - newer versions of bglibs use some C9X/C99 macros (e.g. va_copy) which are only available in GCC 3.x. This should be a NOOP on 5.x but seems to fix the breakage under 4.x, although at the expense of the heavy GCC dependency Submitted by: Dale Woolridge (in private e-mail)
Diffstat (limited to 'devel')
-rw-r--r--devel/bglibs/Makefile1
-rw-r--r--devel/bglibs/files/patch-clockgettime9
2 files changed, 10 insertions, 0 deletions
diff --git a/devel/bglibs/Makefile b/devel/bglibs/Makefile
index d03ddf0fb488..be1736e37f26 100644
--- a/devel/bglibs/Makefile
+++ b/devel/bglibs/Makefile
@@ -18,6 +18,7 @@ NOT_FOR_ARCHS= alpha
USE_GPG= yes
SIG_SUFFIX= .sig
+USE_GCC= 3.2+
LDFLAGS?= -s
BGLIBS_INC= ${PREFIX}/include/${PORTNAME}
BGLIBS_LIB= ${PREFIX}/lib/${PORTNAME}
diff --git a/devel/bglibs/files/patch-clockgettime b/devel/bglibs/files/patch-clockgettime
new file mode 100644
index 000000000000..dbc5c4725c04
--- /dev/null
+++ b/devel/bglibs/files/patch-clockgettime
@@ -0,0 +1,9 @@
+--- sys/tryclockgettime.c Tue Aug 23 14:23:04 2005
++++ sys/tryclockgettime.c Sat Sep 24 20:08:17 2005
+@@ -1,5 +1,5 @@
+ /* $Id: patch-bglibs-1.027-dw-clockgettime.1-freebsd,v 1.1 2005/09/25 00:11:22 root Exp $ */
+-#include <time.h>
++#include <sys/time.h>
+
+ int main(void)
+ {