aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-10-05 05:51:58 +0800
committerdemon <demon@FreeBSD.org>2014-10-05 05:51:58 +0800
commitd098b386516d040f68f370929df913af9b7c462a (patch)
treeeea981e10fa420f1496b16efc2bc29c023faa46d /devel
parent8f99be5f4baeb406670c1ed433670a31d07f753d (diff)
downloadfreebsd-ports-gnome-d098b386516d040f68f370929df913af9b7c462a.tar.gz
freebsd-ports-gnome-d098b386516d040f68f370929df913af9b7c462a.tar.zst
freebsd-ports-gnome-d098b386516d040f68f370929df913af9b7c462a.zip
Install protobuf in ${PREFIX}/protobuf25 to avoid conflict with devel/protobuf.
Diffstat (limited to 'devel')
-rw-r--r--devel/hadoop2/Makefile6
-rw-r--r--devel/protobuf25/Makefile1
-rw-r--r--devel/protobuf25/pkg-plist130
3 files changed, 69 insertions, 68 deletions
diff --git a/devel/hadoop2/Makefile b/devel/hadoop2/Makefile
index a5ab4e21b961..5cb3f2b8a3d6 100644
--- a/devel/hadoop2/Makefile
+++ b/devel/hadoop2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hadoop
PORTVERSION= 2.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_APACHE} \
LOCAL/demon/:maven \
@@ -32,7 +32,7 @@ USE_JAVA= yes
JAVA_VERSION= 1.7+
USE_LDCONFIG= yes
SHEBANG_FILES= hadoop-hdfs-project/hadoop-hdfs-httpfs/src/main/sbin/httpfs.sh hadoop-hdfs-project/hadoop-hdfs-httpfs/src/main/libexec/httpfs-config.sh
-MAKE_ENV+= HADOOP_PROTOC_PATH=${LOCALBASE}/bin/protoc
+MAKE_ENV+= HADOOP_PROTOC_PATH=${LOCALBASE}/protobuf25/bin/protoc
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
TOMCAT_VERSION= 6.0.36
@@ -69,7 +69,7 @@ post-patch:
do-build:
${MKDIR} ${WRKSRC}/hadoop-hdfs-project/hadoop-hdfs-httpfs/downloads
${CP} ${DISTDIR}/${DIST_SUBDIR}/apache-tomcat-${TOMCAT_VERSION}.tar.gz ${WRKSRC}/hadoop-hdfs-project/hadoop-hdfs-httpfs/downloads/
- cd ${WRKSRC} && ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline clean package -Pdist,native -DskipTests
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/m2 --offline clean package -Pdist,native -DskipTests
post-build:
${RM} ${HADOOP_DIST}/etc/hadoop/*.cmd
diff --git a/devel/protobuf25/Makefile b/devel/protobuf25/Makefile
index e2bc6eaba04c..58a46175d054 100644
--- a/devel/protobuf25/Makefile
+++ b/devel/protobuf25/Makefile
@@ -16,6 +16,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING.txt
GNU_CONFIGURE= yes
+GNU_CONFIGURE_PREFIX= ${PREFIX}/protobuf25
USE_LDCONFIG= yes
USES= gmake pathfix pkgconfig tar:bzip2 libtool
ONLY_FOR_ARCHS= i386 amd64
diff --git a/devel/protobuf25/pkg-plist b/devel/protobuf25/pkg-plist
index 4ac7840d623b..345a5dd2c888 100644
--- a/devel/protobuf25/pkg-plist
+++ b/devel/protobuf25/pkg-plist
@@ -1,65 +1,65 @@
-bin/protoc
-include/google/protobuf/compiler/code_generator.h
-include/google/protobuf/compiler/command_line_interface.h
-include/google/protobuf/compiler/cpp/cpp_generator.h
-include/google/protobuf/compiler/importer.h
-include/google/protobuf/compiler/java/java_generator.h
-include/google/protobuf/compiler/parser.h
-include/google/protobuf/compiler/plugin.h
-include/google/protobuf/compiler/plugin.pb.h
-include/google/protobuf/compiler/plugin.proto
-include/google/protobuf/compiler/python/python_generator.h
-include/google/protobuf/descriptor.h
-include/google/protobuf/descriptor.pb.h
-include/google/protobuf/descriptor.proto
-include/google/protobuf/descriptor_database.h
-include/google/protobuf/dynamic_message.h
-include/google/protobuf/extension_set.h
-include/google/protobuf/generated_enum_reflection.h
-include/google/protobuf/generated_message_reflection.h
-include/google/protobuf/generated_message_util.h
-include/google/protobuf/io/coded_stream.h
-include/google/protobuf/io/gzip_stream.h
-include/google/protobuf/io/printer.h
-include/google/protobuf/io/tokenizer.h
-include/google/protobuf/io/zero_copy_stream.h
-include/google/protobuf/io/zero_copy_stream_impl.h
-include/google/protobuf/io/zero_copy_stream_impl_lite.h
-include/google/protobuf/message.h
-include/google/protobuf/message_lite.h
-include/google/protobuf/reflection_ops.h
-include/google/protobuf/repeated_field.h
-include/google/protobuf/service.h
-include/google/protobuf/stubs/atomicops.h
-include/google/protobuf/stubs/atomicops_internals_arm_gcc.h
-include/google/protobuf/stubs/atomicops_internals_arm_qnx.h
-include/google/protobuf/stubs/atomicops_internals_atomicword_compat.h
-include/google/protobuf/stubs/atomicops_internals_macosx.h
-include/google/protobuf/stubs/atomicops_internals_mips_gcc.h
-include/google/protobuf/stubs/atomicops_internals_pnacl.h
-include/google/protobuf/stubs/atomicops_internals_x86_gcc.h
-include/google/protobuf/stubs/atomicops_internals_x86_msvc.h
-include/google/protobuf/stubs/common.h
-include/google/protobuf/stubs/once.h
-include/google/protobuf/stubs/platform_macros.h
-include/google/protobuf/stubs/template_util.h
-include/google/protobuf/stubs/type_traits.h
-include/google/protobuf/text_format.h
-include/google/protobuf/unknown_field_set.h
-include/google/protobuf/wire_format.h
-include/google/protobuf/wire_format_lite.h
-include/google/protobuf/wire_format_lite_inl.h
-lib/libprotobuf-lite.a
-lib/libprotobuf-lite.so
-lib/libprotobuf-lite.so.8
-lib/libprotobuf-lite.so.8.0.0
-lib/libprotobuf.a
-lib/libprotobuf.so
-lib/libprotobuf.so.8
-lib/libprotobuf.so.8.0.0
-lib/libprotoc.a
-lib/libprotoc.so
-lib/libprotoc.so.8
-lib/libprotoc.so.8.0.0
-libdata/pkgconfig/protobuf-lite.pc
-libdata/pkgconfig/protobuf.pc
+protobuf25/bin/protoc
+protobuf25/include/google/protobuf/compiler/code_generator.h
+protobuf25/include/google/protobuf/compiler/command_line_interface.h
+protobuf25/include/google/protobuf/compiler/cpp/cpp_generator.h
+protobuf25/include/google/protobuf/compiler/importer.h
+protobuf25/include/google/protobuf/compiler/java/java_generator.h
+protobuf25/include/google/protobuf/compiler/parser.h
+protobuf25/include/google/protobuf/compiler/plugin.h
+protobuf25/include/google/protobuf/compiler/plugin.pb.h
+protobuf25/include/google/protobuf/compiler/plugin.proto
+protobuf25/include/google/protobuf/compiler/python/python_generator.h
+protobuf25/include/google/protobuf/descriptor.h
+protobuf25/include/google/protobuf/descriptor.pb.h
+protobuf25/include/google/protobuf/descriptor.proto
+protobuf25/include/google/protobuf/descriptor_database.h
+protobuf25/include/google/protobuf/dynamic_message.h
+protobuf25/include/google/protobuf/extension_set.h
+protobuf25/include/google/protobuf/generated_enum_reflection.h
+protobuf25/include/google/protobuf/generated_message_reflection.h
+protobuf25/include/google/protobuf/generated_message_util.h
+protobuf25/include/google/protobuf/io/coded_stream.h
+protobuf25/include/google/protobuf/io/gzip_stream.h
+protobuf25/include/google/protobuf/io/printer.h
+protobuf25/include/google/protobuf/io/tokenizer.h
+protobuf25/include/google/protobuf/io/zero_copy_stream.h
+protobuf25/include/google/protobuf/io/zero_copy_stream_impl.h
+protobuf25/include/google/protobuf/io/zero_copy_stream_impl_lite.h
+protobuf25/include/google/protobuf/message.h
+protobuf25/include/google/protobuf/message_lite.h
+protobuf25/include/google/protobuf/reflection_ops.h
+protobuf25/include/google/protobuf/repeated_field.h
+protobuf25/include/google/protobuf/service.h
+protobuf25/include/google/protobuf/stubs/atomicops.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_arm_gcc.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_arm_qnx.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_atomicword_compat.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_macosx.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_mips_gcc.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_pnacl.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_x86_gcc.h
+protobuf25/include/google/protobuf/stubs/atomicops_internals_x86_msvc.h
+protobuf25/include/google/protobuf/stubs/common.h
+protobuf25/include/google/protobuf/stubs/once.h
+protobuf25/include/google/protobuf/stubs/platform_macros.h
+protobuf25/include/google/protobuf/stubs/template_util.h
+protobuf25/include/google/protobuf/stubs/type_traits.h
+protobuf25/include/google/protobuf/text_format.h
+protobuf25/include/google/protobuf/unknown_field_set.h
+protobuf25/include/google/protobuf/wire_format.h
+protobuf25/include/google/protobuf/wire_format_lite.h
+protobuf25/include/google/protobuf/wire_format_lite_inl.h
+protobuf25/lib/libprotobuf-lite.a
+protobuf25/lib/libprotobuf-lite.so
+protobuf25/lib/libprotobuf-lite.so.8
+protobuf25/lib/libprotobuf-lite.so.8.0.0
+protobuf25/lib/libprotobuf.a
+protobuf25/lib/libprotobuf.so
+protobuf25/lib/libprotobuf.so.8
+protobuf25/lib/libprotobuf.so.8.0.0
+protobuf25/lib/libprotoc.a
+protobuf25/lib/libprotoc.so
+protobuf25/lib/libprotoc.so.8
+protobuf25/lib/libprotoc.so.8.0.0
+protobuf25/libdata/pkgconfig/protobuf-lite.pc
+protobuf25/libdata/pkgconfig/protobuf.pc