aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-09-22 15:04:24 +0800
committerwen <wen@FreeBSD.org>2011-09-22 15:04:24 +0800
commitd3403a832b21cc8f34036ac48e7c8b2bf534f845 (patch)
treeb1a54812278a9b3b82df18da5fc0f556a1d84c3b /devel
parent24a0a92a9f3352c70b44ddb6a0d32dc3091a8ea2 (diff)
downloadfreebsd-ports-gnome-d3403a832b21cc8f34036ac48e7c8b2bf534f845.tar.gz
freebsd-ports-gnome-d3403a832b21cc8f34036ac48e7c8b2bf534f845.tar.zst
freebsd-ports-gnome-d3403a832b21cc8f34036ac48e7c8b2bf534f845.zip
This library implements the JSON-RPC 2.0 proposed specification in pure Python.
It is designed to be as compatible with the syntax of xmlrpclib as possible (it extends where possible), so that projects using xmlrpclib could easily be modified to use JSON and experiment with the differences. It is backwards-compatible with the 1.0 specification, and supports all of the new proposed features of 2.0, including: * Batch submission (via MultiCall) * Keyword arguments * Notifications (both in a batch and 'normal') * Class translation using the 'jsonclass' key. WWW: https://github.com/joshmarshall/jsonrpclib PR: ports/160869 Submitted by: Attila Nagy <bra@fsn.hu>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jsonrpclib/Makefile22
-rw-r--r--devel/py-jsonrpclib/distinfo2
-rw-r--r--devel/py-jsonrpclib/pkg-descr13
-rw-r--r--devel/py-jsonrpclib/pkg-plist20
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5ecf312d4d28..faa5afa25577 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3003,6 +3003,7 @@
SUBDIR += py-json-py
SUBDIR += py-jsonlib
SUBDIR += py-jsonlib2
+ SUBDIR += py-jsonrpclib
SUBDIR += py-kid
SUBDIR += py-kjbuckets
SUBDIR += py-kqueue
diff --git a/devel/py-jsonrpclib/Makefile b/devel/py-jsonrpclib/Makefile
new file mode 100644
index 000000000000..128c1b4ea81a
--- /dev/null
+++ b/devel/py-jsonrpclib/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-jsonrpclib
+# Date created: 09. 21. 2011
+# Whom: Attila Nagy <bra@fsn.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jsonrpclib
+PORTVERSION= 0.1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bra@fsn.hu
+COMMENT= Implements the JSON-RPC 2.0 proposed specification in pure Python
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cjson.so:${PORTSDIR}/devel/py-cjson
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jsonrpclib/distinfo b/devel/py-jsonrpclib/distinfo
new file mode 100644
index 000000000000..45858d391e02
--- /dev/null
+++ b/devel/py-jsonrpclib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jsonrpclib-0.1.3.tar.gz) = a594e702c35408ae5540086ab5bdea284fb27d09520898c381c5bbdbfceffbba
+SIZE (jsonrpclib-0.1.3.tar.gz) = 12468
diff --git a/devel/py-jsonrpclib/pkg-descr b/devel/py-jsonrpclib/pkg-descr
new file mode 100644
index 000000000000..afdaf4cda1d5
--- /dev/null
+++ b/devel/py-jsonrpclib/pkg-descr
@@ -0,0 +1,13 @@
+This library implements the JSON-RPC 2.0 proposed specification in pure Python.
+It is designed to be as compatible with the syntax of xmlrpclib as possible (it
+extends where possible), so that projects using xmlrpclib could easily be
+modified to use JSON and experiment with the differences.
+
+It is backwards-compatible with the 1.0 specification, and supports all of the
+new proposed features of 2.0, including:
+ * Batch submission (via MultiCall)
+ * Keyword arguments
+ * Notifications (both in a batch and 'normal')
+ * Class translation using the 'jsonclass' key.
+
+WWW: https://github.com/joshmarshall/jsonrpclib
diff --git a/devel/py-jsonrpclib/pkg-plist b/devel/py-jsonrpclib/pkg-plist
new file mode 100644
index 000000000000..4c1042464d08
--- /dev/null
+++ b/devel/py-jsonrpclib/pkg-plist
@@ -0,0 +1,20 @@
+%%PYTHON_SITELIBDIR%%/jsonrpclib/SimpleJSONRPCServer.py
+%%PYTHON_SITELIBDIR%%/jsonrpclib/SimpleJSONRPCServer.pyc
+%%PYTHON_SITELIBDIR%%/jsonrpclib/SimpleJSONRPCServer.pyo
+%%PYTHON_SITELIBDIR%%/jsonrpclib/__init__.py
+%%PYTHON_SITELIBDIR%%/jsonrpclib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/jsonrpclib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/jsonrpclib/config.py
+%%PYTHON_SITELIBDIR%%/jsonrpclib/config.pyc
+%%PYTHON_SITELIBDIR%%/jsonrpclib/config.pyo
+%%PYTHON_SITELIBDIR%%/jsonrpclib/history.py
+%%PYTHON_SITELIBDIR%%/jsonrpclib/history.pyc
+%%PYTHON_SITELIBDIR%%/jsonrpclib/history.pyo
+%%PYTHON_SITELIBDIR%%/jsonrpclib/jsonclass.py
+%%PYTHON_SITELIBDIR%%/jsonrpclib/jsonclass.pyc
+%%PYTHON_SITELIBDIR%%/jsonrpclib/jsonclass.pyo
+%%PYTHON_SITELIBDIR%%/jsonrpclib/jsonrpc.py
+%%PYTHON_SITELIBDIR%%/jsonrpclib/jsonrpc.pyc
+%%PYTHON_SITELIBDIR%%/jsonrpclib/jsonrpc.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/jsonrpclib
+@dirrmtry %%PYTHON_SITELIBDIR%%