aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2015-07-01 16:07:49 +0800
committerxmj <xmj@FreeBSD.org>2015-07-01 16:07:49 +0800
commitd3f39174a448aa06789d4a2de92996e467243694 (patch)
treef8b9ae7b35871e6020588193d70090f38b56c77b /devel
parent0fbdf8fd3318c8cb1f89c7bdafa84507e857d2bf (diff)
downloadfreebsd-ports-gnome-d3f39174a448aa06789d4a2de92996e467243694.tar.gz
freebsd-ports-gnome-d3f39174a448aa06789d4a2de92996e467243694.tar.zst
freebsd-ports-gnome-d3f39174a448aa06789d4a2de92996e467243694.zip
devel/py-python-pcre: add port.
A Python PCRE library WWW: https://github.com/awahlig/python-pcre PR: 196947 Differential Revision: https://reviews.freebsd.org/D1596 Submitted by: Maxim Filimonov <che@bein.link> Reviewed by: koobs, swills (while still in mentorship)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-python-pcre/Makefile24
-rw-r--r--devel/py-python-pcre/distinfo2
-rw-r--r--devel/py-python-pcre/files/patch-setup.py11
-rw-r--r--devel/py-python-pcre/pkg-descr3
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 99551eaea5a5..8538d9e6e0f8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4085,6 +4085,7 @@
SUBDIR += py-pytest-xdist
SUBDIR += py-python-bugzilla
SUBDIR += py-python-jenkins
+ SUBDIR += py-python-pcre
SUBDIR += py-python-statsd
SUBDIR += py-python2-pythondialog
SUBDIR += py-pythonbrew
diff --git a/devel/py-python-pcre/Makefile b/devel/py-python-pcre/Makefile
new file mode 100644
index 000000000000..59acafafe84a
--- /dev/null
+++ b/devel/py-python-pcre/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= python-pcre
+PORTVERSION= 0.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= che@bein.link
+COMMENT= Python PCRE bindings
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= pcre>=6.0:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+
+USES= python:2
+USE_PYTHON= autoplist distutils
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/devel/py-python-pcre/distinfo b/devel/py-python-pcre/distinfo
new file mode 100644
index 000000000000..ff31b53325b6
--- /dev/null
+++ b/devel/py-python-pcre/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-pcre-0.6.tar.gz) = 7fed1460f844075a7b2fe22f728b4645a4440e55ad4337c9efc057b7f5ae1ccc
+SIZE (python-pcre-0.6.tar.gz) = 52690
diff --git a/devel/py-python-pcre/files/patch-setup.py b/devel/py-python-pcre/files/patch-setup.py
new file mode 100644
index 000000000000..e678a0114e7f
--- /dev/null
+++ b/devel/py-python-pcre/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2014-08-17 09:21:38 UTC
++++ setup.py
+@@ -33,6 +33,8 @@ from distutils.core import setup, Extens
+
+ _pcre = Extension('_pcre', ['src/pcremodule.c'],
+ libraries=['pcre'],
++ include_dirs=['%%LOCALBASE%%/include'],
++ library_dirs=['%%LOCALBASE%%/lib'],
+ extra_compile_args=['-fno-strict-aliasing'])
+
+
diff --git a/devel/py-python-pcre/pkg-descr b/devel/py-python-pcre/pkg-descr
new file mode 100644
index 000000000000..69335d7ceb75
--- /dev/null
+++ b/devel/py-python-pcre/pkg-descr
@@ -0,0 +1,3 @@
+A Python PCRE library
+
+WWW: https://github.com/awahlig/python-pcre