aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2016-09-16 00:26:00 +0800
committergblach <gblach@FreeBSD.org>2016-09-16 00:26:00 +0800
commitd4dccc244a87fdc2038e1a517728d73e023a265c (patch)
treecf25514fa87bcdca3b103ecc77b49f03701d7864 /devel
parent68a23f06f9d54f197ea58505bc7a9cbbc4ebda75 (diff)
downloadfreebsd-ports-gnome-d4dccc244a87fdc2038e1a517728d73e023a265c.tar.gz
freebsd-ports-gnome-d4dccc244a87fdc2038e1a517728d73e023a265c.tar.zst
freebsd-ports-gnome-d4dccc244a87fdc2038e1a517728d73e023a265c.zip
- Switch GH_ACCOUNT to ninja-build
- Use python also at runtime (needed by 'browse' tool) - Add do-test section - Change WWW to https://ninja-build.org/ - Bump PORTREVISION PR: 212701 Submitted by: gahr
Diffstat (limited to 'devel')
-rw-r--r--devel/ninja/Makefile8
-rw-r--r--devel/ninja/distinfo5
-rw-r--r--devel/ninja/pkg-descr2
3 files changed, 10 insertions, 5 deletions
diff --git a/devel/ninja/Makefile b/devel/ninja/Makefile
index 05bc5c73b79f..e96abc7013ae 100644
--- a/devel/ninja/Makefile
+++ b/devel/ninja/Makefile
@@ -4,6 +4,7 @@
PORTNAME= ninja
PORTVERSION= 1.7.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= devel
@@ -14,10 +15,10 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
-GH_ACCOUNT= martine
+GH_ACCOUNT= ninja-build
CONFLICTS= irc/ninja-[0-9]*
-USES= python:build
+USES= python
PLIST_FILES= bin/ninja
PORTDOCS= HACKING.md README manual.asciidoc
@@ -38,4 +39,7 @@ do-install:
${INSTALL_DATA} HACKING.md README doc/manual.asciidoc \
${STAGEDIR}${DOCSDIR})
+do-test: build
+ cd ${WRKSRC} && ./ninja ninja_test && ./ninja_test
+
.include <bsd.port.mk>
diff --git a/devel/ninja/distinfo b/devel/ninja/distinfo
index 7117e27fa70d..671430146492 100644
--- a/devel/ninja/distinfo
+++ b/devel/ninja/distinfo
@@ -1,2 +1,3 @@
-SHA256 (martine-ninja-v1.7.1_GH0.tar.gz) = 51581de53cf4705b89eb6b14a85baa73288ad08bff256e7d30d529155813be19
-SIZE (martine-ninja-v1.7.1_GH0.tar.gz) = 179717
+TIMESTAMP = 1473955296
+SHA256 (ninja-build-ninja-v1.7.1_GH0.tar.gz) = 51581de53cf4705b89eb6b14a85baa73288ad08bff256e7d30d529155813be19
+SIZE (ninja-build-ninja-v1.7.1_GH0.tar.gz) = 179717
diff --git a/devel/ninja/pkg-descr b/devel/ninja/pkg-descr
index 63724b70b8ae..51768dcaa7a0 100644
--- a/devel/ninja/pkg-descr
+++ b/devel/ninja/pkg-descr
@@ -8,4 +8,4 @@ over 30,000 source files and whose other build systems (including one built
from custom non-recursive Makefiles) can take ten seconds to start building
after changing one file. Ninja is under a second.
-WWW: https://github.com/martine/ninja
+WWW: https://ninja-build.org/