aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2015-08-07 20:08:23 +0800
committerrobak <robak@FreeBSD.org>2015-08-07 20:08:23 +0800
commitd85d8e31153a9eb6f2ac5e4df077d13835998cb9 (patch)
tree84c40ac11387dbdf6a69e642dbdc1d1a32df3dc9 /devel
parent38d2f168ce694b50454c27e5fe7417235a269628 (diff)
downloadfreebsd-ports-gnome-d85d8e31153a9eb6f2ac5e4df077d13835998cb9.tar.gz
freebsd-ports-gnome-d85d8e31153a9eb6f2ac5e4df077d13835998cb9.tar.zst
freebsd-ports-gnome-d85d8e31153a9eb6f2ac5e4df077d13835998cb9.zip
devel/ocaml-opam: fix _DEPENDS declaration
- Move RUN_DEPENDS to proper place in Makefile Submitted by: mat Approved by: portmgr (blanket)
Diffstat (limited to 'devel')
-rw-r--r--devel/ocaml-opam/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/devel/ocaml-opam/Makefile b/devel/ocaml-opam/Makefile
index a050231c9e94..1d1bb293879b 100644
--- a/devel/ocaml-opam/Makefile
+++ b/devel/ocaml-opam/Makefile
@@ -16,6 +16,8 @@ COMMENT= Source-based package manager for OCaml
LICENSE= GPLv3
+RUN_DEPENDS= camlp4:${PORTSDIR}/devel/ocaml-camlp4
+
USES= gmake
USE_OCAML= yes
GNU_CONFIGURE= yes
@@ -32,14 +34,12 @@ HG_DESC= Remote repository synchronized with mercurial
DARCS_DESC= Remote repository synchronized with darcs
ASPCUD_DESC= Use aspcud as an external dependencies solver
-WGET_RUN_DEPENDS:= wget:${PORTSDIR}/ftp/wget
-RSYNC_RUN_DEPENDS:= rsync:${PORTSDIR}/net/rsync
-GIT_RUN_DEPENDS:= git:${PORTSDIR}/devel/git
-HG_RUN_DEPENDS:= hg:${PORTSDIR}/devel/mercurial
-DARCS_RUN_DEPENDS:= darcs:${PORTSDIR}/devel/hs-darcs
-ASPCUD_RUN_DEPENDS:= aspcud:${PORTSDIR}/math/aspcud
-
-RUN_DEPENDS:= camlp4:${PORTSDIR}/devel/ocaml-camlp4
+WGET_RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+RSYNC_RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+GIT_RUN_DEPENDS= git:${PORTSDIR}/devel/git
+HG_RUN_DEPENDS= hg:${PORTSDIR}/devel/mercurial
+DARCS_RUN_DEPENDS= darcs:${PORTSDIR}/devel/hs-darcs
+ASPCUD_RUN_DEPENDS= aspcud:${PORTSDIR}/math/aspcud
MAKE_JOBS_UNSAFE= yes