aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-11-02 11:17:33 +0800
committerijliao <ijliao@FreeBSD.org>2001-11-02 11:17:33 +0800
commitd93ad43b4b7c2aac62d296aef029764c9a5e4ef8 (patch)
tree091ff657c1801e3a84e13ecfa013c84920d41ac3 /devel
parent4d44f76d206d5c675ad6f4b352bf0947aae492d3 (diff)
downloadfreebsd-ports-gnome-d93ad43b4b7c2aac62d296aef029764c9a5e4ef8.tar.gz
freebsd-ports-gnome-d93ad43b4b7c2aac62d296aef029764c9a5e4ef8.tar.zst
freebsd-ports-gnome-d93ad43b4b7c2aac62d296aef029764c9a5e4ef8.zip
add py-ansistyle
Add ANSI color capability to output streams
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ansistyle/Makefile28
-rw-r--r--devel/py-ansistyle/distinfo1
-rw-r--r--devel/py-ansistyle/pkg-comment1
-rw-r--r--devel/py-ansistyle/pkg-descr3
-rw-r--r--devel/py-ansistyle/pkg-plist3
6 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9ba35888c0ef..780f40454d8b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -460,6 +460,7 @@
SUBDIR += pth
SUBDIR += pth-devel
SUBDIR += ptl
+ SUBDIR += py-ansistyle
SUBDIR += py-coro
SUBDIR += py-cxx
SUBDIR += py-game
diff --git a/devel/py-ansistyle/Makefile b/devel/py-ansistyle/Makefile
new file mode 100644
index 000000000000..07da300c7a63
--- /dev/null
+++ b/devel/py-ansistyle/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: py-ansistyle
+# Date created: Nov 2, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ansistyle
+PORTVERSION= 0.2.1
+CATEGORIES= devel python
+MASTER_SITES= ftp://ftp.livinglogic.de/pub/livinglogic/ansistyle/
+PKGNAMEPREFIX= py-
+DISTNAME= ANSIStyle-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>
diff --git a/devel/py-ansistyle/distinfo b/devel/py-ansistyle/distinfo
new file mode 100644
index 000000000000..ac92a0a56d9c
--- /dev/null
+++ b/devel/py-ansistyle/distinfo
@@ -0,0 +1 @@
+MD5 (ANSIStyle-0.2.1.tar.gz) = 3205b5ad620d63e57b05053cdb055d89
diff --git a/devel/py-ansistyle/pkg-comment b/devel/py-ansistyle/pkg-comment
new file mode 100644
index 000000000000..439453c25864
--- /dev/null
+++ b/devel/py-ansistyle/pkg-comment
@@ -0,0 +1 @@
+Add ANSI color capability to output streams
diff --git a/devel/py-ansistyle/pkg-descr b/devel/py-ansistyle/pkg-descr
new file mode 100644
index 000000000000..d105c35de9ec
--- /dev/null
+++ b/devel/py-ansistyle/pkg-descr
@@ -0,0 +1,3 @@
+ANSIStyle is a module that adds ANSI color capability to an output stream.
+
+WWW: http://www.livinglogic.de/Python/ansistyle/
diff --git a/devel/py-ansistyle/pkg-plist b/devel/py-ansistyle/pkg-plist
new file mode 100644
index 000000000000..0ca5b4a5e97a
--- /dev/null
+++ b/devel/py-ansistyle/pkg-plist
@@ -0,0 +1,3 @@
+lib/%%PYTHON_VERSION%%/site-packages/_ansistyle.so
+lib/%%PYTHON_VERSION%%/site-packages/ansistyle.py
+lib/%%PYTHON_VERSION%%/site-packages/ansistyle.pyc