aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-09-08 09:17:37 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-09-08 09:17:37 +0800
commitd95cb4732cc2e7f12ac59188dad09d797924faa1 (patch)
tree92fd647dd05bc9a6b342a7af2fe423330927540c /devel
parent72caa64511ce47873454f895545757f36428c673 (diff)
downloadfreebsd-ports-gnome-d95cb4732cc2e7f12ac59188dad09d797924faa1.tar.gz
freebsd-ports-gnome-d95cb4732cc2e7f12ac59188dad09d797924faa1.tar.zst
freebsd-ports-gnome-d95cb4732cc2e7f12ac59188dad09d797924faa1.zip
Test::Requires checks to see if the module can be loaded.
If this fails rather than failing tests this skips all tests. WWW: http://search.cpan.org/dist/Test-Requires/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Requires/Makefile21
-rw-r--r--devel/p5-Test-Requires/distinfo3
-rw-r--r--devel/p5-Test-Requires/pkg-descr5
-rw-r--r--devel/p5-Test-Requires/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4f05a77ef974..0993e53e8c49 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1972,6 +1972,7 @@
SUBDIR += p5-Test-Portability-Files
SUBDIR += p5-Test-RandomResults
SUBDIR += p5-Test-Reporter
+ SUBDIR += p5-Test-Requires
SUBDIR += p5-Test-Script
SUBDIR += p5-Test-SharedFork
SUBDIR += p5-Test-Simple
diff --git a/devel/p5-Test-Requires/Makefile b/devel/p5-Test-Requires/Makefile
new file mode 100644
index 000000000000..5ea678582bb6
--- /dev/null
+++ b/devel/p5-Test-Requires/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: Test::Requires
+# Date created: 08 Sep 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Requires
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for checking to see if the module can be loaded
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Requires.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Requires/distinfo b/devel/p5-Test-Requires/distinfo
new file mode 100644
index 000000000000..a5a8a4b428bf
--- /dev/null
+++ b/devel/p5-Test-Requires/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Requires-0.01.tar.gz) = 8a566fe04aaf9d153a09a35a89a378af
+SHA256 (Test-Requires-0.01.tar.gz) = b8f45193fd8f8c54c586a9cd55997456ffa5e97bf89d4e835abbb3ca42345d47
+SIZE (Test-Requires-0.01.tar.gz) = 40997
diff --git a/devel/p5-Test-Requires/pkg-descr b/devel/p5-Test-Requires/pkg-descr
new file mode 100644
index 000000000000..2bbdce33285c
--- /dev/null
+++ b/devel/p5-Test-Requires/pkg-descr
@@ -0,0 +1,5 @@
+Test::Requires checks to see if the module can be loaded.
+
+If this fails rather than failing tests this skips all tests.
+
+WWW: http://search.cpan.org/dist/Test-Requires/
diff --git a/devel/p5-Test-Requires/pkg-plist b/devel/p5-Test-Requires/pkg-plist
new file mode 100644
index 000000000000..05621859c5ac
--- /dev/null
+++ b/devel/p5-Test-Requires/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Requires/.packlist
+%%SITE_PERL%%/Test/Requires.pm
+@dirrmtry %%SITE_PERL%%/Test
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Requires
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test