aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-11-18 18:40:18 +0800
committermiwi <miwi@FreeBSD.org>2009-11-18 18:40:18 +0800
commitdbd258139412c0d23b08c629596ce61a3d809f50 (patch)
tree8f5d3320931cd01a02c1c3c85b86e39f1b737403 /devel
parentc132e05a0dd60e9a223f71a5ac7296f33537f72c (diff)
downloadfreebsd-ports-gnome-dbd258139412c0d23b08c629596ce61a3d809f50.tar.gz
freebsd-ports-gnome-dbd258139412c0d23b08c629596ce61a3d809f50.tar.zst
freebsd-ports-gnome-dbd258139412c0d23b08c629596ce61a3d809f50.zip
Time::Format provides a very easy way to format dates and times. The
formatting functions are tied to hash variables, so they can be used inside strings as well as in ordinary expressions. The formatting codes used are meant to be easy to remember, use, and read. They follow a simple, consistent pattern. If I've done my job right, once you learn the codes, you should never have to refer to the documentation again. A quick-reference page is included, just in case. ;-) Time::Format can also format DateTime objects, and strings created with Date::Manip. Also provided is a tied-hash interface to POSIX::strftime and Date::Manip::UnixDate. If the I18N::Langinfo module is available, Time::Format provides weekday and month names in a language appropriate for your locale. A companion module, Time::Format_XS, is also available; if it is installed, Time::Format will detect and use it, which will result in a significant speed improvement. WWW: http://search.cpan.org/dist/Time-Format/ PR: ports/140659 Submitted by: Sergey V. Dyatko <Sergey.Dyatko at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Time-Format/Makefile21
-rw-r--r--devel/p5-Time-Format/distinfo3
-rw-r--r--devel/p5-Time-Format/pkg-descr23
-rw-r--r--devel/p5-Time-Format/pkg-plist5
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dd0ad12b53b9..ae64ebd27f55 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2070,6 +2070,7 @@
SUBDIR += p5-Time-Clock
SUBDIR += p5-Time-Duration
SUBDIR += p5-Time-Duration-Parse
+ SUBDIR += p5-Time-Format
SUBDIR += p5-Time-HiRes
SUBDIR += p5-Time-Interval
SUBDIR += p5-Time-Local
diff --git a/devel/p5-Time-Format/Makefile b/devel/p5-Time-Format/Makefile
new file mode 100644
index 000000000000..07614dba579e
--- /dev/null
+++ b/devel/p5-Time-Format/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: devel/p5-Time-Format
+# Date created: 18 November 2009
+# Whom: Sergey V. Dyatko <Sergey.Dyatko@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Time-Format
+PORTVERSION= 1.11
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= Sergey.Dyatko@gmail.com
+COMMENT= Easy-to-use date/time formatting.
+
+PERL_CONFIGURE= yes
+
+MAN3= Time::Format.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Time-Format/distinfo b/devel/p5-Time-Format/distinfo
new file mode 100644
index 000000000000..10ff4869ff3c
--- /dev/null
+++ b/devel/p5-Time-Format/distinfo
@@ -0,0 +1,3 @@
+MD5 (Time-Format-1.11.tar.gz) = 20b6f13b67c6840a0527a6597c9861b2
+SHA256 (Time-Format-1.11.tar.gz) = fb3a39e8cf8fd8f47462b4fc2f99dbacc51896bc4b7c46fcb80f71b780e9bd09
+SIZE (Time-Format-1.11.tar.gz) = 30330
diff --git a/devel/p5-Time-Format/pkg-descr b/devel/p5-Time-Format/pkg-descr
new file mode 100644
index 000000000000..048b43312431
--- /dev/null
+++ b/devel/p5-Time-Format/pkg-descr
@@ -0,0 +1,23 @@
+Time::Format provides a very easy way to format dates and times. The
+formatting functions are tied to hash variables, so they can be used
+inside strings as well as in ordinary expressions. The formatting
+codes used are meant to be easy to remember, use, and read. They
+follow a simple, consistent pattern. If I've done my job right, once
+you learn the codes, you should never have to refer to the
+documentation again.
+A quick-reference page is included, just in case. ;-)
+
+Time::Format can also format DateTime objects, and strings created
+with Date::Manip.
+
+Also provided is a tied-hash interface to POSIX::strftime and
+Date::Manip::UnixDate.
+
+If the I18N::Langinfo module is available, Time::Format provides
+weekday and month names in a language appropriate for your locale.
+
+A companion module, Time::Format_XS, is also available; if it is
+installed, Time::Format will detect and use it, which will result in a
+significant speed improvement.
+
+WWW: http://search.cpan.org/dist/Time-Format/
diff --git a/devel/p5-Time-Format/pkg-plist b/devel/p5-Time-Format/pkg-plist
new file mode 100644
index 000000000000..22f0c16e51ba
--- /dev/null
+++ b/devel/p5-Time-Format/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Time/Format.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Format/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Format
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time
+@dirrmtry %%SITE_PERL%%/Time