aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-04-11 20:01:24 +0800
committergarga <garga@FreeBSD.org>2006-04-11 20:01:24 +0800
commitde608f2a76f41e8e4f8148903d97c4426df9ff9a (patch)
treee2842a9c19298832973759ea56f4995dc9eadd9e /devel
parent1d51c322cb5e708c67d5419f4eda0798dd4d475c (diff)
downloadfreebsd-ports-gnome-de608f2a76f41e8e4f8148903d97c4426df9ff9a.tar.gz
freebsd-ports-gnome-de608f2a76f41e8e4f8148903d97c4426df9ff9a.tar.zst
freebsd-ports-gnome-de608f2a76f41e8e4f8148903d97c4426df9ff9a.zip
A small utility package that depends on tools too recent for Twisted (like
datetime in python2.4) but performs generic enough functions that it can be used in projects that don't want to share Divmod's other projects' large footprint. Currently included: * A powerful date/time formatting and import/export class (ExtimeDotTime), for exchanging date and time information between all Python's various ways to interpret objects as times or time deltas. * Tools for managing concurrent asynchronous processes within Twisted. * A metaclass which helps you define classes with explicit states. * A featureful Version class. * A formal system for application of monkey-patches. WWW: http://divmod.org/trac/wiki/DivmodEpsilon PR: ports/95611 Submitted by: Alexander Botero-Lowry <alex@foxybanana.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-epsilon/Makefile24
-rw-r--r--devel/py-epsilon/distinfo3
-rw-r--r--devel/py-epsilon/pkg-descr16
-rw-r--r--devel/py-epsilon/pkg-plist57
5 files changed, 101 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b6e439a3ef46..73b4fcae435a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1434,6 +1434,7 @@
SUBDIR += py-dbus
SUBDIR += py-dialog
SUBDIR += py-elementtree
+ SUBDIR += py-epsilon
SUBDIR += py-fam
SUBDIR += py-fileutils
SUBDIR += py-fortran
diff --git a/devel/py-epsilon/Makefile b/devel/py-epsilon/Makefile
new file mode 100644
index 000000000000..2cd4935135fb
--- /dev/null
+++ b/devel/py-epsilon/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-epsilon
+# Date created: 10 Apr 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= epsilon
+PORTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= http://divmod.org/trac/attachment/wiki/SoftwareReleases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Epsilon-${PORTVERSION}
+EXTRACT_SUFX= .tar.gz?format=raw
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Epsilon is a set of Python utility modules used by DivMod projects
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_TWISTED= yes
+NO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-epsilon/distinfo b/devel/py-epsilon/distinfo
new file mode 100644
index 000000000000..3c62ccf98e45
--- /dev/null
+++ b/devel/py-epsilon/distinfo
@@ -0,0 +1,3 @@
+MD5 (Epsilon-0.4.0.tar.gz?format=raw) = f5fade1ca2cfa99cdc530ffd342967a0
+SHA256 (Epsilon-0.4.0.tar.gz?format=raw) = d6bbff9f15137417fe0b17b0382e9f7ed501ec9e9480e0c8c9262dfb60b25b2d
+SIZE (Epsilon-0.4.0.tar.gz?format=raw) = 27223
diff --git a/devel/py-epsilon/pkg-descr b/devel/py-epsilon/pkg-descr
new file mode 100644
index 000000000000..dcf777ca846e
--- /dev/null
+++ b/devel/py-epsilon/pkg-descr
@@ -0,0 +1,16 @@
+A small utility package that depends on tools too recent for Twisted (like
+datetime in python2.4) but performs generic enough functions that it can be
+used in projects that don't want to share Divmod's other projects' large
+footprint.
+
+Currently included:
+
+ * A powerful date/time formatting and import/export class (ExtimeDotTime),
+ for exchanging date and time information between all Python's various
+ ways to interpret objects as times or time deltas.
+ * Tools for managing concurrent asynchronous processes within Twisted.
+ * A metaclass which helps you define classes with explicit states.
+ * A featureful Version class.
+ * A formal system for application of monkey-patches.
+
+WWW: http://divmod.org/trac/wiki/DivmodEpsilon
diff --git a/devel/py-epsilon/pkg-plist b/devel/py-epsilon/pkg-plist
new file mode 100644
index 000000000000..d53cd414f5bb
--- /dev/null
+++ b/devel/py-epsilon/pkg-plist
@@ -0,0 +1,57 @@
+%%PYTHON_SITELIBDIR%%/epsilon/versions.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/versions.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/versions.py
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_versions.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_versions.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_versions.py
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_setuphelper.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_setuphelper.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_setuphelper.py
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_modes.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_modes.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_modes.py
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_extime.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_extime.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_extime.py
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_cooperator.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_cooperator.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/test/test_cooperator.py
+%%PYTHON_SITELIBDIR%%/epsilon/test/mantissa-structure.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/test/mantissa-structure.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/test/mantissa-structure.py
+%%PYTHON_SITELIBDIR%%/epsilon/test/__init__.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/test/__init__.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/test/__init__.py
+%%PYTHON_SITELIBDIR%%/epsilon/setuphelper.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/setuphelper.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/setuphelper.py
+%%PYTHON_SITELIBDIR%%/epsilon/pending.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/pending.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/pending.py
+%%PYTHON_SITELIBDIR%%/epsilon/modal.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/modal.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/modal.py
+%%PYTHON_SITELIBDIR%%/epsilon/hotfixes/filepath_copyTo.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/hotfixes/filepath_copyTo.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/hotfixes/filepath_copyTo.py
+%%PYTHON_SITELIBDIR%%/epsilon/hotfixes/__init__.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/hotfixes/__init__.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/hotfixes/__init__.py
+%%PYTHON_SITELIBDIR%%/epsilon/hotfix.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/hotfix.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/hotfix.py
+%%PYTHON_SITELIBDIR%%/epsilon/extime.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/extime.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/extime.py
+%%PYTHON_SITELIBDIR%%/epsilon/cooperator.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/cooperator.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/cooperator.py
+%%PYTHON_SITELIBDIR%%/epsilon/asplode.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/asplode.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/asplode.py
+%%PYTHON_SITELIBDIR%%/epsilon/__init__.pyo
+%%PYTHON_SITELIBDIR%%/epsilon/__init__.pyc
+%%PYTHON_SITELIBDIR%%/epsilon/__init__.py
+@dirrm %%PYTHON_SITELIBDIR%%/epsilon/test
+@dirrm %%PYTHON_SITELIBDIR%%/epsilon/hotfixes
+@dirrm %%PYTHON_SITELIBDIR%%/epsilon