aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-08-02 21:58:58 +0800
committermat <mat@FreeBSD.org>2004-08-02 21:58:58 +0800
commitdf3b9040d19a391e472e97729f9d622d4fc9a80f (patch)
tree8dd18219dd1db51efad16a96d9044b07ef5cdc66 /devel
parenta7127191adbd5dbc1feff0cfaf714ba58734dd1b (diff)
downloadfreebsd-ports-gnome-df3b9040d19a391e472e97729f9d622d4fc9a80f.tar.gz
freebsd-ports-gnome-df3b9040d19a391e472e97729f9d622d4fc9a80f.tar.zst
freebsd-ports-gnome-df3b9040d19a391e472e97729f9d622d4fc9a80f.zip
Add p5-Tree-Simple-View 0.09, a set of classes for viewing Tree::Simple
hierarchies. PR: ports/69882 Submitted by: Aaron Dalton <aaron@daltons.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tree-Simple-View/Makefile31
-rw-r--r--devel/p5-Tree-Simple-View/distinfo2
-rw-r--r--devel/p5-Tree-Simple-View/pkg-descr8
-rw-r--r--devel/p5-Tree-Simple-View/pkg-plist10
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a35e474280c0..307a1e86d859 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -989,6 +989,7 @@
SUBDIR += p5-TraceFuncs
SUBDIR += p5-Tree-DAG_Node
SUBDIR += p5-Tree-Simple
+ SUBDIR += p5-Tree-Simple-View
SUBDIR += p5-UNIVERSAL-exports
SUBDIR += p5-UNIVERSAL-moniker
SUBDIR += p5-Unix-Statgrab
diff --git a/devel/p5-Tree-Simple-View/Makefile b/devel/p5-Tree-Simple-View/Makefile
new file mode 100644
index 000000000000..7d96d3933b4c
--- /dev/null
+++ b/devel/p5-Tree-Simple-View/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Tree::Simple::View
+# Date created: 1 August 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tree-Simple-View
+PORTVERSION= 0.09
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tree
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= A set of classes for viewing Tree::Simple hierarchies
+
+BUILD_DEPENDS= ${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Tree::Simple::View.3 Tree::Simple::View::DHTML.3 Tree::Simple::View::HTML.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "This port requires perl 5.6 or above."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Tree-Simple-View/distinfo b/devel/p5-Tree-Simple-View/distinfo
new file mode 100644
index 000000000000..7aa356f297ed
--- /dev/null
+++ b/devel/p5-Tree-Simple-View/distinfo
@@ -0,0 +1,2 @@
+MD5 (Tree-Simple-View-0.09.tar.gz) = 5e506dec24ea1228d61e1157d1854820
+SIZE (Tree-Simple-View-0.09.tar.gz) = 17927
diff --git a/devel/p5-Tree-Simple-View/pkg-descr b/devel/p5-Tree-Simple-View/pkg-descr
new file mode 100644
index 000000000000..05decd78d3f7
--- /dev/null
+++ b/devel/p5-Tree-Simple-View/pkg-descr
@@ -0,0 +1,8 @@
+Tree::Simple::View - A set of classes for viewing Tree::Simple hierarchies
+
+WWW: http://search.cpan.org/dist/Tree-Simple-View/
+Author: Stevan Little <stevan@iinteractive.com>
+
+--
+Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Tree-Simple-View/pkg-plist b/devel/p5-Tree-Simple-View/pkg-plist
new file mode 100644
index 000000000000..0076da7df929
--- /dev/null
+++ b/devel/p5-Tree-Simple-View/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Tree/Simple/View.pm
+%%SITE_PERL%%/Tree/Simple/View/DHTML.pm
+%%SITE_PERL%%/Tree/Simple/View/HTML.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple/View/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple/View
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Tree/Simple/View
+@unexec rmdir %D/%%SITE_PERL%%/Tree/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Tree 2>/dev/null || true