aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-05-27 08:47:16 +0800
committerwen <wen@FreeBSD.org>2012-05-27 08:47:16 +0800
commitdfec7a3abba1dff21a3c3a5afac695d714c56b60 (patch)
treeaff28cd4b43a524bac2648a12329587c009ae88d /devel
parent01f647c3d454be00ca129f92836fecd80567c957 (diff)
downloadfreebsd-ports-gnome-dfec7a3abba1dff21a3c3a5afac695d714c56b60.tar.gz
freebsd-ports-gnome-dfec7a3abba1dff21a3c3a5afac695d714c56b60.tar.zst
freebsd-ports-gnome-dfec7a3abba1dff21a3c3a5afac695d714c56b60.zip
- Update to 2.3.1
PR: 166387 Submitted by: dikshie <dikshie@sfc.wide.ad.jp>
Diffstat (limited to 'devel')
-rw-r--r--devel/py-tables/Makefile6
-rw-r--r--devel/py-tables/distinfo8
-rw-r--r--devel/py-tables/files/patch-setup.py25
3 files changed, 20 insertions, 19 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index 105e63144bac..655e9b0cac6d 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -7,11 +7,9 @@
#
PORTNAME= tables
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.3.1
CATEGORIES= devel python
-MASTER_SITES= http://www.pytables.org/download/stable/ \
- http://www.pytables.org/download/py${PORTNAME}-${PORTVERSION}/
+MASTER_SITES= SF/py${PORTNAME:L}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= tables-${PORTVERSION}.tar.gz pytablesmanual-${PORTVERSION}.pdf
EXTRACT_ONLY= tables-${PORTVERSION}.tar.gz
diff --git a/devel/py-tables/distinfo b/devel/py-tables/distinfo
index e312aee87c1e..48675a4aa8f4 100644
--- a/devel/py-tables/distinfo
+++ b/devel/py-tables/distinfo
@@ -1,4 +1,4 @@
-SHA256 (tables-2.2.1.tar.gz) = 65dbdb7d3d6f37be01ebd9ececae8b165b60c4648381abef9d08d76c1a1a6cb1
-SIZE (tables-2.2.1.tar.gz) = 4985175
-SHA256 (pytablesmanual-2.2.1.pdf) = 91fe78b80f856fcc58f72ee798ba6e23276713c6dde0732b868d9f513f729e5b
-SIZE (pytablesmanual-2.2.1.pdf) = 1808008
+SHA256 (tables-2.3.1.tar.gz) = 3126151f909bcd22c5f2555b1727563f73d6402f3b1483ea8dbae5cc3e7da2a4
+SIZE (tables-2.3.1.tar.gz) = 8823365
+SHA256 (pytablesmanual-2.3.1.pdf) = 25eefac99cc712e1c0aac9d15376b7212266218c497646d046dd41afea6f633a
+SIZE (pytablesmanual-2.3.1.pdf) = 3019532
diff --git a/devel/py-tables/files/patch-setup.py b/devel/py-tables/files/patch-setup.py
index adcb2170851e..f0a7d6aa21ba 100644
--- a/devel/py-tables/files/patch-setup.py
+++ b/devel/py-tables/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2010-07-06 11:11:43.000000000 +0800
-+++ setup.py 2010-07-06 11:13:13.000000000 +0800
-@@ -83,8 +83,8 @@
+--- setup.py.orig 2012-03-25 19:20:35.000000000 +0900
++++ setup.py 2012-03-25 19:22:53.000000000 +0900
+@@ -96,8 +96,8 @@
debug = '--debug' in sys.argv
# Global variables
@@ -11,16 +11,19 @@
optional_libs = []
data_files = [] # list of data files to add to packages (mainly for DLL's)
-@@ -93,10 +93,10 @@
- default_runtime_dirs = None
-
- if os.name == 'posix':
-- default_header_dirs = ['/usr/include', '/usr/local/include']
+@@ -121,13 +121,12 @@
+ add_from_path("CPATH", default_header_dirs)
+ add_from_path("C_INCLUDE_PATH", default_header_dirs)
+ add_from_flags("CPPFLAGS", "-I", default_header_dirs)
+- default_header_dirs.extend(['/usr/include', '/usr/local/include'])
+-
+ default_header_dirs = ['/usr/include', '/usr/local/include','%%LOCALBASE%%/include']
- default_library_dirs = [
+ default_library_dirs = []
+ add_from_flags("LDFLAGS", "-L", default_library_dirs)
+ default_library_dirs.extend(
os.path.join(_tree, _arch)
- for _tree in ('/', '/usr', '/usr/local')
-+ for _tree in ('/', '/usr', '/usr/local','%%LOCALBASE%%')
- for _arch in ('lib64', 'lib') ]
++ for _tree in ('/', '/usr', '/usr/local','%%LOCALBASE%%')
+ for _arch in ('lib64', 'lib') )
default_runtime_dirs = default_library_dirs