aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-07 11:10:29 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-07 11:10:29 +0800
commite57fd81cc7065cc053fb1bde2222b2a12e882878 (patch)
tree85ebbe572c9ded38a3f33ad3fb4be50155204326 /devel
parent8abd56bd9d0ea9f0e12397a1f6b9c833d1a454ff (diff)
downloadfreebsd-ports-gnome-e57fd81cc7065cc053fb1bde2222b2a12e882878.tar.gz
freebsd-ports-gnome-e57fd81cc7065cc053fb1bde2222b2a12e882878.tar.zst
freebsd-ports-gnome-e57fd81cc7065cc053fb1bde2222b2a12e882878.zip
add p5-Config-Ini
Perl interface to MS-Windows registry and .ini files PR: 28240 Submitted by: Christopher Elkins <chrise@scardini.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-Ini/Makefile24
-rw-r--r--devel/p5-Config-Ini/distinfo1
-rw-r--r--devel/p5-Config-Ini/pkg-comment1
-rw-r--r--devel/p5-Config-Ini/pkg-descr4
-rw-r--r--devel/p5-Config-Ini/pkg-plist5
6 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1749c00aa632..d9d6bf3a8cfa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -294,6 +294,7 @@
SUBDIR += p5-Class-MethodMaker
SUBDIR += p5-Class-Singleton
SUBDIR += p5-Class-Tom
+ SUBDIR += p5-Config-Ini
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Config-Setting
SUBDIR += p5-ConfigReader
diff --git a/devel/p5-Config-Ini/Makefile b/devel/p5-Config-Ini/Makefile
new file mode 100644
index 000000000000..45cb4ba6b276
--- /dev/null
+++ b/devel/p5-Config-Ini/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Config-Ini
+# Date created: 17 June 2001
+# Whom: Christopher Elkins <chrise@scardini.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Ini
+PORTVERSION= 1.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash
+
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Config::Ini.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-Ini/distinfo b/devel/p5-Config-Ini/distinfo
new file mode 100644
index 000000000000..a820fe012658
--- /dev/null
+++ b/devel/p5-Config-Ini/distinfo
@@ -0,0 +1 @@
+MD5 (Config-Ini-1.07.tar.gz) = 10b46245ca1699b6c64b5ae87668ff12
diff --git a/devel/p5-Config-Ini/pkg-comment b/devel/p5-Config-Ini/pkg-comment
new file mode 100644
index 000000000000..ce8db9a62446
--- /dev/null
+++ b/devel/p5-Config-Ini/pkg-comment
@@ -0,0 +1 @@
+Perl interface to MS-Windows registry and .ini files
diff --git a/devel/p5-Config-Ini/pkg-descr b/devel/p5-Config-Ini/pkg-descr
new file mode 100644
index 000000000000..d39b31ab48cf
--- /dev/null
+++ b/devel/p5-Config-Ini/pkg-descr
@@ -0,0 +1,4 @@
+Config::Ini provides easy access to MS-Windows style .ini files, Unreal
+style extended .ini files (where multiple values can be associated with
+a single key), as well as registry files with automatic conversion from
+native Perl to Windows registry data encoding and vice versa.
diff --git a/devel/p5-Config-Ini/pkg-plist b/devel/p5-Config-Ini/pkg-plist
new file mode 100644
index 000000000000..e233984591ea
--- /dev/null
+++ b/devel/p5-Config-Ini/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Config/Ini.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/Ini/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/Ini
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Config 2>/dev/null || true