aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-23 20:44:07 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-23 20:44:07 +0800
commite98ea9204cad15c17a3df31da9f11f2b326bac16 (patch)
treec2f6da49e356bc064dad1898669be23a6bba33d9 /devel
parent9b35c9800f862cddf41ea4f1aae494f4636e5b16 (diff)
downloadfreebsd-ports-gnome-e98ea9204cad15c17a3df31da9f11f2b326bac16.tar.gz
freebsd-ports-gnome-e98ea9204cad15c17a3df31da9f11f2b326bac16.tar.zst
freebsd-ports-gnome-e98ea9204cad15c17a3df31da9f11f2b326bac16.zip
add p5-Proc-Reliable 1.10
Run external processes reliably with many options PR: 33439 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Proc-Reliable/Makefile22
-rw-r--r--devel/p5-Proc-Reliable/distinfo1
-rw-r--r--devel/p5-Proc-Reliable/pkg-comment1
-rw-r--r--devel/p5-Proc-Reliable/pkg-descr11
-rw-r--r--devel/p5-Proc-Reliable/pkg-plist8
6 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1c7c3ec9b36e..391ef6432453 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -499,6 +499,7 @@
SUBDIR += p5-Proc-Background
SUBDIR += p5-Proc-Daemon
SUBDIR += p5-Proc-ProcessTable
+ SUBDIR += p5-Proc-Reliable
SUBDIR += p5-Proc-Simple
SUBDIR += p5-ReadLine-Gnu
SUBDIR += p5-ReadLine-Perl
diff --git a/devel/p5-Proc-Reliable/Makefile b/devel/p5-Proc-Reliable/Makefile
new file mode 100644
index 000000000000..d7080a95de94
--- /dev/null
+++ b/devel/p5-Proc-Reliable/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Proc::Reliable
+# Date created: 31 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-Reliable
+PORTVERSION= 1.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::Reliable.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Proc-Reliable/distinfo b/devel/p5-Proc-Reliable/distinfo
new file mode 100644
index 000000000000..c98010863088
--- /dev/null
+++ b/devel/p5-Proc-Reliable/distinfo
@@ -0,0 +1 @@
+MD5 (Proc-Reliable-1.10.tar.gz) = 3c1e9b2ba6d7f6986b17975a6a14aa44
diff --git a/devel/p5-Proc-Reliable/pkg-comment b/devel/p5-Proc-Reliable/pkg-comment
new file mode 100644
index 000000000000..aa85687ff011
--- /dev/null
+++ b/devel/p5-Proc-Reliable/pkg-comment
@@ -0,0 +1 @@
+Run external processes reliably with many options
diff --git a/devel/p5-Proc-Reliable/pkg-descr b/devel/p5-Proc-Reliable/pkg-descr
new file mode 100644
index 000000000000..fa5384708027
--- /dev/null
+++ b/devel/p5-Proc-Reliable/pkg-descr
@@ -0,0 +1,11 @@
+The Proc::Reliable is intended to be a method for simple, reliable
+and configurable subprocess execution in PERL. It includes all the
+functionality of the backticks operator and system() functions,
+plus many uses of fork/exec, open2() and open3(). Proc::Reliable
+incorporates a number of options, including sending data to the
+subprocess on STDIN, collecting STDOUT and STDERR separately or
+together, killing hung processes, timouts and automatic retries.
+
+WWW: http://search.cpan.org/search?dist=Proc-Reliable
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/devel/p5-Proc-Reliable/pkg-plist b/devel/p5-Proc-Reliable/pkg-plist
new file mode 100644
index 000000000000..efb480c75b2d
--- /dev/null
+++ b/devel/p5-Proc-Reliable/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Proc/Reliable.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Proc/Reliable/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc/Reliable/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Proc 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Proc/Reliable
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Proc 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc/Reliable
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Proc 2>/dev/null || true