aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-06-20 14:08:08 +0800
committeryuri <yuri@FreeBSD.org>2018-06-20 14:08:08 +0800
commitea593c6dda42b342c0e7fc7a62a8fabe03af1fba (patch)
treee899bfb30e497a77891cb6878644112eabc26d25 /devel
parent69506921f551a700ed06a34a87976543b7dcada0 (diff)
downloadfreebsd-ports-gnome-ea593c6dda42b342c0e7fc7a62a8fabe03af1fba.tar.gz
freebsd-ports-gnome-ea593c6dda42b342c0e7fc7a62a8fabe03af1fba.tar.zst
freebsd-ports-gnome-ea593c6dda42b342c0e7fc7a62a8fabe03af1fba.zip
New port: devel/py-jupyterlab_launcher: Jupyter Launcher (launcher for the JupiterLab environment)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jupyterlab_launcher/Makefile21
-rw-r--r--devel/py-jupyterlab_launcher/distinfo3
-rw-r--r--devel/py-jupyterlab_launcher/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0cb688d3834e..f5140f1169d6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4637,6 +4637,7 @@
SUBDIR += py-jupyter_client
SUBDIR += py-jupyter_console
SUBDIR += py-jupyter_core
+ SUBDIR += py-jupyterlab_launcher
SUBDIR += py-kaitaistruct
SUBDIR += py-kaptan
SUBDIR += py-kayako
diff --git a/devel/py-jupyterlab_launcher/Makefile b/devel/py-jupyterlab_launcher/Makefile
new file mode 100644
index 000000000000..72e300fb6c93
--- /dev/null
+++ b/devel/py-jupyterlab_launcher/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= jupyterlab_launcher
+DISTVERSION= 0.11.0
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Jupyter Launcher (launcher for the JupiterLab environment)
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=2.6.0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}notebook>=4.2.0:www/py-notebook@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-jupyterlab_launcher/distinfo b/devel/py-jupyterlab_launcher/distinfo
new file mode 100644
index 000000000000..5d538dc3e264
--- /dev/null
+++ b/devel/py-jupyterlab_launcher/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529473624
+SHA256 (jupyterlab_launcher-0.11.0.tar.gz) = 2eea0cc95b312e136e6e5abc64e2e62baaeca493cd32f553c2205f79e01c0423
+SIZE (jupyterlab_launcher-0.11.0.tar.gz) = 18412
diff --git a/devel/py-jupyterlab_launcher/pkg-descr b/devel/py-jupyterlab_launcher/pkg-descr
new file mode 100644
index 000000000000..c35d1fdfa137
--- /dev/null
+++ b/devel/py-jupyterlab_launcher/pkg-descr
@@ -0,0 +1,6 @@
+Launcher is useful in the context of the Jupyter Project.
+
+Project Jupyter exists to develop open-source software, open-standards, and
+services for interactive computing across dozens of programming languages.
+
+WWW: http://jupyter.org/