aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-05-26 09:39:59 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-05-26 09:39:59 +0800
commiteb68aa6b4647b44cf9ada215cb9173e1b57b8bc4 (patch)
treed968f2071b1817eb6b8572a0e055e080b6e5047b /devel
parent1b4ce9f23887b332e105588ad0c9ac60e2c1856f (diff)
downloadfreebsd-ports-gnome-eb68aa6b4647b44cf9ada215cb9173e1b57b8bc4.tar.gz
freebsd-ports-gnome-eb68aa6b4647b44cf9ada215cb9173e1b57b8bc4.tar.zst
freebsd-ports-gnome-eb68aa6b4647b44cf9ada215cb9173e1b57b8bc4.zip
This small low-level module only has one purpose: pass a file
descriptor to another process, using a (streaming) unix domain socket (on POSIX systems) or any (streaming) socket (on WIN32 systems). The ability to pass file descriptors on windows is currently the unique selling point of this module. Have I mentioned that it is really small, too? WWW: http://search.cpan.org/dist/IO-FDPass/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IO-FDPass/Makefile16
-rw-r--r--devel/p5-IO-FDPass/distinfo2
-rw-r--r--devel/p5-IO-FDPass/pkg-descr8
-rw-r--r--devel/p5-IO-FDPass/pkg-plist7
5 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b0dc19f13179..cbefb2f22c74 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2103,6 +2103,7 @@
SUBDIR += p5-IO-Detect
SUBDIR += p5-IO-Digest
SUBDIR += p5-IO-Event
+ SUBDIR += p5-IO-FDPass
SUBDIR += p5-IO-HTML
SUBDIR += p5-IO-Handle-Util
SUBDIR += p5-IO-Interactive
diff --git a/devel/p5-IO-FDPass/Makefile b/devel/p5-IO-FDPass/Makefile
new file mode 100644
index 000000000000..9d9856f01855
--- /dev/null
+++ b/devel/p5-IO-FDPass/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= IO-FDPass
+PORTVERSION= 1.0
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to pass a file descriptor over a socket
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::FDPass.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-FDPass/distinfo b/devel/p5-IO-FDPass/distinfo
new file mode 100644
index 000000000000..6a5dd8514f1b
--- /dev/null
+++ b/devel/p5-IO-FDPass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IO-FDPass-1.0.tar.gz) = cbc56b327cc6301e36ceedaf3b85a06987d514f5212d22efab7c7e13d8080aa4
+SIZE (IO-FDPass-1.0.tar.gz) = 5866
diff --git a/devel/p5-IO-FDPass/pkg-descr b/devel/p5-IO-FDPass/pkg-descr
new file mode 100644
index 000000000000..c323222817a6
--- /dev/null
+++ b/devel/p5-IO-FDPass/pkg-descr
@@ -0,0 +1,8 @@
+This small low-level module only has one purpose: pass a file
+descriptor to another process, using a (streaming) unix domain socket
+(on POSIX systems) or any (streaming) socket (on WIN32 systems). The
+ability to pass file descriptors on windows is currently the unique
+selling point of this module. Have I mentioned that it is really
+small, too?
+
+WWW: http://search.cpan.org/dist/IO-FDPass/
diff --git a/devel/p5-IO-FDPass/pkg-plist b/devel/p5-IO-FDPass/pkg-plist
new file mode 100644
index 000000000000..8da0b9da23b8
--- /dev/null
+++ b/devel/p5-IO-FDPass/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/FDPass/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/FDPass/FDPass.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/FDPass/FDPass.so
+%%SITE_PERL%%/%%PERL_ARCH%%/IO/FDPass.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/IO
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/FDPass
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO