aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-02 16:31:46 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-02 16:31:46 +0800
commiteb6f963b9a1fa0e3e0038fc62d0b5827aa3f0778 (patch)
tree07a7ab08e804b9fdf6b6b7945a64ee128570b48a /devel
parent571676c46bb7c650436606b41d0eeee396446286 (diff)
downloadfreebsd-ports-gnome-eb6f963b9a1fa0e3e0038fc62d0b5827aa3f0778.tar.gz
freebsd-ports-gnome-eb6f963b9a1fa0e3e0038fc62d0b5827aa3f0778.tar.zst
freebsd-ports-gnome-eb6f963b9a1fa0e3e0038fc62d0b5827aa3f0778.zip
Mark broken with gcc4.2. While here, remove cruft and pet portlint.
Diffstat (limited to 'devel')
-rw-r--r--devel/clanlib-devel/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/devel/clanlib-devel/Makefile b/devel/clanlib-devel/Makefile
index 4811809f9e46..2646e4457be8 100644
--- a/devel/clanlib-devel/Makefile
+++ b/devel/clanlib-devel/Makefile
@@ -36,7 +36,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-clanJavaScript --disable-docs
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -46,15 +46,11 @@ PLIST_SUB= VER=${PORTVERSION:C/(^[0-9]\.[0-9]).*/\1/}
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
-BROKEN= "Does not compile on !i386 and !amd64"
+BROKEN= Does not compile on !i386 and !amd64
.endif
-.if ${OSVERSION} < 500032
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CPPFLAGS+= -I${LOCALBASE}/include/stlport
-LDFLAGS+= -lstlport_gcc
-CFLAGS+= -O0
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
.endif
.if defined(WITHOUT_SDL)