aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2012-03-20 00:21:20 +0800
committerskreuzer <skreuzer@FreeBSD.org>2012-03-20 00:21:20 +0800
commitebdaacd6c35d123111742bfa05b0d71e3381e4c4 (patch)
treece6c072376ee68bc68d43a298b89b8ff345c99c2 /devel
parente0ddbea04e10bffe47f176ab7d15a04979e68c75 (diff)
downloadfreebsd-ports-gnome-ebdaacd6c35d123111742bfa05b0d71e3381e4c4.tar.gz
freebsd-ports-gnome-ebdaacd6c35d123111742bfa05b0d71e3381e4c4.tar.zst
freebsd-ports-gnome-ebdaacd6c35d123111742bfa05b0d71e3381e4c4.zip
Hash::Diff returns the difference between two hashes as a hash.
WWW: http://search.cpan.org/dist/Hash-Diff/ Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Hash-Diff/Makefile27
-rw-r--r--devel/p5-Hash-Diff/distinfo2
-rw-r--r--devel/p5-Hash-Diff/pkg-descr3
-rw-r--r--devel/p5-Hash-Diff/pkg-plist6
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 16df683ba24c..bd8fdaa096a1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1882,6 +1882,7 @@
SUBDIR += p5-Hash-AsObject
SUBDIR += p5-Hash-AutoHash
SUBDIR += p5-Hash-Case
+ SUBDIR += p5-Hash-Diff
SUBDIR += p5-Hash-FieldHash
SUBDIR += p5-Hash-Flatten
SUBDIR += p5-Hash-Merge-Simple
diff --git a/devel/p5-Hash-Diff/Makefile b/devel/p5-Hash-Diff/Makefile
new file mode 100644
index 000000000000..e705994a57b1
--- /dev/null
+++ b/devel/p5-Hash-Diff/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Hash-Diff
+# Date created: 2012-03-16
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hash-Diff
+PORTVERSION= 0.005
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Return the difference between two hashes as a hash
+
+RUN_DEPENDS= p5-Hash-Merge>=0.12:${PORTSDIR}/textproc/p5-Hash-Merge
+BUILD_DEPENDS= p5-Hash-Merge>=0.12:${PORTSDIR}/textproc/p5-Hash-Merge
+
+TEST_DEPENDS= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-use-ok>=0.02:${PORTSDIR}/devel/p5-Test-use-ok
+
+PERL_CONFIGURE= yes
+
+MAN3= Hash::Diff.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Hash-Diff/distinfo b/devel/p5-Hash-Diff/distinfo
new file mode 100644
index 000000000000..36d406dc18c7
--- /dev/null
+++ b/devel/p5-Hash-Diff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Hash-Diff-0.005.tar.gz) = 6275f12f1dab005cfcdd8a88b111389bee48b74b73e6b3f0e86f2bf1865b15ff
+SIZE (Hash-Diff-0.005.tar.gz) = 22766
diff --git a/devel/p5-Hash-Diff/pkg-descr b/devel/p5-Hash-Diff/pkg-descr
new file mode 100644
index 000000000000..a1d426cea89b
--- /dev/null
+++ b/devel/p5-Hash-Diff/pkg-descr
@@ -0,0 +1,3 @@
+Hash::Diff returns the difference between two hashes as a hash.
+
+WWW: http://search.cpan.org/dist/Hash-Diff/
diff --git a/devel/p5-Hash-Diff/pkg-plist b/devel/p5-Hash-Diff/pkg-plist
new file mode 100644
index 000000000000..bdc17de684b3
--- /dev/null
+++ b/devel/p5-Hash-Diff/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/Diff/.packlist
+%%SITE_PERL%%/Hash/Diff.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/Diff
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash
+@dirrmtry %%SITE_PERL%%/Hash