aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-11-23 18:51:45 +0800
committerkoobs <koobs@FreeBSD.org>2013-11-23 18:51:45 +0800
commited9652c25f64ac32a0b131d8dc917cef7f9ff714 (patch)
tree9434d044b3d0a3815e60230d7a7015fb72c340a2 /devel
parent1f5031ec64cb7a5469d3fc8975ab83240777423c (diff)
downloadfreebsd-ports-gnome-ed9652c25f64ac32a0b131d8dc917cef7f9ff714.tar.gz
freebsd-ports-gnome-ed9652c25f64ac32a0b131d8dc917cef7f9ff714.tar.zst
freebsd-ports-gnome-ed9652c25f64ac32a0b131d8dc917cef7f9ff714.zip
devel/libhtp: Update to 0.5.9
- Update to 0.5.9 - Update pkg-plist - Remove unnecessary patch - QA: Enable STAGE support - QA: Add LICENSE (BSD) - QA: Add regression-test target - QA: Remove commented-out MASTER_SITES - QA: Re-order USE_* section Changes: https://github.com/ironbee/libhtp/blob/0.5.9/ChangeLog PR: ports/183785 Submitted by: wxs
Diffstat (limited to 'devel')
-rw-r--r--devel/libhtp/Makefile14
-rw-r--r--devel/libhtp/distinfo4
-rw-r--r--devel/libhtp/files/patch-htp__htp_util.c22
-rw-r--r--devel/libhtp/pkg-plist16
4 files changed, 21 insertions, 35 deletions
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
index f037945ed6ec..a176cfbe5039 100644
--- a/devel/libhtp/Makefile
+++ b/devel/libhtp/Makefile
@@ -1,22 +1,22 @@
# $FreeBSD$
PORTNAME= libhtp
-PORTVERSION= 0.3.0
-PORTREVISION= 2
+PORTVERSION= 0.5.9
CATEGORIES= devel
-#MASTER_SITES= # This port uses github
MAINTAINER= koobs@FreeBSD.org
COMMENT= Security-aware parser for the HTTP protocol
+LICENSE= BSD
+
USE_GITHUB= yes
GH_ACCOUNT= ironbee
-GH_COMMIT= a334539
+GH_COMMIT= f5f3c5c
+USES= pkgconfig pathfix iconv
USE_AUTOTOOLS= libtool autoheader aclocal
ACLOCAL_ARGS= -Im4
USE_LDCONFIG= yes
-USES= pkgconfig pathfix iconv
CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
@@ -24,9 +24,11 @@ CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
CONFLICTS_INSTALL= libhtp-suricata-*
-NO_STAGE= yes
pre-configure:
@${REINPLACE_CMD} -Ee 's,^(pkgconfigdir = ).*,\1$$(exec_prefix)/libdata/pkgconfig,' ${WRKSRC}/Makefile.am
@cd ${WRKSRC} && ${SH} ./autogen.sh
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} check
+
.include <bsd.port.mk>
diff --git a/devel/libhtp/distinfo b/devel/libhtp/distinfo
index 713cc6073f52..09da6ebabc06 100644
--- a/devel/libhtp/distinfo
+++ b/devel/libhtp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libhtp-0.3.0.tar.gz) = 5ea1c8c7b230113dd293c8d04a278db2c0ff2d894b158a578dbee15ab6a1d552
-SIZE (libhtp-0.3.0.tar.gz) = 397501
+SHA256 (libhtp-0.5.9.tar.gz) = b67f236a25abc197069260d454c7a1b16198be21338068ab57a0a156ec18198d
+SIZE (libhtp-0.5.9.tar.gz) = 5764911
diff --git a/devel/libhtp/files/patch-htp__htp_util.c b/devel/libhtp/files/patch-htp__htp_util.c
deleted file mode 100644
index ceb152e0a157..000000000000
--- a/devel/libhtp/files/patch-htp__htp_util.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./htp/htp_util.c.orig 2012-10-09 18:53:48.000000000 -0400
-+++ ./htp/htp_util.c 2012-10-09 18:54:31.000000000 -0400
-@@ -2099,7 +2099,8 @@
- len += bstr_len(hl->line);
- }
-
-- len += bstr_len(tx->request_headers_sep);
-+ if (tx->request_headers_sep)
-+ len += bstr_len(tx->request_headers_sep);
-
- request_headers_raw = bstr_alloc(len);
- if (request_headers_raw == NULL) {
-@@ -2112,7 +2113,8 @@
- bstr_add_noex(request_headers_raw, hl->line);
- }
-
-- bstr_add_noex(request_headers_raw, tx->request_headers_sep);
-+ if (tx->request_headers_sep)
-+ bstr_add_noex(request_headers_raw, tx->request_headers_sep);
-
- return request_headers_raw;
- }
diff --git a/devel/libhtp/pkg-plist b/devel/libhtp/pkg-plist
index 72a66208625e..939462b2c8d5 100644
--- a/devel/libhtp/pkg-plist
+++ b/devel/libhtp/pkg-plist
@@ -1,15 +1,21 @@
-include/htp/hooks.h
+include/htp/htp_config.h
+include/htp/htp_connection_parser.h
+include/htp/htp_core.h
+include/htp/htp_list.h
+include/htp/htp_table.h
+include/htp/htp_transaction.h
+include/htp/htp_version.h
+include/htp/htp_hooks.h
include/htp/htp_decompressors.h
include/htp/bstr.h
include/htp/bstr_builder.h
-include/htp/utf8_decoder.h
-include/htp/dslib.h
+include/htp/htp_utf8_decoder.h
include/htp/htp.h
include/htp/htp_base64.h
include/htp/htp_multipart.h
include/htp/htp_urlencoded.h
-lib/libhtp-0.3.so
-lib/libhtp-0.3.so.1
+lib/libhtp-0.5.9.so
+lib/libhtp-0.5.9.so.1
lib/libhtp.a
lib/libhtp.la
lib/libhtp.so