aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2011-04-07 00:57:47 +0800
committernivit <nivit@FreeBSD.org>2011-04-07 00:57:47 +0800
commiteedebfcdd57a01fd51e2ad355694b07a39482d86 (patch)
tree2d65008c0b7d45a1a08645fcedf9d678c3bdd47f /devel
parent3b993ebe170260b031c83fcd3d0e923957cef6f6 (diff)
downloadfreebsd-ports-gnome-eedebfcdd57a01fd51e2ad355694b07a39482d86.tar.gz
freebsd-ports-gnome-eedebfcdd57a01fd51e2ad355694b07a39482d86.tar.zst
freebsd-ports-gnome-eedebfcdd57a01fd51e2ad355694b07a39482d86.zip
- Update to 1.0
Diffstat (limited to 'devel')
-rw-r--r--devel/py-pip/Makefile7
-rw-r--r--devel/py-pip/distinfo4
-rw-r--r--devel/py-pip/pkg-plist18
3 files changed, 14 insertions, 15 deletions
diff --git a/devel/py-pip/Makefile b/devel/py-pip/Makefile
index 0ec4fa44a4d7..7080b88687d3 100644
--- a/devel/py-pip/Makefile
+++ b/devel/py-pip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pip
-PORTVERSION= 0.8.3
+PORTVERSION= 1.0
PORTREVISION= 0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP \
@@ -22,16 +22,17 @@ REINPLACE_ARGS= -i.bak -e "s/env python$$/&${PYTHON_VER}/"
PLIST_SUB= PYTHON_VER=${PYTHON_VER}
+# Python3 ready
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
post-patch:
- ${FIND} ${WRKSRC} -type f -name "pip*" -print0 | ${XARGS} -0 ${REINPLACE_CMD}
+ ${REINPLACE_CMD} ${WRKSRC}/pip/__init__.py
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/docs/_build && ${COPYTREE_SHARE} . ${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/py-pip/distinfo b/devel/py-pip/distinfo
index 35531ff49c85..66d0243b2f62 100644
--- a/devel/py-pip/distinfo
+++ b/devel/py-pip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pip-0.8.3.tar.gz) = 1be2e18edd38aa75b5e4ef38a99ec33ba9247177cfcb4a6d2d2b3e73430e3001
-SIZE (pip-0.8.3.tar.gz) = 107684
+SHA256 (pip-1.0.tar.gz) = 34ba07e2d14ba86d5088ba896ac80bed845a9b276ab8acb279b8d99bc77fec8e
+SIZE (pip-1.0.tar.gz) = 100102
diff --git a/devel/py-pip/pkg-plist b/devel/py-pip/pkg-plist
index 871a7c3d6a96..f40eb80d1e08 100644
--- a/devel/py-pip/pkg-plist
+++ b/devel/py-pip/pkg-plist
@@ -94,16 +94,14 @@ bin/pip-%%PYTHON_VER%%
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip/venv.py
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip/venv.pyc
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip/venv.pyo
-%%PORTDOCS%%%%DOCSDIR%%/html/._ci-server-step-by-step.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ci-server-step-by-step.html
-%%PORTDOCS%%%%DOCSDIR%%/html/configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/html/how-to-contribute.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/news.html
-%%PORTDOCS%%%%DOCSDIR%%/html/requirement-format.html
-%%PORTDOCS%%%%DOCSDIR%%/html/running-tests.html
-%%PORTDOCS%%%%DOCSDIR%%/html/search.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%%%DOCSDIR%%/ci-server-step-by-step.txt
+%%PORTDOCS%%%%DOCSDIR%%/configuration.txt
+%%PORTDOCS%%%%DOCSDIR%%/how-to-contribute.txt
+%%PORTDOCS%%%%DOCSDIR%%/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/installing.txt
+%%PORTDOCS%%%%DOCSDIR%%/news.txt
+%%PORTDOCS%%%%DOCSDIR%%/requirement-format.txt
+%%PORTDOCS%%%%DOCSDIR%%/running-tests.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip/vcs
@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pip/commands