aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-27 22:13:03 +0800
committerpav <pav@FreeBSD.org>2004-06-27 22:13:03 +0800
commitf038e4a6649f200277926ca35ebb6b75043c84be (patch)
treede6fb4f3ce483076abdd37f88344ec4ad3f12aad /devel
parent9846d006db81a96418d0af546e68586848c77ffa (diff)
downloadfreebsd-ports-gnome-f038e4a6649f200277926ca35ebb6b75043c84be.tar.gz
freebsd-ports-gnome-f038e4a6649f200277926ca35ebb6b75043c84be.tar.zst
freebsd-ports-gnome-f038e4a6649f200277926ca35ebb6b75043c84be.zip
- Update to 0.2.2
PR: ports/68418 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/phptags/Makefile2
-rw-r--r--devel/phptags/distinfo4
-rw-r--r--devel/phptags/files/patch-phptags.c64
3 files changed, 3 insertions, 67 deletions
diff --git a/devel/phptags/Makefile b/devel/phptags/Makefile
index 387adccec437..63ecae169e9f 100644
--- a/devel/phptags/Makefile
+++ b/devel/phptags/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= phptags
-PORTVERSION= 0.2.1
+PORTVERSION= 0.2.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/phptags/distinfo b/devel/phptags/distinfo
index 6177496b5bf2..3dc585545993 100644
--- a/devel/phptags/distinfo
+++ b/devel/phptags/distinfo
@@ -1,2 +1,2 @@
-MD5 (phptags-0.2.1.tar.gz) = 0e3557dae913e3e81fca7532e1684db9
-SIZE (phptags-0.2.1.tar.gz) = 149646
+MD5 (phptags-0.2.2.tar.gz) = d1f4f694195b2aeadef285f034fa46b7
+SIZE (phptags-0.2.2.tar.gz) = 149772
diff --git a/devel/phptags/files/patch-phptags.c b/devel/phptags/files/patch-phptags.c
deleted file mode 100644
index eedb15710ee7..000000000000
--- a/devel/phptags/files/patch-phptags.c
+++ /dev/null
@@ -1,64 +0,0 @@
---- src/phptags.c.orig Wed May 26 08:21:25 2004
-+++ src/phptags.c Mon May 31 23:56:48 2004
-@@ -48,6 +48,9 @@
- int i,
- ch;
-
-+ FILE *tmp_file;
-+// char *line = malloc(255);
-+
- (void)read_config();
-
- while ((ch = getopt(argc, argv, "cdf:hvV")) != -1) {
-@@ -84,9 +87,6 @@
- if (verbose && (current_conf != "none"))
- printf("Using config file: %s\n", current_conf);
-
-- FILE *tmp_file;
--// char *line = malloc(255);
--
- tmp_file = fopen(tagsfile, "w+");
-
- if ((int)tmp_file == NULL) {
-@@ -101,8 +101,8 @@
- for (i = 0; i < argc; i++) {
- char *m = malloc(256);
- char *line;
-- line = m;
- FILE *fd;
-+ line = m;
-
- fd = fopen(argv[i], "r");
- if ((int)fd == NULL) {
-@@ -132,11 +132,13 @@
- if (!commented) {
- if (!strncmp("function ", line, 9)) {
- /* foo bar.c /^function foo($bar)$/; */
-+ int func_name_len;
-+ char *func_name;
- line+=9;
- line[strlen(line) - 1] = '\0';
-
-- int func_name_len = strlen(line) - strlen(strstr(line, "("));
-- char *func_name = malloc(func_name_len);
-+ func_name_len = strlen(line) - strlen(strstr(line, "("));
-+ func_name = malloc(func_name_len);
-
- (void)memmove(func_name, line, func_name_len);
-
-@@ -148,11 +150,13 @@
-
- free(func_name);
- } else if (!strncmp("class ", line, 6) && tag_classes == 1) {
-+ int class_name_len;
-+ char *class_name;
- line+=6;
- line[strlen(line) - 1] = '\0';
-
-- int class_name_len = strlen(line) - strlen(strstr(line, " "));
-- char *class_name = malloc(class_name_len);
-+ class_name_len = strlen(line) - strlen(strstr(line, " "));
-+ class_name = malloc(class_name_len);
-
- (void)strncpy(class_name, line, class_name_len);
-