aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2003-09-27 21:38:33 +0800
committervanilla <vanilla@FreeBSD.org>2003-09-27 21:38:33 +0800
commitf0e0a5222603a45056153f573f70d8ea1cfa719c (patch)
tree410a7effecad9ec7b4b7289039617d891d6b997d /devel
parentc60ae51d7610f8fa59721e6594285d97f061601c (diff)
downloadfreebsd-ports-gnome-f0e0a5222603a45056153f573f70d8ea1cfa719c.tar.gz
freebsd-ports-gnome-f0e0a5222603a45056153f573f70d8ea1cfa719c.tar.zst
freebsd-ports-gnome-f0e0a5222603a45056153f573f70d8ea1cfa719c.zip
Add p5-ExtUtils-XSBuilder, it's a set modules to parse C header files and
create XS glue code and documentation out of it. Sponsor by: Open Source Software Foundry <http://www.openfoundry.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ExtUtils-XSBuilder/Makefile26
-rw-r--r--devel/p5-ExtUtils-XSBuilder/distinfo1
-rw-r--r--devel/p5-ExtUtils-XSBuilder/pkg-descr7
-rw-r--r--devel/p5-ExtUtils-XSBuilder/pkg-plist17
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d19fbd915d1c..60ab0db35a21 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -608,6 +608,7 @@
SUBDIR += p5-Exception-Class
SUBDIR += p5-Exporter-Lite
SUBDIR += p5-ExtUtils-ParseXS
+ SUBDIR += p5-ExtUtils-XSBuilder
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Binary
SUBDIR += p5-File-Cache
diff --git a/devel/p5-ExtUtils-XSBuilder/Makefile b/devel/p5-ExtUtils-XSBuilder/Makefile
new file mode 100644
index 000000000000..ca65d02be548
--- /dev/null
+++ b/devel/p5-ExtUtils-XSBuilder/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ExtUtils::XSBuilder
+# Date created: 11 Sep 2003
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-XSBuilder
+PORTVERSION= 0.23
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Autogenerating XS-glue Code
+
+RUN_DEPENDS= ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INSTALLDIRS=site
+
+MAN3= ExtUtils::XSBuilder.3 ExtUtils::xsbuilder.osc2002.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-XSBuilder/distinfo b/devel/p5-ExtUtils-XSBuilder/distinfo
new file mode 100644
index 000000000000..a3b2cdd0f593
--- /dev/null
+++ b/devel/p5-ExtUtils-XSBuilder/distinfo
@@ -0,0 +1 @@
+MD5 (ExtUtils-XSBuilder-0.23.tar.gz) = b6c8dee223cc9772ed6288ab223cfa54
diff --git a/devel/p5-ExtUtils-XSBuilder/pkg-descr b/devel/p5-ExtUtils-XSBuilder/pkg-descr
new file mode 100644
index 000000000000..a3d2c63fb9d7
--- /dev/null
+++ b/devel/p5-ExtUtils-XSBuilder/pkg-descr
@@ -0,0 +1,7 @@
+ExtUtils::XSBuilder is a set modules to parse C header files and create XS
+glue code and documentation out of it. Idealy this allows to "write" an
+interface to a C library without coding a line. Since no C-API is ideal,
+some adjuments are necessary most of the time. So to use this module you
+must still be familar with C and XS programming, but it removes a lot of
+stupid work and copy&paste from you. Also when the C API changes, most
+of the time you only have to rerun XSBuilder to get your new Perl API.
diff --git a/devel/p5-ExtUtils-XSBuilder/pkg-plist b/devel/p5-ExtUtils-XSBuilder/pkg-plist
new file mode 100644
index 000000000000..8953b945831d
--- /dev/null
+++ b/devel/p5-ExtUtils-XSBuilder/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/ExtUtils/XSBuilder.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder.pod
+%%SITE_PERL%%/ExtUtils/XSBuilder/C/grammar.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder/CallbackMap.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder/FunctionMap.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder/MapUtil.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder/ParseSource.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder/StructureMap.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder/TypeMap.pm
+%%SITE_PERL%%/ExtUtils/XSBuilder/WrapXS.pm
+%%SITE_PERL%%/ExtUtils/xsbuilder.osc2002.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/XSBuilder/.packlist
+@dirrm %%SITE_PERL%%/ExtUtils/XSBuilder/C
+@dirrm %%SITE_PERL%%/ExtUtils/XSBuilder
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/XSBuilder
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/ExtUtils 2>/dev/null || true