aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-04-05 23:41:43 +0800
committertobez <tobez@FreeBSD.org>2007-04-05 23:41:43 +0800
commitf3dbb0bf3326da9dbbfbe20d10183fa01ebd1ec6 (patch)
tree5e53fc9490dee2d0cc30b4272b497d877e60d555 /devel
parent04984e892235cccf9bc44c39440f179fc5720496 (diff)
downloadfreebsd-ports-gnome-f3dbb0bf3326da9dbbfbe20d10183fa01ebd1ec6.tar.gz
freebsd-ports-gnome-f3dbb0bf3326da9dbbfbe20d10183fa01ebd1ec6.tar.zst
freebsd-ports-gnome-f3dbb0bf3326da9dbbfbe20d10183fa01ebd1ec6.zip
Add devel/p5-Data-GUID 0.043, a Perl module to generate globally unique
identifiers.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-GUID/Makefile33
-rw-r--r--devel/p5-Data-GUID/distinfo3
-rw-r--r--devel/p5-Data-GUID/pkg-descr4
-rw-r--r--devel/p5-Data-GUID/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6490965e1b1c..95c7a82e3cdb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -982,6 +982,7 @@
SUBDIR += p5-Data-Dumper
SUBDIR += p5-Data-Dumper-Simple
SUBDIR += p5-Data-Flow
+ SUBDIR += p5-Data-GUID
SUBDIR += p5-Data-HexDump
SUBDIR += p5-Data-Hexdumper
SUBDIR += p5-Data-Hierarchy
diff --git a/devel/p5-Data-GUID/Makefile b/devel/p5-Data-GUID/Makefile
new file mode 100644
index 000000000000..48a784d8feb7
--- /dev/null
+++ b/devel/p5-Data-GUID/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: devel/p5-Data-GUID
+# Date created: 05 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-GUID
+PORTVERSION= 0.043
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Generate globally unique identifiers
+
+BUILD_DEPENDS= ${SITE_PERL}/Sub/Install.pm:${PORTSDIR}/devel/p5-Sub-Install \
+ ${SITE_PERL}/Sub/Exporter.pm:${PORTSDIR}/devel/p5-Sub-Exporter \
+ ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::GUID.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= has a dependency that wants perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-GUID/distinfo b/devel/p5-Data-GUID/distinfo
new file mode 100644
index 000000000000..b195dc22e37c
--- /dev/null
+++ b/devel/p5-Data-GUID/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-GUID-0.043.tar.gz) = 130afa8c397bfec6ac09d1125d3e0405
+SHA256 (Data-GUID-0.043.tar.gz) = d2dd5f932a2745646be91961b03490b53b24c5b14fa5bc60af7f4e33b707b70e
+SIZE (Data-GUID-0.043.tar.gz) = 13221
diff --git a/devel/p5-Data-GUID/pkg-descr b/devel/p5-Data-GUID/pkg-descr
new file mode 100644
index 000000000000..2895a2c2e4bb
--- /dev/null
+++ b/devel/p5-Data-GUID/pkg-descr
@@ -0,0 +1,4 @@
+Data::GUID provides a simple interface for generating and using globally
+unique identifiers.
+
+WWW: http://search.cpan.org/dist/Data-GUID/
diff --git a/devel/p5-Data-GUID/pkg-plist b/devel/p5-Data-GUID/pkg-plist
new file mode 100644
index 000000000000..3ae4bfb665e4
--- /dev/null
+++ b/devel/p5-Data-GUID/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/GUID.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/GUID/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/GUID
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data