aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-05-11 07:14:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-05-11 07:14:57 +0800
commitf5cbde7ae515a31121d4d527faf65162a8cfd814 (patch)
tree0d863f6ad3f2887f6a156227e0ca5f7f45a0786f /devel
parentc713d6cff3b38302e03c8a2b5d03c653d156260e (diff)
downloadfreebsd-ports-gnome-f5cbde7ae515a31121d4d527faf65162a8cfd814.tar.gz
freebsd-ports-gnome-f5cbde7ae515a31121d4d527faf65162a8cfd814.tar.zst
freebsd-ports-gnome-f5cbde7ae515a31121d4d527faf65162a8cfd814.zip
Fix device scan
- Bump PORTREVISION for package change PR: 227252 Reported by: doktornotor <doktornotor@mailinator.com> Tested by: <vidwer@gmail.com> Obtained from: https://github.com/pciutils/pciutils/commit/58d9f25f25c0070c3c3df3073f375d87a9163e88
Diffstat (limited to 'devel')
-rw-r--r--devel/libpci/Makefile1
-rw-r--r--devel/libpci/files/patch-lib-fbsd-device.c9
2 files changed, 10 insertions, 0 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index f268d25a0f04..db94ee0a8972 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libpci
PORTVERSION= 3.5.6
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/utils/pciutils \
ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/ \
diff --git a/devel/libpci/files/patch-lib-fbsd-device.c b/devel/libpci/files/patch-lib-fbsd-device.c
index 6f32908b6412..33bfa09f74a7 100644
--- a/devel/libpci/files/patch-lib-fbsd-device.c
+++ b/devel/libpci/files/patch-lib-fbsd-device.c
@@ -1,5 +1,14 @@
--- lib/fbsd-device.c.orig 2017-11-17 12:57:00 UTC
+++ lib/fbsd-device.c
+@@ -143,7 +143,7 @@ fbsd_scan(struct pci_access *a)
+ t = pci_alloc_dev(a);
+ t->bus = matches[i].pc_sel.pc_bus;
+ t->dev = matches[i].pc_sel.pc_dev;
+- t->dev = matches[i].pc_sel.pc_dev;
++ t->func = matches[i].pc_sel.pc_func;
+ t->domain = matches[i].pc_sel.pc_domain;
+ t->domain_16 = matches[i].pc_sel.pc_domain;
+ t->vendor_id = matches[i].pc_vendor;
@@ -254,7 +254,7 @@ fbsd_read(struct pci_dev *d, int pos, by
if (d->access->fd_rw < 0)