aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-03-04 20:27:14 +0800
committermiwi <miwi@FreeBSD.org>2012-03-04 20:27:14 +0800
commitf987ef90b1cd42dd3565d63efac32b5d6b623969 (patch)
tree62c69f9b0f429c2f7174d43737ceaba491f56cd8 /devel
parent5c318e38e2b5e5fcc8a8478f053f74f8695f0e64 (diff)
downloadfreebsd-ports-gnome-f987ef90b1cd42dd3565d63efac32b5d6b623969.tar.gz
freebsd-ports-gnome-f987ef90b1cd42dd3565d63efac32b5d6b623969.tar.zst
freebsd-ports-gnome-f987ef90b1cd42dd3565d63efac32b5d6b623969.zip
- Fix broken regression test
PR: 164665 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/premake4/Makefile6
-rw-r--r--devel/premake4/files/patch-src-base-os.lua17
-rw-r--r--devel/premake4/files/patch-src-host-scripts.c5
3 files changed, 27 insertions, 1 deletions
diff --git a/devel/premake4/Makefile b/devel/premake4/Makefile
index c23bd13a227d..1bf0848d9349 100644
--- a/devel/premake4/Makefile
+++ b/devel/premake4/Makefile
@@ -29,12 +29,16 @@ PORTDOCS= CHANGES.txt LICENSE.txt README.txt
post-patch:
${REINPLACE_CMD} -e 's|-ldl||' ${BUILD_WRKSRC}/Premake4.make
+ ${REINPLACE_CMD} -e 's|debug|release|' ${WRKSRC}/tests/test
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/release/premake4 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/release/premake4 ${PREFIX}/bin
+
+regression-test: build
+ cd ${WRKSRC}/tests && ./test
.include <bsd.port.post.mk>
diff --git a/devel/premake4/files/patch-src-base-os.lua b/devel/premake4/files/patch-src-base-os.lua
new file mode 100644
index 000000000000..fa9d6a5d91b3
--- /dev/null
+++ b/devel/premake4/files/patch-src-base-os.lua
@@ -0,0 +1,17 @@
+--- src/base/os.lua.orig 2012-01-31 15:40:25.000000000 +0200
++++ src/base/os.lua 2012-01-31 15:42:16.000000000 +0200
+@@ -33,14 +33,6 @@
+ else
+ formats = { "lib%s.so", "%s.so" }
+ path = os.getenv("LD_LIBRARY_PATH") or ""
+-
+- io.input("/etc/ld.so.conf")
+- if io.input() then
+- for line in io.lines() do
+- path = path .. ":" .. line
+- end
+- io.input():close()
+- end
+ end
+
+ table.insert(formats, "%s")
diff --git a/devel/premake4/files/patch-src-host-scripts.c b/devel/premake4/files/patch-src-host-scripts.c
new file mode 100644
index 000000000000..cebce32bfbf5
--- /dev/null
+++ b/devel/premake4/files/patch-src-host-scripts.c
@@ -0,0 +1,5 @@
+--- src/host/scripts.c.orig 2010-11-16 13:29:13.000000000 +0200
++++ src/host/scripts.c 2012-01-31 16:05:26.000000000 +0200
+@@ -7 +7 @@
+- "function os.executef(cmd, ...)\ncmd = string.format(cmd, unpack(arg))\nreturn os.execute(cmd)\nend\nfunction os.findlib(libname)\nlocal path, formats\nif os.is(\"windows\") then\nformats = { \"%s.dll\", \"%s\" }\npath = os.getenv(\"PATH\")\nelse\nif os.is(\"macosx\") then\nformats = { \"lib%s.dylib\", \"%s.dylib\" }\npath = os.getenv(\"DYLD_LIBRARY_PATH\")\nelse\nformats = { \"lib%s.so\", \"%s.so\" }\npath = os.getenv(\"LD_LIBRARY_PATH\") or \"\"\nio.input(\"/etc/ld.so.conf\")\nif io.input() then\nfor line in io.lines() do\npath = path .. \":\" .. line\nend\nio.input():close()\nend\nend\ntable.insert(formats, \"%s\")\npath = (path or \"\") .. \":/lib:/usr/lib:/usr/local/lib\"\nend\nfor _, fmt in ipairs(formats) do\nlocal name = string.format(fmt, libname)\nlocal result = os.pathsearch(name, path)\nif result then return result end\nend\nend\nfunction os.get()\nreturn _OPTIONS.os or _OS\nend\nfunction os.is(id)\nreturn (os.get():lower() == id:lower())\nend\nlocal function domatch(result, mask, wantfiles)\nif mas"
++ "function os.executef(cmd, ...)\ncmd = string.format(cmd, unpack(arg))\nreturn os.execute(cmd)\nend\nfunction os.findlib(libname)\nlocal path, formats\nif os.is(\"windows\") then\nformats = { \"%s.dll\", \"%s\" }\npath = os.getenv(\"PATH\")\nelse\nif os.is(\"macosx\") then\nformats = { \"lib%s.dylib\", \"%s.dylib\" }\npath = os.getenv(\"DYLD_LIBRARY_PATH\")\nelse\nformats = { \"lib%s.so\", \"%s.so\" }\npath = os.getenv(\"LD_LIBRARY_PATH\") or \"\"\nend\ntable.insert(formats, \"%s\")\npath = (path or \"\") .. \":/lib:/usr/lib:/usr/local/lib\"\nend\nfor _, fmt in ipairs(formats) do\nlocal name = string.format(fmt, libname)\nlocal result = os.pathsearch(name, path)\nif result then return result end\nend\nend\nfunction os.get()\nreturn _OPTIONS.os or _OS\nend\nfunction os.is(id)\nreturn (os.get():lower() == id:lower())\nend\nlocal function domatch(result, mask, wantfiles)\nif mas"