aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2013-11-30 09:57:45 +0800
committersbruno <sbruno@FreeBSD.org>2013-11-30 09:57:45 +0800
commitfa62cb788fb2edae156d6eda24b573630a6f4199 (patch)
tree33f3483961a93320db4999a65224e6ea967d6090 /devel
parent081d13799e4878767242c116814ca065d9be50cd (diff)
downloadfreebsd-ports-gnome-fa62cb788fb2edae156d6eda24b573630a6f4199.tar.gz
freebsd-ports-gnome-fa62cb788fb2edae156d6eda24b573630a6f4199.tar.zst
freebsd-ports-gnome-fa62cb788fb2edae156d6eda24b573630a6f4199.zip
Address some of the nonsense seen in audio/clementine-player as the code in
this port ends up generating libraries and code that just don't link correctly. PR: ports/178687
Diffstat (limited to 'devel')
-rw-r--r--devel/protobuf/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/protobuf/Makefile b/devel/protobuf/Makefile
index d01ab982d9d2..0da77b74a2af 100644
--- a/devel/protobuf/Makefile
+++ b/devel/protobuf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= protobuf
PORTVERSION= 2.5.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -16,6 +17,10 @@ USE_LDCONFIG= yes
USES= pathfix pkgconfig
ONLY_FOR_ARCHS= i386 amd64
+# clang will generate code that just doesn't work with clementine-player
+# if this isn't compiled as though it were C99.
+CFLAGS+= -std=c99
+
tests: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)