aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2012-10-14 15:55:54 +0800
committerculot <culot@FreeBSD.org>2012-10-14 15:55:54 +0800
commitfe02f98772a1e21e5aaf7c99c50f09ecf3cb64c5 (patch)
tree9ca921defdadd8f46e28bab2f0c5b95d3d8246d5 /devel
parent052b40635d78b10ea640fc3e4c498fc9b6ca10be (diff)
downloadfreebsd-ports-gnome-fe02f98772a1e21e5aaf7c99c50f09ecf3cb64c5.tar.gz
freebsd-ports-gnome-fe02f98772a1e21e5aaf7c99c50f09ecf3cb64c5.tar.zst
freebsd-ports-gnome-fe02f98772a1e21e5aaf7c99c50f09ecf3cb64c5.zip
App::Rad aims to be a simple yet powerful framework for developing your
command-line applications. It can easily transform your Perl one-liners into reusable subroutines than can be called directly by the user of your program. WWW: http://search.cpan.org/dist/App-Rad/ PR: ports/172530 Submitted by: Gea-Suan Lin <gslin@gslin.org> Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-App-Rad/Makefile24
-rw-r--r--devel/p5-App-Rad/distinfo2
-rw-r--r--devel/p5-App-Rad/pkg-descr6
-rw-r--r--devel/p5-App-Rad/pkg-plist11
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 45fe04aec531..6c9cf42e5736 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1353,6 +1353,7 @@
SUBDIR += p5-App-GitHub
SUBDIR += p5-App-Info
SUBDIR += p5-App-Options
+ SUBDIR += p5-App-Rad
SUBDIR += p5-App-SD
SUBDIR += p5-App-SVN-Bisect
SUBDIR += p5-App-Trace
diff --git a/devel/p5-App-Rad/Makefile b/devel/p5-App-Rad/Makefile
new file mode 100644
index 000000000000..4b5400321766
--- /dev/null
+++ b/devel/p5-App-Rad/Makefile
@@ -0,0 +1,24 @@
+# Created by: Gea-Suan Lin <gslin@gslin.org>
+# $FreeBSD$
+
+PORTNAME= App-Rad
+PORTVERSION= 1.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Rapid (and easy!) creation of command line applications
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+PERL_CONFIGURE= yes
+
+MAN3= App::Rad.3 \
+ App::Rad::Exclude.3 \
+ App::Rad::Help.3 \
+ App::Rad::Include.3 \
+ App::Rad::Plugin.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-App-Rad/distinfo b/devel/p5-App-Rad/distinfo
new file mode 100644
index 000000000000..0cc32f236c02
--- /dev/null
+++ b/devel/p5-App-Rad/distinfo
@@ -0,0 +1,2 @@
+SHA256 (App-Rad-1.04.tar.gz) = 308b039378dcefe83218cf0539e3125f072c373ffa9e5f615275f868e3230428
+SIZE (App-Rad-1.04.tar.gz) = 29551
diff --git a/devel/p5-App-Rad/pkg-descr b/devel/p5-App-Rad/pkg-descr
new file mode 100644
index 000000000000..457625461ba9
--- /dev/null
+++ b/devel/p5-App-Rad/pkg-descr
@@ -0,0 +1,6 @@
+App::Rad aims to be a simple yet powerful framework for developing your
+command-line applications. It can easily transform your Perl one-liners
+into reusable subroutines than can be called directly by the user of
+your program.
+
+WWW: http://search.cpan.org/dist/App-Rad/
diff --git a/devel/p5-App-Rad/pkg-plist b/devel/p5-App-Rad/pkg-plist
new file mode 100644
index 000000000000..f2c7128ba566
--- /dev/null
+++ b/devel/p5-App-Rad/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/Rad/.packlist
+%%SITE_PERL%%/App/Rad.pm
+%%SITE_PERL%%/App/Rad/Config.pm
+%%SITE_PERL%%/App/Rad/Exclude.pm
+%%SITE_PERL%%/App/Rad/Help.pm
+%%SITE_PERL%%/App/Rad/Include.pm
+%%SITE_PERL%%/App/Rad/Plugin.pod
+@dirrm %%SITE_PERL%%/App/Rad
+@dirrmtry %%SITE_PERL%%/App
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/App/Rad
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/App