aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2007-11-09 16:09:19 +0800
committervs <vs@FreeBSD.org>2007-11-09 16:09:19 +0800
commit24571585711c6d1894015d12213aad7bde909e35 (patch)
treecd20230303ad096569f5e5cc3f319a5e7d551eca /devel
parent5b081f4f32e105aa7f5a787629e4cb49e7c67f85 (diff)
downloadfreebsd-ports-gnome-24571585711c6d1894015d12213aad7bde909e35.tar.gz
freebsd-ports-gnome-24571585711c6d1894015d12213aad7bde909e35.tar.zst
freebsd-ports-gnome-24571585711c6d1894015d12213aad7bde909e35.zip
Fix packaging blunder: install supporting file where it belongs
Approved by: portmgr (linimon)
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-c2hs/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/hs-c2hs/Makefile b/devel/hs-c2hs/Makefile
index 73e598367ab7..6542a3e13a20 100644
--- a/devel/hs-c2hs/Makefile
+++ b/devel/hs-c2hs/Makefile
@@ -24,12 +24,15 @@ LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
GHC_VERSION= 6.6.1
# 'owned' by lang/ghc:
-CABALDIR= ${PREFIX}/lib/ghc-${GHC_VERSION}/cabal
+CABALDIR= ${PREFIX}/${SUBDIR}
CABALCMD= ${LOCALBASE}/bin/runghc Setup.hs
+SUBDIR= lib/ghc-${GHC_VERSION}/cabal
-PLIST_FILES= bin/c2hs
+PLIST_FILES= bin/c2hs ${SUBDIR}/${PORTNAME}/C2HS.hs
+PLIST_DIRS= ${SUBDIR}/${PORTNAME}
CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${CABALDIR} \
+ --datadir=${CABALDIR}/${PORTNAME} \
--libsubdir='' --datasubdir=''
do-configure: