aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-12-05 01:12:03 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-12-05 01:12:03 +0800
commit26448e48e38250a47e6415b7170eaf8691b6f004 (patch)
tree871dced8508d7c7df7a05edf250f09f44d515472 /devel
parent142bf24d7416665ad9c629a39e6dd4fb542b6d1e (diff)
downloadfreebsd-ports-gnome-26448e48e38250a47e6415b7170eaf8691b6f004.tar.gz
freebsd-ports-gnome-26448e48e38250a47e6415b7170eaf8691b6f004.tar.zst
freebsd-ports-gnome-26448e48e38250a47e6415b7170eaf8691b6f004.zip
- Add p5-Scalar-Does 0.009
Scalar::Does has long been noted that Perl would benefit from a does() built-in. A check that ref($thing) eq 'ARRAY' doesn't allow you to accept an object that uses overloading to provide an array-like interface. WWW: http://search.cpan.org/dist/Scalar-Does/ Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Scalar-Does/Makefile38
-rw-r--r--devel/p5-Scalar-Does/distinfo2
-rw-r--r--devel/p5-Scalar-Does/pkg-descr5
-rw-r--r--devel/p5-Scalar-Does/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 421512e6d2ee..26e452524141 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2504,6 +2504,7 @@
SUBDIR += p5-SVN-Web
SUBDIR += p5-Safe-Isa
SUBDIR += p5-Scalar-Defer
+ SUBDIR += p5-Scalar-Does
SUBDIR += p5-Scalar-Listify
SUBDIR += p5-Scalar-String
SUBDIR += p5-Scope-Guard
diff --git a/devel/p5-Scalar-Does/Makefile b/devel/p5-Scalar-Does/Makefile
new file mode 100644
index 000000000000..97d537718688
--- /dev/null
+++ b/devel/p5-Scalar-Does/Makefile
@@ -0,0 +1,38 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Scalar-Does
+PORTVERSION= 0.009
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Like ref() but useful
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-IO-Detect>=0.001:${PORTSDIR}/devel/p5-IO-Detect \
+ p5-PadWalker>=0:${PORTSDIR}/devel/p5-PadWalker \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-namespace-clean>=0.19:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
+
+# It requires UNIVERSAL::DOES on Perl 5.8
+PERL_CONFIGURE= 5.10+
+
+MAN3= Scalar::Does.3 \
+ Scalar::Does::MooseTypes.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.20:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.20:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Scalar-Does/distinfo b/devel/p5-Scalar-Does/distinfo
new file mode 100644
index 000000000000..e7bf61be9a00
--- /dev/null
+++ b/devel/p5-Scalar-Does/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Scalar-Does-0.009.tar.gz) = ce7a21c6ddf979259ac2217994fe9dac1fa7b224157b38ce25b3ba366b42c7d9
+SIZE (Scalar-Does-0.009.tar.gz) = 57343
diff --git a/devel/p5-Scalar-Does/pkg-descr b/devel/p5-Scalar-Does/pkg-descr
new file mode 100644
index 000000000000..45663acf4c0b
--- /dev/null
+++ b/devel/p5-Scalar-Does/pkg-descr
@@ -0,0 +1,5 @@
+Scalar::Does has long been noted that Perl would benefit from a does() built-in.
+A check that ref($thing) eq 'ARRAY' doesn't allow you to accept an object that
+uses overloading to provide an array-like interface.
+
+WWW: http://search.cpan.org/dist/Scalar-Does/
diff --git a/devel/p5-Scalar-Does/pkg-plist b/devel/p5-Scalar-Does/pkg-plist
new file mode 100644
index 000000000000..075e92ad65d6
--- /dev/null
+++ b/devel/p5-Scalar-Does/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Scalar/Does.pm
+%%SITE_PERL%%/Scalar/Does/MooseTypes.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Does/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Does
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar
+@dirrm %%SITE_PERL%%/Scalar/Does
+@dirrmtry %%SITE_PERL%%/Scalar