aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-02-18 17:42:58 +0800
committeraaron <aaron@FreeBSD.org>2006-02-18 17:42:58 +0800
commit289b06b978773fc6a51ea1c7d29318fb9f91e659 (patch)
treefd72e6b05182df3180cf0357ff3a3ec96c28a4a1 /devel
parentb481b2b99e4ec8220082fb7a3575226027aa8fdb (diff)
downloadfreebsd-ports-gnome-289b06b978773fc6a51ea1c7d29318fb9f91e659.tar.gz
freebsd-ports-gnome-289b06b978773fc6a51ea1c7d29318fb9f91e659.tar.zst
freebsd-ports-gnome-289b06b978773fc6a51ea1c7d29318fb9f91e659.zip
Adding port devel/p5-Test-RandomResults, allowing one to test non-deterministic functions.
Commited by: aaron Approved by: tobez (implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-RandomResults/Makefile31
-rw-r--r--devel/p5-Test-RandomResults/distinfo3
-rw-r--r--devel/p5-Test-RandomResults/pkg-descr13
-rw-r--r--devel/p5-Test-RandomResults/pkg-plist5
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1aaef4c78a16..79986392c201 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1204,6 +1204,7 @@
SUBDIR += p5-Test-NoWarnings
SUBDIR += p5-Test-Pod
SUBDIR += p5-Test-Pod-Coverage
+ SUBDIR += p5-Test-RandomResults
SUBDIR += p5-Test-Reporter
SUBDIR += p5-Test-Simple
SUBDIR += p5-Test-Strict
diff --git a/devel/p5-Test-RandomResults/Makefile b/devel/p5-Test-RandomResults/Makefile
new file mode 100644
index 000000000000..d20a9d130fb1
--- /dev/null
+++ b/devel/p5-Test-RandomResults/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Test-RandomResults
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-RandomResults
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Test non-deterministic functions
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Test::RandomResults.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-RandomResults/distinfo b/devel/p5-Test-RandomResults/distinfo
new file mode 100644
index 000000000000..d3913fe2357e
--- /dev/null
+++ b/devel/p5-Test-RandomResults/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-RandomResults-0.03.tar.gz) = fc74756a3bedd6345f142e09bd6ece14
+SHA256 (Test-RandomResults-0.03.tar.gz) = 3b87a7ab4c86c5b226f9a8f60d45474b9eb81ed28daa68e306d4e4d263a5ad5d
+SIZE (Test-RandomResults-0.03.tar.gz) = 4198
diff --git a/devel/p5-Test-RandomResults/pkg-descr b/devel/p5-Test-RandomResults/pkg-descr
new file mode 100644
index 000000000000..6a27b3ea6148
--- /dev/null
+++ b/devel/p5-Test-RandomResults/pkg-descr
@@ -0,0 +1,13 @@
+This module aims to provide ways of testing functions that are meant to
+return results that are random; that is, non-deterministic functions.
+
+Some of the tests provided here might be easily achieved with other
+testing modules. The reason why they're here is that this way users become
+aware of how to test their non-deterministic functions.
+
+WWW: http://search.cpan.org/dist/Test-RandomResults
+Author: Jose Castro <cog@cpan.org>
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/devel/p5-Test-RandomResults/pkg-plist b/devel/p5-Test-RandomResults/pkg-plist
new file mode 100644
index 000000000000..8d4322e8bbe7
--- /dev/null
+++ b/devel/p5-Test-RandomResults/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/RandomResults.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/RandomResults/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/RandomResults
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test