aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-06-22 14:53:39 +0800
committerahze <ahze@FreeBSD.org>2005-06-22 14:53:39 +0800
commit339f1511cea751bd9a56dce542779291d88acf7d (patch)
tree722f1c32bffdecf9f6ed36d0d38caa252f7d240b /devel
parent0e14cdcc50407e807a9908fdd306522fd0c58703 (diff)
downloadfreebsd-ports-gnome-339f1511cea751bd9a56dce542779291d88acf7d.tar.gz
freebsd-ports-gnome-339f1511cea751bd9a56dce542779291d88acf7d.tar.zst
freebsd-ports-gnome-339f1511cea751bd9a56dce542779291d88acf7d.zip
Add p5-Test-Warn 0.08, perl extension to test methods for warnings.
PR: ports/82400 Submitted by: Brian Minard <bminard@flatfoot.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Warn/Makefile30
-rw-r--r--devel/p5-Test-Warn/distinfo2
-rw-r--r--devel/p5-Test-Warn/pkg-descr7
-rw-r--r--devel/p5-Test-Warn/pkg-plist5
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 03adfe8958da..7c987c0b4b78 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1115,6 +1115,7 @@
SUBDIR += p5-Test-Tester
SUBDIR += p5-Test-Unit
SUBDIR += p5-Test-WWW-Mechanize
+ SUBDIR += p5-Test-Warn
SUBDIR += p5-Text-vFile-asData
SUBDIR += p5-Tie-Array-Sorted
SUBDIR += p5-Tie-Cache
diff --git a/devel/p5-Test-Warn/Makefile b/devel/p5-Test-Warn/Makefile
new file mode 100644
index 000000000000..61fc4786e7e1
--- /dev/null
+++ b/devel/p5-Test-Warn/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Test-Warn
+# Date created: June 18, 2005
+# Whom: Brian Minard <bminard@flatfoot.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Warn
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bminard@flatfoot.ca
+COMMENT= Perl extension to test methods for warnings
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/Array/Compare.pm:${PORTSDIR}/misc/p5-Array-Compare \
+ ${SITE_PERL}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel \
+ ${SITE_PERL}/Tree/DAG_Node.pm:${PORTSDIR}/devel/p5-Tree-DAG_Node
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Test::Warn.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Warn/distinfo b/devel/p5-Test-Warn/distinfo
new file mode 100644
index 000000000000..516438a4ab97
--- /dev/null
+++ b/devel/p5-Test-Warn/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-Warn-0.08.tar.gz) = 95fa7fa694f00ec414a877ae4ef65d7b
+SIZE (Test-Warn-0.08.tar.gz) = 9008
diff --git a/devel/p5-Test-Warn/pkg-descr b/devel/p5-Test-Warn/pkg-descr
new file mode 100644
index 000000000000..a1b24d926f11
--- /dev/null
+++ b/devel/p5-Test-Warn/pkg-descr
@@ -0,0 +1,7 @@
+Test::Warn provides a few convenience methods for testing warning based
+code.
+
+WWW: http://search.cpan.org/dist/Test-Warn/
+
+--Brian
+bminard@flatfoot.ca
diff --git a/devel/p5-Test-Warn/pkg-plist b/devel/p5-Test-Warn/pkg-plist
new file mode 100644
index 000000000000..d25e43d599a5
--- /dev/null
+++ b/devel/p5-Test-Warn/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Warn/.packlist
+%%SITE_PERL%%/Test/Warn.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Warn
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Warn 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/Warn 2>/dev/null || true