aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-14 16:08:43 +0800
committerwen <wen@FreeBSD.org>2010-12-14 16:08:43 +0800
commit4b7644b7cfad51c6e242c4594c6758e21153084a (patch)
treec6fc3b102d3375f8c435c48b84c1de1eaa8867af /devel
parentf65bcf7d297eac72eede823586c0c54647734b3c (diff)
downloadfreebsd-ports-gnome-4b7644b7cfad51c6e242c4594c6758e21153084a.tar.gz
freebsd-ports-gnome-4b7644b7cfad51c6e242c4594c6758e21153084a.tar.zst
freebsd-ports-gnome-4b7644b7cfad51c6e242c4594c6758e21153084a.zip
Test::Script::Run exports some subs to help test and run scripts in your
dist's bin/ directory, if the script path is not absolute. Nearly all the essential code is stolen from Prophet::Test, we think subs like those should live below Test:: namespace, that's why we packed them and created this module. WWW: http://search.cpan.org/dist/Test-Script-Run/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Script-Run/Makefile25
-rw-r--r--devel/p5-Test-Script-Run/distinfo2
-rw-r--r--devel/p5-Test-Script-Run/pkg-descr8
-rw-r--r--devel/p5-Test-Script-Run/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5d63ab478d0f..ae267326c328 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2291,6 +2291,7 @@
SUBDIR += p5-Test-Reporter
SUBDIR += p5-Test-Requires
SUBDIR += p5-Test-Script
+ SUBDIR += p5-Test-Script-Run
SUBDIR += p5-Test-SharedFork
SUBDIR += p5-Test-Simple
SUBDIR += p5-Test-Singleton
diff --git a/devel/p5-Test-Script-Run/Makefile b/devel/p5-Test-Script-Run/Makefile
new file mode 100644
index 000000000000..de826174d587
--- /dev/null
+++ b/devel/p5-Test-Script-Run/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Test-Script-Run
+# Date created: Dec 14, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Script-Run
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Test the script with run
+
+RUN_DEPENDS= p5-IPC-Run3>=0:${PORTSDIR}/devel/p5-IPC-Run3 \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Script::Run.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Script-Run/distinfo b/devel/p5-Test-Script-Run/distinfo
new file mode 100644
index 000000000000..b2e050f6bef3
--- /dev/null
+++ b/devel/p5-Test-Script-Run/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Script-Run-0.04.tar.gz) = 1c28325822d44c203e4579f7062f3c8425e9013a6b3fbbc5b7fb8646dc2dc9d1
+SIZE (Test-Script-Run-0.04.tar.gz) = 24754
diff --git a/devel/p5-Test-Script-Run/pkg-descr b/devel/p5-Test-Script-Run/pkg-descr
new file mode 100644
index 000000000000..9d094fc940b9
--- /dev/null
+++ b/devel/p5-Test-Script-Run/pkg-descr
@@ -0,0 +1,8 @@
+Test::Script::Run exports some subs to help test and run scripts in your
+dist's bin/ directory, if the script path is not absolute.
+
+Nearly all the essential code is stolen from Prophet::Test, we think subs
+like those should live below Test:: namespace, that's why we packed them
+and created this module.
+
+WWW: http://search.cpan.org/dist/Test-Script-Run/
diff --git a/devel/p5-Test-Script-Run/pkg-plist b/devel/p5-Test-Script-Run/pkg-plist
new file mode 100644
index 000000000000..baad4517ab24
--- /dev/null
+++ b/devel/p5-Test-Script-Run/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/Script/Run.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Script/Run/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Script/Run
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Script
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/Script
+@dirrmtry %%SITE_PERL%%/Test