aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-02-12 16:36:50 +0800
committergahr <gahr@FreeBSD.org>2013-02-12 16:36:50 +0800
commit5190465b64de7418d7b9be0fc02fc964fbf977ae (patch)
tree7be4b46abab7d123af0cce7781ecbeea150db0a0 /devel
parent4794bb539e72b8bc9c6828ae273aff4563d243f4 (diff)
downloadfreebsd-ports-gnome-5190465b64de7418d7b9be0fc02fc964fbf977ae.tar.gz
freebsd-ports-gnome-5190465b64de7418d7b9be0fc02fc964fbf977ae.tar.zst
freebsd-ports-gnome-5190465b64de7418d7b9be0fc02fc964fbf977ae.zip
- Make fetchable again by updating to 4.1.2
Changes: - Objects up to 128 MB are now cached by the tbbmalloc. Previously the threshold was 8MB. Objects larger than 128 MB are still processed by direct OS calls. - Concurrent_unordered_multiset and concurrent_unordered_multimap have been added, based on Microsoft* PPL prototype. - Ability to value-initialize a tbb::atomic<T> variable on construction in C++11, with const expressions properly supported. Community Preview Features: - Added a possibility to wait until all worker threads terminate. This is necessary before calling fork() from an application. Bugs fixed: - Fixed data race in tbbmalloc that might lead to memory leaks for large object allocations. - Fixed task_arena::enqueue() to use task_group_context of target arena. - Improved implementation of 64 bit atomics on ia32. Approved by: martymac (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/tbb/Makefile15
-rw-r--r--devel/tbb/distinfo4
2 files changed, 7 insertions, 12 deletions
diff --git a/devel/tbb/Makefile b/devel/tbb/Makefile
index 5b780b75247f..df3ba85b6a18 100644
--- a/devel/tbb/Makefile
+++ b/devel/tbb/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: tbb
-# Date created: 30 Sept 2007
-# Whom: Arun Sharma <arun@sharma-home.net>
-#
+# Created by: Arun Sharma <arun@sharma-home.net>
# $FreeBSD$
-#
PORTNAME= tbb
-PORTVERSION= 4.1.1
+PORTVERSION= 4.1.2
CATEGORIES= devel
MASTER_SITES= http://threadingbuildingblocks.org/sites/default/files/software_releases/source/ \
LOCAL/martymac
-DISTNAME= tbb41_20121003oss_src
+DISTNAME= tbb41_20130116oss_src
EXTRACT_SUFX= .tgz
MAINTAINER= martymac@FreeBSD.org
@@ -25,15 +21,14 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
ALL_TARGET= default
-WRKSRC= ${WRKDIR}/tbb41_20121003oss
+WRKSRC= ${WRKDIR}/tbb41_20130116oss
post-extract:
@${CP} ${WRKSRC}/build/FreeBSD.gcc.inc ${WRKSRC}/build/FreeBSD.${CC}.inc
@${CP} ${FILESDIR}/version_info_FreeBSD.sh ${WRKSRC}/build/
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- -e 's|gcc|${CC}|g' -e 's|g++|${CXX}|g' \
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|g' -e 's|g++|${CXX}|g' \
${WRKSRC}/build/FreeBSD.${CC}.inc
do-install:
diff --git a/devel/tbb/distinfo b/devel/tbb/distinfo
index 47e42a65bc31..c4bc2648744e 100644
--- a/devel/tbb/distinfo
+++ b/devel/tbb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tbb41_20121003oss_src.tgz) = 5383727b9582a54cf4c4adbf22186b70e8eba276fcd3be81d746a937c5b47afc
-SIZE (tbb41_20121003oss_src.tgz) = 2250789
+SHA256 (tbb41_20130116oss_src.tgz) = 4ae2c10899e3b6ef2f686013ec5901fc658444ca90178efaca6014b0665c34b6
+SIZE (tbb41_20130116oss_src.tgz) = 2461689