aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-10-27 22:09:19 +0800
committerjylefort <jylefort@FreeBSD.org>2005-10-27 22:09:19 +0800
commit64d6c92174ee18b422ee2f36298d9d930834b69c (patch)
tree65c3ef9f5eede61db568feca2cf77428dcd0d834 /devel
parent18fdf12fa2a5565bea3a464f63247ae64adc9669 (diff)
downloadfreebsd-ports-gnome-64d6c92174ee18b422ee2f36298d9d930834b69c.tar.gz
freebsd-ports-gnome-64d6c92174ee18b422ee2f36298d9d930834b69c.tar.zst
freebsd-ports-gnome-64d6c92174ee18b422ee2f36298d9d930834b69c.zip
Add cmunge.
CMUNGE is a simple tool for encrypting and compacting C source code, while leaving it syntactically and semantically unchanged. It does this by: * Recursively in-lining `user-defined' #include files. * Renaming C identifiers, except those in the C Standard Library, with names like l1 (i.e. letter-l one), l2, l3, etc. * Removing comments and blank lines, converting multiple consecutive whitespace characters (including `\n') into single blanks, removing all unnecessary whitespace between tokens. * Outputting the transformed code in lines of least N characters long, where N is a user-specified minimum line length. It accepts ANSI and K & R C as its input language. WWW: http://www.vcpc.univie.ac.at/~jhm/cmunge/ PR: ports/88066 Submitted by: Frerich Raabe <frerich.raabe@gmx.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cmunge/Makefile32
-rw-r--r--devel/cmunge/distinfo2
-rw-r--r--devel/cmunge/pkg-descr18
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b87e9711e17c..c042e6fe0694 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -143,6 +143,7 @@
SUBDIR += clint
SUBDIR += clisp-hyperspec
SUBDIR += cmake
+ SUBDIR += cmunge
SUBDIR += cocktail
SUBDIR += codecrusader
SUBDIR += codeville
diff --git a/devel/cmunge/Makefile b/devel/cmunge/Makefile
new file mode 100644
index 000000000000..29d5c2ba5c68
--- /dev/null
+++ b/devel/cmunge/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cmunge
+# Date created: October 26th 2005
+# Whom: Frerich Raabe <frerich.raabe@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cmunge
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.vcpc.univie.ac.at/vcpc/jhm/code/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= frerich.raabe@gmx.de
+COMMENT= A tool for encrypting and compacting C source code
+
+WRKSRC= ${WRKDIR}/cmunger
+MAKE_ARGS= CC="${CC} ${CFLAGS}"
+
+PLIST_FILES= bin/cmunge bin/ctran bin/proc-incl
+PORTDOCS= *
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/ctran ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/proc-incl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/cmunge ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cmunge/distinfo b/devel/cmunge/distinfo
new file mode 100644
index 000000000000..39b0a255a4fb
--- /dev/null
+++ b/devel/cmunge/distinfo
@@ -0,0 +1,2 @@
+MD5 (cmunge.tar.gz) = 1ba149c619cacdfbbaf7ec59281b8cc2
+SIZE (cmunge.tar.gz) = 27591
diff --git a/devel/cmunge/pkg-descr b/devel/cmunge/pkg-descr
new file mode 100644
index 000000000000..bfaaf5f215b6
--- /dev/null
+++ b/devel/cmunge/pkg-descr
@@ -0,0 +1,18 @@
+CMUNGE is a simple tool for encrypting and compacting C source code, while
+leaving it syntactically and semantically unchanged. It does this by:
+
+* Recursively in-lining `user-defined' #include files.
+* Renaming C identifiers, except those in the C Standard Library, with names
+ like l1 (i.e. letter-l one), l2, l3, etc.
+* Removing comments and blank lines, converting multiple consecutive whitespace
+ characters (including `\n') into single blanks, removing all unnecessary
+ whitespace between tokens.
+* Outputting the transformed code in lines of least N characters long, where N
+ is a user-specified minimum line length.
+
+It accepts ANSI and K & R C as its input language.
+
+WWW: http://www.vcpc.univie.ac.at/~jhm/cmunge/
+
+- Frerich Raabe
+frerich.raabe@gmx.de