aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-07-07 19:16:23 +0800
committerwen <wen@FreeBSD.org>2010-07-07 19:16:23 +0800
commit6fc6761fb3a249b3cb93af4da897f1e56a1e37c0 (patch)
tree5b0693edb2b196944b157eaae0757137096b0ce5 /devel
parentf8c0b8916df759f7de7f19ec92ae466c573f3247 (diff)
downloadfreebsd-ports-gnome-6fc6761fb3a249b3cb93af4da897f1e56a1e37c0.tar.gz
freebsd-ports-gnome-6fc6761fb3a249b3cb93af4da897f1e56a1e37c0.tar.zst
freebsd-ports-gnome-6fc6761fb3a249b3cb93af4da897f1e56a1e37c0.zip
- Update to 2.2
Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/py-tables/Makefile6
-rw-r--r--devel/py-tables/distinfo12
-rw-r--r--devel/py-tables/files/patch-setup.py12
3 files changed, 16 insertions, 14 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index a2a67031423c..790ccf129082 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= tables
-PORTVERSION= 2.1.2
+PORTVERSION= 2.2
CATEGORIES= devel python
MASTER_SITES= http://www.pytables.org/download/stable/ \
http://www.pytables.org/download/py${PORTNAME}-${PORTVERSION}/
@@ -18,7 +18,9 @@ EXTRACT_ONLY= tables-${PORTVERSION}.tar.gz
MAINTAINER= wen@FreeBSD.org
COMMENT= A hierarchical database for Python
-BUILD_DEPENDS= ${PYNUMPY}
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${LOCALBASE}/bin/cython:${PORTSDIR}/lang/cython \
+ ${PYTHON_PKGNAMEPREFIX}numexpr>=1.3.1:${PORTSDIR}/math/py-numexpr
LIB_DEPENDS= hdf5.0:${PORTSDIR}/science/hdf5 \
lzo.1:${PORTSDIR}/archivers/lzo \
ucl.1:${PORTSDIR}/archivers/ucl
diff --git a/devel/py-tables/distinfo b/devel/py-tables/distinfo
index a623270ae4c0..2cdbbeccc5f3 100644
--- a/devel/py-tables/distinfo
+++ b/devel/py-tables/distinfo
@@ -1,6 +1,6 @@
-MD5 (tables-2.1.2.tar.gz) = 0033be22577d76fd1689a77afb9975da
-SHA256 (tables-2.1.2.tar.gz) = 948d80fb66693bca67863c4a7dc879dae1d6caa4235df0030ca0cc3220cffa39
-SIZE (tables-2.1.2.tar.gz) = 4677233
-MD5 (pytablesmanual-2.1.2.pdf) = 30c6512a38be9a0d52411fbe9041cb6a
-SHA256 (pytablesmanual-2.1.2.pdf) = 453a77f1e9668862d42c60d94321c1975e61e8cdfcc7cfd3b89a91465818cf4d
-SIZE (pytablesmanual-2.1.2.pdf) = 1738331
+MD5 (tables-2.2.tar.gz) = b95ebb5e501296f30fd75254a689d57b
+SHA256 (tables-2.2.tar.gz) = ef84024e498b91cf973b4ff24b9cc3663ea67c52dacef8df80ee73aed467585b
+SIZE (tables-2.2.tar.gz) = 4700399
+MD5 (pytablesmanual-2.2.pdf) = 61609ed51b1bfab0689dbbc3ca636cb3
+SHA256 (pytablesmanual-2.2.pdf) = 0a147d7b6f21b8a210967dcd15d19c41349906edf33e276914488350915df203
+SIZE (pytablesmanual-2.2.pdf) = 1805982
diff --git a/devel/py-tables/files/patch-setup.py b/devel/py-tables/files/patch-setup.py
index a52666a2ee26..adcb2170851e 100644
--- a/devel/py-tables/files/patch-setup.py
+++ b/devel/py-tables/files/patch-setup.py
@@ -1,17 +1,17 @@
---- setup.py.orig 2009-06-18 17:57:21.000000000 +0800
-+++ setup.py 2009-06-18 18:02:43.000000000 +0800
-@@ -81,8 +81,8 @@
+--- setup.py.orig 2010-07-06 11:11:43.000000000 +0800
++++ setup.py 2010-07-06 11:13:13.000000000 +0800
+@@ -83,8 +83,8 @@
debug = '--debug' in sys.argv
# Global variables
-lib_dirs = []
--inc_dirs = []
+-inc_dirs = ['blosc']
+lib_dirs = ['%%LOCALBASE%%/lib']
-+inc_dirs = ['%%LOCALBASE%%/include']
++inc_dirs = ['blosc','%%LOCALBASE%%/include']
optional_libs = []
data_files = [] # list of data files to add to packages (mainly for DLL's)
-@@ -91,10 +91,10 @@
+@@ -93,10 +93,10 @@
default_runtime_dirs = None
if os.name == 'posix':