aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-04-17 08:18:05 +0800
committerreg <reg@FreeBSD.org>2000-04-17 08:18:05 +0800
commit8b766534122d71052c9f8e5a0752944edf0450f8 (patch)
tree255862bd3b0c32802317a9ddc3193fd714753916 /devel
parente0c8ef49d897de0719277097a1e6578f291f493e (diff)
downloadfreebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.tar.gz
freebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.tar.zst
freebsd-ports-gnome-8b766534122d71052c9f8e5a0752944edf0450f8.zip
Standardize all user defined options to the booleans WITH_FOO and
WITHOUT_FOO. Begin the process of reserving these prefixes for user defined options. No comment by: ports
Diffstat (limited to 'devel')
-rw-r--r--devel/glade/Makefile8
-rw-r--r--devel/glade2/Makefile8
-rw-r--r--devel/kdevelop/Makefile6
-rw-r--r--devel/tclreadline/Makefile12
4 files changed, 17 insertions, 17 deletions
diff --git a/devel/glade/Makefile b/devel/glade/Makefile
index baab79372d33..b6d0cb7d32e2 100644
--- a/devel/glade/Makefile
+++ b/devel/glade/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://glade.pn.org/
MAINTAINER= ade@FreeBSD.org
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
PLIST_GNOME= ${PKGDIR}/PLIST.gnome
.else
@@ -32,13 +32,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/libs"
-.if !defined(USE_GNOME)
+.if !defined(WITH_GNOME)
pre-extract:
- @${ECHO} "You can add hooks for GNOME by defining USE_GNOME"
+ @${ECHO} "You can add hooks for GNOME by defining WITH_GNOME"
.endif
post-patch:
-.if !defined(USE_GNOME)
+.if !defined(WITH_GNOME)
@cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-nognome
.endif
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index baab79372d33..b6d0cb7d32e2 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://glade.pn.org/
MAINTAINER= ade@FreeBSD.org
-.if defined(USE_GNOME)
+.if defined(WITH_GNOME)
LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
PLIST_GNOME= ${PKGDIR}/PLIST.gnome
.else
@@ -32,13 +32,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/libs"
-.if !defined(USE_GNOME)
+.if !defined(WITH_GNOME)
pre-extract:
- @${ECHO} "You can add hooks for GNOME by defining USE_GNOME"
+ @${ECHO} "You can add hooks for GNOME by defining WITH_GNOME"
.endif
post-patch:
-.if !defined(USE_GNOME)
+.if !defined(WITH_GNOME)
@cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${FILESDIR}/patch-nognome
.endif
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index 60e08c91761c..dc8a0f0014a3 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -22,7 +22,7 @@ MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= kdeui.3:${PORTSDIR}/x11/kdelibs11
RUN_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
-.if defined(USE_OPTIONAL_DEPENDS)
+.if defined(WITH_OPTIONAL_DEPENDS)
RUN_DEPENDS+= automake:${PORTSDIR}/devel/automake \
kdbg:${PORTSDIR}/devel/kdbg \
${LOCALBASE}/share/doc/HTML/en/kdelibs/kdecore/index.html:${PORTSDIR}/devel/kdelibdocs \
@@ -45,9 +45,9 @@ SOMAJOR= 1
PLIST_SUB+= LIBVER="${SOMAJOR}"
pre-patch:
-.if !defined(USE_OPTIONAL_DEPENDS)
+.if !defined(WITH_OPTIONAL_DEPENDS)
@${ECHO}
- @${ECHO} "You may define USE_OPTIONAL_DEPENDS (make USE_OPTIONAL_DEPENDS=YES)"
+ @${ECHO} "You may define WITH_OPTIONAL_DEPENDS (make WITH_OPTIONAL_DEPENDS=YES)"
@${ECHO} "to automatically build the suggested programs to compliment kdevelop."
@${ECHO}
@sleep 1
diff --git a/devel/tclreadline/Makefile b/devel/tclreadline/Makefile
index 0181694e9ee4..6b150e3c1d06 100644
--- a/devel/tclreadline/Makefile
+++ b/devel/tclreadline/Makefile
@@ -18,21 +18,21 @@ MANN= tclreadline.n
.include <bsd.port.pre.mk>
-.if (!defined(USE_TCL80) && !defined(USE_TCL82))
+.if (!defined(WITH_TCL80) && !defined(WITH_TCL82))
.if exists(${PREFIX}/bin/tclsh8.0)
-USE_TCL80= YES
+WITH_TCL80= yes
.else
-USE_TCL82= YES
+WITH_TCL82= yes
.endif
.endif
-.if defined(USE_TCL80)
+.if defined(WITH_TCL80)
LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.0 --with-tcl-includes=${PREFIX}/include/tcl8.0
TCLVERMSG= "Building for Tcl 8.0"
.endif
-.if defined(USE_TCL82)
+.if defined(WITH_TCL82)
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
CONFIGURE_ARGS= --with-tcl=${PREFIX}/lib/tcl8.2 --with-tcl-includes=${PREFIX}/include/tcl8.2
TCLVERMSG= "Building for Tcl 8.2"
@@ -40,7 +40,7 @@ TCLVERMSG= "Building for Tcl 8.2"
pre-fetch:
@${ECHO} ${TCLVERMSG}
- @${ECHO} "Define USE_TCL80, or USE_TCL82"
+ @${ECHO} "Define WITH_TCL80, or WITH_TCL82"
@${ECHO} "To compile against a different version of TCL"
.include <bsd.port.post.mk>