aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2010-12-15 01:27:39 +0800
committerskv <skv@FreeBSD.org>2010-12-15 01:27:39 +0800
commitb6360f1c2159ecad08ad169ae8ed49cd20a1ce77 (patch)
tree94a5e5d10d4fa0df0822a4f64b27f017ace9eb6f /devel
parent87c34a050170851c1b4175fd1e89d03a64d75cd8 (diff)
downloadfreebsd-ports-gnome-b6360f1c2159ecad08ad169ae8ed49cd20a1ce77.tar.gz
freebsd-ports-gnome-b6360f1c2159ecad08ad169ae8ed49cd20a1ce77.tar.zst
freebsd-ports-gnome-b6360f1c2159ecad08ad169ae8ed49cd20a1ce77.zip
- Update to 3.0.4
- Use XS versions of some pure-perl modules Changes: http://otrs.org/releases/3.0.4/
Diffstat (limited to 'devel')
-rw-r--r--devel/otrs/Makefile2
-rw-r--r--devel/otrs/distinfo4
-rw-r--r--devel/otrs/files/patch-Kernel-System-Loader.pm31
-rw-r--r--devel/otrs/files/patch-SHA44
-rw-r--r--devel/otrs/files/patch-bin-otrs.CheckModules.pl30
-rw-r--r--devel/otrs/pkg-plist10
6 files changed, 115 insertions, 6 deletions
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 57a26e8d54b2..695ca13195c2 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= otrs
-PORTVERSION= 3.0.3
+PORTVERSION= 3.0.4
CATEGORIES= devel
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
diff --git a/devel/otrs/distinfo b/devel/otrs/distinfo
index d183324a9a1a..b7feaa452774 100644
--- a/devel/otrs/distinfo
+++ b/devel/otrs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (otrs-3.0.3.tar.bz2) = b3927a1719035237e8c70869bcb1d6c52e806655275bc1bd7e8ae704af106dc9
-SIZE (otrs-3.0.3.tar.bz2) = 17297427
+SHA256 (otrs-3.0.4.tar.bz2) = fe941570cfca21475bf50b1a36454a0d05d9f15ccdf7e0a5a9f01ade5bbde49e
+SIZE (otrs-3.0.4.tar.bz2) = 12371950
diff --git a/devel/otrs/files/patch-Kernel-System-Loader.pm b/devel/otrs/files/patch-Kernel-System-Loader.pm
new file mode 100644
index 000000000000..97a74ef05cc6
--- /dev/null
+++ b/devel/otrs/files/patch-Kernel-System-Loader.pm
@@ -0,0 +1,31 @@
+--- Kernel/System/Loader.pm.orig 2010-12-02 18:20:40.000000000 +0000
++++ Kernel/System/Loader.pm 2010-12-02 18:21:30.000000000 +0000
+@@ -19,8 +19,8 @@
+
+ use Kernel::System::CacheInternal;
+
+-use CSS::Minifier qw();
+-use JavaScript::Minifier qw();
++use CSS::Minifier::XS qw();
++use JavaScript::Minifier::XS qw();
+
+ =head1 NAME
+
+@@ -361,7 +361,7 @@
+ return;
+ }
+
+- my $Result = CSS::Minifier::minify( input => $Param{Code} );
++ my $Result = CSS::Minifier::XS::minify( $Param{Code} );
+
+ # a few optimizations can be made for the minified CSS that CSS::Minifier doesn't yet do
+
+@@ -408,7 +408,7 @@
+ return;
+ }
+
+- return JavaScript::Minifier::minify( input => $Param{Code} );
++ return JavaScript::Minifier::XS::minify( $Param{Code} );
+ }
+
+ =item CacheDelete()
diff --git a/devel/otrs/files/patch-SHA b/devel/otrs/files/patch-SHA
new file mode 100644
index 000000000000..3f3ba45f8daa
--- /dev/null
+++ b/devel/otrs/files/patch-SHA
@@ -0,0 +1,44 @@
+--- Kernel/System/CustomerUser/DB.pm.orig 2010-12-03 07:59:29.000000000 +0000
++++ Kernel/System/CustomerUser/DB.pm 2010-12-03 08:00:38.000000000 +0000
+@@ -15,7 +15,7 @@
+ use warnings;
+
+ use Crypt::PasswdMD5 qw(unix_md5_crypt);
+-use Digest::SHA::PurePerl qw(sha1_hex sha256_hex);
++use Digest::SHA qw(sha1_hex sha256_hex);
+
+ use Kernel::System::CheckItem;
+ use Kernel::System::Valid;
+--- Kernel/System/CustomerAuth/DB.pm.orig 2010-12-03 07:59:41.000000000 +0000
++++ Kernel/System/CustomerAuth/DB.pm 2010-12-03 08:00:47.000000000 +0000
+@@ -15,7 +15,7 @@
+ use warnings;
+
+ use Crypt::PasswdMD5 qw(unix_md5_crypt);
+-use Digest::SHA::PurePerl qw(sha1_hex sha256_hex);
++use Digest::SHA qw(sha1_hex sha256_hex);
+
+ use vars qw($VERSION);
+ $VERSION = qw($Revision: 1.32 $) [1];
+--- Kernel/System/User.pm.orig 2010-12-03 07:59:51.000000000 +0000
++++ Kernel/System/User.pm 2010-12-03 08:00:56.000000000 +0000
+@@ -15,7 +15,7 @@
+ use warnings;
+
+ use Crypt::PasswdMD5 qw(unix_md5_crypt);
+-use Digest::SHA::PurePerl qw(sha1_hex sha256_hex);
++use Digest::SHA qw(sha1_hex sha256_hex);
+
+ use Kernel::System::CheckItem;
+ use Kernel::System::Valid;
+--- Kernel/System/Auth/DB.pm.orig 2010-12-03 08:00:03.000000000 +0000
++++ Kernel/System/Auth/DB.pm 2010-12-03 08:01:02.000000000 +0000
+@@ -15,7 +15,7 @@
+ use warnings;
+
+ use Crypt::PasswdMD5 qw(unix_md5_crypt);
+-use Digest::SHA::PurePerl qw(sha1_hex sha256_hex);
++use Digest::SHA qw(sha1_hex sha256_hex);
+
+ use Kernel::System::Valid;
+
diff --git a/devel/otrs/files/patch-bin-otrs.CheckModules.pl b/devel/otrs/files/patch-bin-otrs.CheckModules.pl
new file mode 100644
index 000000000000..958674526d46
--- /dev/null
+++ b/devel/otrs/files/patch-bin-otrs.CheckModules.pl
@@ -0,0 +1,30 @@
+--- bin/otrs.CheckModules.pl.orig 2010-12-02 18:26:47.000000000 +0000
++++ bin/otrs.CheckModules.pl 2010-12-02 18:39:46.000000000 +0000
+@@ -39,7 +39,7 @@
+ Required => 1,
+ },
+ {
+- Module => 'CSS::Minifier',
++ Module => 'CSS::Minifier::XS',
+ Required => 1,
+ },
+ {
+@@ -64,7 +64,7 @@
+ Required => 1,
+ },
+ {
+- Module => 'Digest::SHA::PurePerl',
++ Module => 'Digest::SHA',
+ Version => '5.48',
+ Required => 1,
+ Comment => 'Required to authenticate users and customers using SHA-1 or SHA-2 methods',
+@@ -111,8 +111,7 @@
+ Required => 1,
+ },
+ {
+- Module => 'JavaScript::Minifier',
+- Version => '1.05',
++ Module => 'JavaScript::Minifier::XS',
+ Required => 1,
+ },
+ {
diff --git a/devel/otrs/pkg-plist b/devel/otrs/pkg-plist
index fca02581198f..21e37d56ce86 100644
--- a/devel/otrs/pkg-plist
+++ b/devel/otrs/pkg-plist
@@ -267,6 +267,7 @@ otrs/var/httpd/htdocs/js/Core.UI.RichTextEditor.js
otrs/var/httpd/htdocs/js/Core.UI.Table.Sort.js
otrs/var/httpd/htdocs/js/Core.UI.Table.js
otrs/var/httpd/htdocs/js/Core.UI.js
+otrs/var/httpd/htdocs/js/test/Core.AJAX.UnitTest.js
otrs/var/httpd/htdocs/js/test/Core.Config.UnitTest.js
otrs/var/httpd/htdocs/js/test/Core.Data.UnitTest.js
otrs/var/httpd/htdocs/js/test/Core.Debug.UnitTest.js
@@ -275,6 +276,8 @@ otrs/var/httpd/htdocs/js/test/Core.JSON.UnitTest.js
otrs/var/httpd/htdocs/js/test/Core.JavaScriptEnhancements.UnitTest.js
otrs/var/httpd/htdocs/js/test/Core.UI.Accessibility.UnitTest.js
otrs/var/httpd/htdocs/js/test/JSUnitTest.html
+otrs/var/httpd/htdocs/js/test/sample/Core.AJAX.ContentUpdate1.html
+otrs/var/httpd/htdocs/js/test/sample/Core.AJAX.FunctionCall1.html
otrs/var/httpd/htdocs/js/thirdparty/ckeditor-3.4.2/.htaccess
otrs/var/httpd/htdocs/js/thirdparty/ckeditor-3.4.2/CHANGES.html
otrs/var/httpd/htdocs/js/thirdparty/ckeditor-3.4.2/INSTALL.html
@@ -510,7 +513,7 @@ otrs/var/httpd/htdocs/js/thirdparty/flot-0.6/jquery.flot.js
otrs/var/httpd/htdocs/js/thirdparty/jquery-1.4.4/jquery.js
otrs/var/httpd/htdocs/js/thirdparty/jquery-tablesorter-2.0.5/jquery.tablesorter.js
otrs/var/httpd/htdocs/js/thirdparty/jquery-tooltip-1.3/jquery.tooltip.js
-otrs/var/httpd/htdocs/js/thirdparty/jquery-ui-1.8.5/jquery-ui.js
+otrs/var/httpd/htdocs/js/thirdparty/jquery-ui-1.8.6/jquery-ui.js
otrs/var/httpd/htdocs/js/thirdparty/jquery-validate-1.7/jquery.validate.js
otrs/var/httpd/htdocs/js/thirdparty/json/json2.js
otrs/var/httpd/htdocs/js/thirdparty/qunit/qunit.css
@@ -816,7 +819,7 @@ otrs/var/httpd/htdocs/skins/Customer/default/img/tr_bg.png
otrs/var/httpd/htdocs/skins/Customer/default/img/tr_hover.png
otrs/var/httpd/htdocs/skins/Customer/default/img/tr_hover_next_bg.png
otrs/var/httpd/htdocs/skins/Customer/ivory/css/Core.Default.css
-otrs/var/packages/Support-1.2.5.opm
+otrs/var/packages/Support-1.2.6.opm
otrs/var/packages/iPhoneHandle-1.0.2.opm
otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilEscalationDeadlineExpires.de.xml
otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilEscalationDeadlineExpires.en.xml
@@ -1469,7 +1472,7 @@ otrs/Kernel/System/XMLMaster.pm
@dirrm otrs/var/httpd/htdocs/js/thirdparty/stacktrace
@dirrm otrs/var/httpd/htdocs/js/thirdparty/json
@dirrm otrs/var/httpd/htdocs/js/thirdparty/jquery-validate-1.7
-@dirrm otrs/var/httpd/htdocs/js/thirdparty/jquery-ui-1.8.5
+@dirrm otrs/var/httpd/htdocs/js/thirdparty/jquery-ui-1.8.6
@dirrm otrs/var/httpd/htdocs/js/thirdparty/jquery-tooltip-1.3
@dirrm otrs/var/httpd/htdocs/js/thirdparty/jquery-tablesorter-2.0.5
@dirrm otrs/var/httpd/htdocs/js/thirdparty/jquery-1.4.4
@@ -1556,6 +1559,7 @@ otrs/Kernel/System/XMLMaster.pm
@dirrm otrs/var/httpd/htdocs/js/thirdparty/ckeditor-3.4.2/adapters
@dirrm otrs/var/httpd/htdocs/js/thirdparty/ckeditor-3.4.2
@dirrm otrs/var/httpd/htdocs/js/thirdparty
+@dirrm otrs/var/httpd/htdocs/js/test/sample
@dirrm otrs/var/httpd/htdocs/js/test
@dirrm otrs/var/httpd/htdocs/js
@dirrm otrs/var/httpd/htdocs