aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-02-10 16:57:45 +0800
committeraz <az@FreeBSD.org>2013-02-10 16:57:45 +0800
commitd4663cb8871e45e8e41b2d98b6fb6a63680b4902 (patch)
tree3a82f57651fbffd6b4aaf87d29836ad02d5d24dc /devel
parent219874f468dd78efe07c53628f28af35c5864d33 (diff)
downloadfreebsd-ports-gnome-d4663cb8871e45e8e41b2d98b6fb6a63680b4902.tar.gz
freebsd-ports-gnome-d4663cb8871e45e8e41b2d98b6fb6a63680b4902.tar.zst
freebsd-ports-gnome-d4663cb8871e45e8e41b2d98b6fb6a63680b4902.zip
- Update to version 1.03
- Add LICENSE - Trim Makefile header PR: ports/175830 Submitted by: Vivek Khera <vivek@khera.org> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Event-RPC/Makefile21
-rw-r--r--devel/p5-Event-RPC/distinfo4
-rw-r--r--devel/p5-Event-RPC/pkg-descr7
-rw-r--r--devel/p5-Event-RPC/pkg-plist1
4 files changed, 21 insertions, 12 deletions
diff --git a/devel/p5-Event-RPC/Makefile b/devel/p5-Event-RPC/Makefile
index 0df1c63fb7e2..6636f58c4c3b 100644
--- a/devel/p5-Event-RPC/Makefile
+++ b/devel/p5-Event-RPC/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: p5-Event-RPC
-# Date created: Tue May 16 10:45:27 EDT 2006
-# Whom: Vivek Khera <vivek@khera.org>
-#
+# Created by: Vivek Khera <vivek@khera.org>
# $FreeBSD$
-#
PORTNAME= Event-RPC
-PORTVERSION= 1.01
+PORTVERSION= 1.03
CATEGORIES= devel net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,6 +10,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vivek@khera.org
COMMENT= Event based transparent Client/Server RPC framework
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
PERL_CONFIGURE= yes
MAN3= Event::RPC.3 \
@@ -22,13 +21,15 @@ MAN3= Event::RPC.3 \
Event::RPC::LogConnection.3 \
Event::RPC::Logger.3 \
Event::RPC::Loop.3 \
+ Event::RPC::Loop::AnyEvent.3 \
Event::RPC::Loop::Event.3 \
Event::RPC::Loop::Glib.3 \
Event::RPC::Message.3 \
Event::RPC::Server.3
-OPTIONS= GLIB "Use Glib event handler" off \
- EVENT "Use Event.pm event handler" on \
+OPTIONS= GLIB "Register dependency to Glib event handler" off \
+ EVENT "Register dependency to Event.pm event handler" on \
+ ANYEVENT "Register dependency to AnyEvent event handler" on \
SSL "Register dependency to SSL lib" on
.include <bsd.port.pre.mk>
@@ -39,6 +40,10 @@ BUILD_DEPENDS= p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
BUILD_DEPENDS+= p5-Event>=0:${PORTSDIR}/devel/p5-Event
.endif
+.if defined(WITH_ANYEVENT)
+BUILD_DEPENDS+= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent
+.endif
+
.if defined(WITH_GLIB)
BUILD_DEPENDS+= p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2
.endif
diff --git a/devel/p5-Event-RPC/distinfo b/devel/p5-Event-RPC/distinfo
index 2c1fbfebd1e8..2d47051b616b 100644
--- a/devel/p5-Event-RPC/distinfo
+++ b/devel/p5-Event-RPC/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Event-RPC-1.01.tar.gz) = 4a4d086630fc8af6fd84cc8053ab0483fa3712a42d320e75e51027319ca46ce4
-SIZE (Event-RPC-1.01.tar.gz) = 35011
+SHA256 (Event-RPC-1.03.tar.gz) = e97e96bc9294d8b3466cf9fcf4a157650ad1483dda3dd02d1b11793cbc429983
+SIZE (Event-RPC-1.03.tar.gz) = 47011
diff --git a/devel/p5-Event-RPC/pkg-descr b/devel/p5-Event-RPC/pkg-descr
index af440c8f3432..82c387307ffc 100644
--- a/devel/p5-Event-RPC/pkg-descr
+++ b/devel/p5-Event-RPC/pkg-descr
@@ -2,6 +2,9 @@ Event::RPC supports you in developing Event based networking client/server
applications with transparent object/method access from the client to the
server. Network communication is optionally encrypted using IO::Socket::SSL.
Several event loop managers are supported due to an extensible API. Currently
-Event and Glib are implemented.
+Event, Glib and AnyEvent are implemented. The latter lets you use nearly every
+event loop implementation available for Perl. AnyEvent was invented after
+Event::RPC was created and thus Event::RPC started using it's own abstraction
+model.
-WWW: http://search.cpan.org/dist/Event::RPC/
+WWW: http://search.cpan.org/dist/Event-RPC/
diff --git a/devel/p5-Event-RPC/pkg-plist b/devel/p5-Event-RPC/pkg-plist
index 498eafcc40fd..23280c76ba4e 100644
--- a/devel/p5-Event-RPC/pkg-plist
+++ b/devel/p5-Event-RPC/pkg-plist
@@ -5,6 +5,7 @@
%%SITE_PERL%%/Event/RPC/LogConnection.pm
%%SITE_PERL%%/Event/RPC/Logger.pm
%%SITE_PERL%%/Event/RPC/Loop.pm
+%%SITE_PERL%%/Event/RPC/Loop/AnyEvent.pm
%%SITE_PERL%%/Event/RPC/Loop/Event.pm
%%SITE_PERL%%/Event/RPC/Loop/Glib.pm
%%SITE_PERL%%/Event/RPC/Message.pm