aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2012-12-13 18:36:08 +0800
committertobez <tobez@FreeBSD.org>2012-12-13 18:36:08 +0800
commitd5f61ab5202cc9a0b0e7b4002944c6142fb00bc3 (patch)
treeb1173c80d1f80d14dff9a3fa769494ae2d601d30 /devel
parent33ac6a5d77ab11ab52caebbe8ea3647aee032b21 (diff)
downloadfreebsd-ports-gnome-d5f61ab5202cc9a0b0e7b4002944c6142fb00bc3.tar.gz
freebsd-ports-gnome-d5f61ab5202cc9a0b0e7b4002944c6142fb00bc3.tar.zst
freebsd-ports-gnome-d5f61ab5202cc9a0b0e7b4002944c6142fb00bc3.zip
Add devel/p5-Data-Thunk 0.07, a Perl module implementing lazy evaluation.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Thunk/Makefile29
-rw-r--r--devel/p5-Data-Thunk/distinfo2
-rw-r--r--devel/p5-Data-Thunk/pkg-descr5
-rw-r--r--devel/p5-Data-Thunk/pkg-plist9
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f675ff677df0..d00a53d7aed2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1655,6 +1655,7 @@
SUBDIR += p5-Data-TemporaryBag
SUBDIR += p5-Data-Throttler
SUBDIR += p5-Data-Throttler-Memcached
+ SUBDIR += p5-Data-Thunk
SUBDIR += p5-Data-TreeDumper
SUBDIR += p5-Data-TreeDumper-Renderer-GTK
SUBDIR += p5-Data-Types
diff --git a/devel/p5-Data-Thunk/Makefile b/devel/p5-Data-Thunk/Makefile
new file mode 100644
index 000000000000..762620627db0
--- /dev/null
+++ b/devel/p5-Data-Thunk/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= Data-Thunk
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:FLORA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Lazy/deferred evaluation - a sneakier Scalar::Defer
+
+BUILD_DEPENDS= p5-Check-ISA>=0:${PORTSDIR}/devel/p5-Check-ISA \
+ p5-Data-Swap>=0:${PORTSDIR}/devel/p5-Data-Swap \
+ p5-Devel-Refcount>=0:${PORTSDIR}/devel/p5-Devel-Refcount \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-UNIVERSAL-ref>=0:${PORTSDIR}/devel/p5-UNIVERSAL-ref \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Thunk.3 \
+ Data::Thunk::Code.3 \
+ Data::Thunk::Object.3 \
+ Data::Thunk::ScalarValue.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Thunk/distinfo b/devel/p5-Data-Thunk/distinfo
new file mode 100644
index 000000000000..cb66eed3657e
--- /dev/null
+++ b/devel/p5-Data-Thunk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Data-Thunk-0.07.tar.gz) = 0d079ce4c7c7640be9d1eff93d26540decb70557cc686464a154641744620dd4
+SIZE (Data-Thunk-0.07.tar.gz) = 8152
diff --git a/devel/p5-Data-Thunk/pkg-descr b/devel/p5-Data-Thunk/pkg-descr
new file mode 100644
index 000000000000..04d36a795527
--- /dev/null
+++ b/devel/p5-Data-Thunk/pkg-descr
@@ -0,0 +1,5 @@
+This is an implementation of thunks a la Scalar::Defer, but uses
+Data::Swap and assignment to $_[0] in order to leave a minimal trace of
+the thunk.
+
+WWW: http://search.cpan.org/dist/Data-Thunk/
diff --git a/devel/p5-Data-Thunk/pkg-plist b/devel/p5-Data-Thunk/pkg-plist
new file mode 100644
index 000000000000..aebc9e3a1a12
--- /dev/null
+++ b/devel/p5-Data-Thunk/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Data/Thunk.pm
+%%SITE_PERL%%/Data/Thunk/Code.pm
+%%SITE_PERL%%/Data/Thunk/Object.pm
+%%SITE_PERL%%/Data/Thunk/ScalarValue.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Thunk/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Thunk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data/Thunk
+@dirrmtry %%SITE_PERL%%/Data