aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2010-10-07 08:21:56 +0800
committersahil <sahil@FreeBSD.org>2010-10-07 08:21:56 +0800
commitd60ad14879b8f7f8e87b5f0a0c10b7c81384f29e (patch)
tree663b1592ffa6cd310c8fedecf7588636b3c957b5 /devel
parent9708805820909b99c577a51222773bce9f841e43 (diff)
downloadfreebsd-ports-gnome-d60ad14879b8f7f8e87b5f0a0c10b7c81384f29e.tar.gz
freebsd-ports-gnome-d60ad14879b8f7f8e87b5f0a0c10b7c81384f29e.tar.zst
freebsd-ports-gnome-d60ad14879b8f7f8e87b5f0a0c10b7c81384f29e.zip
This module provides a 'parallel map'. Multiple worker processes are
forked so that many instances of the transformation function may be executed simultaneously. WWW: http://search.cpan.org/dist/Parallel-Iterator/ PR: ports/151117 Submitted by: Frederic Culot <frederic@culot.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Parallel-Iterator/Makefile21
-rw-r--r--devel/p5-Parallel-Iterator/distinfo3
-rw-r--r--devel/p5-Parallel-Iterator/pkg-descr5
-rw-r--r--devel/p5-Parallel-Iterator/pkg-plist2
5 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fc7e5aaaa8f6..77b62ce48fb6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1991,6 +1991,7 @@
SUBDIR += p5-Package-Stash
SUBDIR += p5-PadWalker
SUBDIR += p5-Parallel-ForkManager
+ SUBDIR += p5-Parallel-Iterator
SUBDIR += p5-Parallel-Prefork
SUBDIR += p5-Params-CallbackRequest
SUBDIR += p5-Params-Check
diff --git a/devel/p5-Parallel-Iterator/Makefile b/devel/p5-Parallel-Iterator/Makefile
new file mode 100644
index 000000000000..c4ebed0c2eb7
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Parallel-Iterator
+# Date created: 2010-09-30
+# Whom: Frederic Culot <frederic@culot.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parallel-Iterator
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= frederic@culot.org
+COMMENT= Simple parallel execution
+
+PERL_MODBUILD= 5.8.0+
+
+MAN3= Parallel::Iterator.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Parallel-Iterator/distinfo b/devel/p5-Parallel-Iterator/distinfo
new file mode 100644
index 000000000000..55e128e1b60d
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/distinfo
@@ -0,0 +1,3 @@
+MD5 (Parallel-Iterator-1.00.tar.gz) = 879051d329ea79f59eb4b03bb0bf7c87
+SHA256 (Parallel-Iterator-1.00.tar.gz) = e8495095cf5746a14e154037b11b0d911da2a32283b77291abb37bf6311345f4
+SIZE (Parallel-Iterator-1.00.tar.gz) = 15227
diff --git a/devel/p5-Parallel-Iterator/pkg-descr b/devel/p5-Parallel-Iterator/pkg-descr
new file mode 100644
index 000000000000..51cc7a6831ca
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a 'parallel map'. Multiple worker processes are
+forked so that many instances of the transformation function may be
+executed simultaneously.
+
+WWW: http://search.cpan.org/dist/Parallel-Iterator/
diff --git a/devel/p5-Parallel-Iterator/pkg-plist b/devel/p5-Parallel-Iterator/pkg-plist
new file mode 100644
index 000000000000..417e0d84b46f
--- /dev/null
+++ b/devel/p5-Parallel-Iterator/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Parallel/Iterator.pm
+@dirrmtry %%SITE_PERL%%/Parallel