aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-07-04 16:58:11 +0800
committerwen <wen@FreeBSD.org>2010-07-04 16:58:11 +0800
commitd743fbef1bf576fc1c6e27467e1eec0c82f64296 (patch)
treeb25d4e4fceae04d116cdd57617a3bd5891b4ba9e /devel
parent3902d4ad373a44073544aabd1714ade33bf71376 (diff)
downloadfreebsd-ports-gnome-d743fbef1bf576fc1c6e27467e1eec0c82f64296.tar.gz
freebsd-ports-gnome-d743fbef1bf576fc1c6e27467e1eec0c82f64296.tar.zst
freebsd-ports-gnome-d743fbef1bf576fc1c6e27467e1eec0c82f64296.zip
- Update to 3.0
PR: ports/147870 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com> (maintainer) Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/tbb/Makefile14
-rw-r--r--devel/tbb/distinfo6
-rw-r--r--devel/tbb/pkg-plist94
3 files changed, 63 insertions, 51 deletions
diff --git a/devel/tbb/Makefile b/devel/tbb/Makefile
index 6f2716d425c8..97bde9076fe9 100644
--- a/devel/tbb/Makefile
+++ b/devel/tbb/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= tbb
-PORTVERSION= 2.2
+PORTVERSION= 3.0
CATEGORIES= devel
-MASTER_SITES= http://www.threadingbuildingblocks.org/uploads/78/140/2.2/
-DISTNAME= tbb22_004oss_src
+MASTER_SITES= http://www.threadingbuildingblocks.org/uploads/78/154/3.0/
+DISTNAME= tbb30_018oss_src
EXTRACT_SUFX= .tgz
MAINTAINER= ganael.laplanche@martymac.com
@@ -21,7 +21,7 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
ALL_TARGET= default
-WRKSRC= ${WRKDIR}/tbb22_004oss
+WRKSRC= ${WRKDIR}/tbb30_018oss
post-extract:
@${CP} ${FILESDIR}/version_info_FreeBSD.sh ${WRKSRC}/build/
@@ -32,9 +32,11 @@ post-patch:
do-install:
cd ${WRKSRC}; \
${INSTALL_DATA} build/FreeBSD*release/libtbb.so \
- ${PREFIX}/lib/libtbb.so; \
+ ${PREFIX}/lib/libtbb.so.3; \
+ ${LN} -fs ${PREFIX}/lib/libtbb.so.3 ${PREFIX}/lib/libtbb.so; \
${INSTALL_DATA} build/FreeBSD*release/libtbbmalloc.so \
- ${PREFIX}/lib/libtbbmalloc.so; \
+ ${PREFIX}/lib/libtbbmalloc.so.3; \
+ ${LN} -fs ${PREFIX}/lib/libtbbmalloc.so.3 ${PREFIX}/lib/libtbbmalloc.so; \
${MKDIR} ${PREFIX}/include/tbb/; \
cd include/tbb/ && ${COPYTREE_SHARE} \* ${PREFIX}/include/tbb/
diff --git a/devel/tbb/distinfo b/devel/tbb/distinfo
index 60969e012e02..565183eabb4a 100644
--- a/devel/tbb/distinfo
+++ b/devel/tbb/distinfo
@@ -1,3 +1,3 @@
-MD5 (tbb22_004oss_src.tgz) = 98b46b075f96f13d2695476b8de058a2
-SHA256 (tbb22_004oss_src.tgz) = d4f8227af4d9f65241ab9d9b441f4ac1e17e13ca4b36a2dc2b4111920635e04d
-SIZE (tbb22_004oss_src.tgz) = 1471837
+MD5 (tbb30_018oss_src.tgz) = 3907331f6b978f15c5fdf1047bdaafcc
+SHA256 (tbb30_018oss_src.tgz) = 6a6e79ae3866ddaea664ae0e93e31563f16024a950c11be52a441c0c91ef62e7
+SIZE (tbb30_018oss_src.tgz) = 1550402
diff --git a/devel/tbb/pkg-plist b/devel/tbb/pkg-plist
index cffe64a22a53..320e6fdbfe81 100644
--- a/devel/tbb/pkg-plist
+++ b/devel/tbb/pkg-plist
@@ -1,61 +1,71 @@
-include/tbb/machine/linux_ia32.h
-include/tbb/machine/windows_ia32.h
-include/tbb/machine/linux_common.h
-include/tbb/machine/ibm_aix51.h
-include/tbb/machine/linux_intel64.h
-include/tbb/machine/windows_intel64.h
-include/tbb/machine/linux_ia64.h
-include/tbb/machine/mac_ppc.h
+include/tbb/task.h
+include/tbb/parallel_while.h
include/tbb/task_scheduler_init.h
-include/tbb/tbbmalloc_proxy.h
-include/tbb/combinable.h
+include/tbb/tbb_config.h
include/tbb/tbb_exception.h
+include/tbb/critical_section.h
+include/tbb/index.html
+include/tbb/parallel_invoke.h
+include/tbb/combinable.h
+include/tbb/parallel_reduce.h
include/tbb/tbb_stddef.h
-include/tbb/blocked_range2d.h
+include/tbb/concurrent_queue.h
+include/tbb/partitioner.h
+include/tbb/parallel_do.h
+include/tbb/mutex.h
+include/tbb/atomic.h
+include/tbb/queuing_rw_mutex.h
+include/tbb/tick_count.h
+include/tbb/parallel_for.h
+include/tbb/recursive_mutex.h
+include/tbb/machine/sunos_sparc.h
+include/tbb/machine/xbox360_ppc.h
+include/tbb/machine/mac_ppc.h
+include/tbb/machine/ibm_aix51.h
+include/tbb/machine/linux_ia32.h
+include/tbb/machine/linux_ia64.h
+include/tbb/machine/linux_common.h
+include/tbb/machine/windows_intel64.h
+include/tbb/machine/linux_intel64.h
+include/tbb/machine/windows_ia32.h
include/tbb/concurrent_vector.h
-include/tbb/tbb.h
-include/tbb/tbb_machine.h
include/tbb/parallel_for_each.h
-include/tbb/tbb_config.h
-include/tbb/scalable_allocator.h
-include/tbb/mutex.h
-include/tbb/compat/ppl.h
-include/tbb/blocked_range3d.h
-include/tbb/task_scheduler_observer.h
-include/tbb/index.html
-include/tbb/_tbb_windef.h
-include/tbb/queuing_mutex.h
include/tbb/tbb_allocator.h
-include/tbb/cache_aligned_allocator.h
-include/tbb/tick_count.h
+include/tbb/queuing_mutex.h
+include/tbb/_concurrent_unordered_internal.h
+include/tbb/blocked_range2d.h
include/tbb/parallel_sort.h
-include/tbb/parallel_invoke.h
-include/tbb/spin_mutex.h
-include/tbb/spin_rw_mutex.h
-include/tbb/null_rw_mutex.h
-include/tbb/parallel_reduce.h
-include/tbb/_concurrent_queue_internal.h
+include/tbb/task_scheduler_observer.h
include/tbb/blocked_range.h
include/tbb/parallel_scan.h
-include/tbb/parallel_for.h
-include/tbb/task.h
-include/tbb/queuing_rw_mutex.h
-include/tbb/parallel_do.h
-include/tbb/concurrent_queue.h
-include/tbb/null_mutex.h
+include/tbb/null_rw_mutex.h
+include/tbb/spin_rw_mutex.h
+include/tbb/blocked_range3d.h
+include/tbb/_concurrent_queue_internal.h
include/tbb/pipeline.h
-include/tbb/partitioner.h
-include/tbb/recursive_mutex.h
-include/tbb/task_group.h
+include/tbb/compat/ppl.h
+include/tbb/compat/thread
+include/tbb/compat/condition_variable
+include/tbb/spin_mutex.h
+include/tbb/tbbmalloc_proxy.h
+include/tbb/concurrent_unordered_map.h
+include/tbb/cache_aligned_allocator.h
+include/tbb/_tbb_windef.h
+include/tbb/tbb.h
+include/tbb/tbb_machine.h
+include/tbb/scalable_allocator.h
+include/tbb/tbb_thread.h
include/tbb/tbb_profiling.h
include/tbb/enumerable_thread_specific.h
-include/tbb/tbb_thread.h
include/tbb/aligned_space.h
-include/tbb/atomic.h
include/tbb/concurrent_hash_map.h
-include/tbb/parallel_while.h
+include/tbb/null_mutex.h
+include/tbb/reader_writer_lock.h
+include/tbb/task_group.h
@dirrm include/tbb/machine
@dirrm include/tbb/compat
@dirrm include/tbb
lib/libtbb.so
+lib/libtbb.so.3
lib/libtbbmalloc.so
+lib/libtbbmalloc.so.3