aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-10 09:23:45 +0800
committeraaron <aaron@FreeBSD.org>2006-05-10 09:23:45 +0800
commitdc1dda81ed1b251e2a750fd386953bebe7122e05 (patch)
treeb266ba2b0223b9f31e77e4f2543e0b09851b7eb0 /devel
parent2d4518a7dd1a4603e0d6b1485e6ad982aa3453e3 (diff)
downloadfreebsd-ports-gnome-dc1dda81ed1b251e2a750fd386953bebe7122e05.tar.gz
freebsd-ports-gnome-dc1dda81ed1b251e2a750fd386953bebe7122e05.tar.zst
freebsd-ports-gnome-dc1dda81ed1b251e2a750fd386953bebe7122e05.zip
Add p5-File-Cat 1.2, perl implementation of cat.
PR: ports/93882 Submitted by: Jason Heiss <jheiss@aput.biz> Approved by: tobez (implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Cat/Makefile22
-rw-r--r--devel/p5-File-Cat/distinfo2
-rw-r--r--devel/p5-File-Cat/pkg-descr3
-rw-r--r--devel/p5-File-Cat/pkg-plist5
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6248152ee73e..c8d8e6226501 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -956,6 +956,7 @@
SUBDIR += p5-File-BasicFlock
SUBDIR += p5-File-Binary
SUBDIR += p5-File-Cache
+ SUBDIR += p5-File-Cat
SUBDIR += p5-File-Copy-Recursive
SUBDIR += p5-File-DirSync
SUBDIR += p5-File-FTS
diff --git a/devel/p5-File-Cat/Makefile b/devel/p5-File-Cat/Makefile
new file mode 100644
index 000000000000..13ba1b0a22d5
--- /dev/null
+++ b/devel/p5-File-Cat/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-File-Cat
+# Date created: 19 March 2005
+# Whom: Jason Heiss <jheiss@aput.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Cat
+PORTVERSION= 1.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl implementation of cat
+
+PERL_CONFIGURE= YES
+
+MAN3= File::Cat.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Cat/distinfo b/devel/p5-File-Cat/distinfo
new file mode 100644
index 000000000000..c07c8abfeecd
--- /dev/null
+++ b/devel/p5-File-Cat/distinfo
@@ -0,0 +1,2 @@
+MD5 (File-Cat-1.2.tar.gz) = 300600b3786cec4360e88947f775f4fb
+SIZE (File-Cat-1.2.tar.gz) = 2026
diff --git a/devel/p5-File-Cat/pkg-descr b/devel/p5-File-Cat/pkg-descr
new file mode 100644
index 000000000000..9943b8dce7ca
--- /dev/null
+++ b/devel/p5-File-Cat/pkg-descr
@@ -0,0 +1,3 @@
+File::Cat is a module of adventure, danger, and low cunning. With it,
+you will explore some of the most inane programs ever seen by mortals.
+No computer should be without one!
diff --git a/devel/p5-File-Cat/pkg-plist b/devel/p5-File-Cat/pkg-plist
new file mode 100644
index 000000000000..6b8aeafdb1c5
--- /dev/null
+++ b/devel/p5-File-Cat/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/Cat.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Cat/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Cat
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File