aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-16 01:21:56 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-16 01:21:56 +0800
commitdd64660abd3e50f55c43bf3cc6422312929afacc (patch)
tree382a45fd59d5b83c2dfb6b94958fb359d5214917 /devel
parentbaa62d89b811800e4c8eb24f17b0f2c072267300 (diff)
downloadfreebsd-ports-gnome-dd64660abd3e50f55c43bf3cc6422312929afacc.tar.gz
freebsd-ports-gnome-dd64660abd3e50f55c43bf3cc6422312929afacc.tar.zst
freebsd-ports-gnome-dd64660abd3e50f55c43bf3cc6422312929afacc.zip
Convert USE_GLIB into USE_GNOMENG+USE_GNOME.
Diffstat (limited to 'devel')
-rw-r--r--devel/getxml/Makefile3
-rw-r--r--devel/hat/Makefile3
-rw-r--r--devel/hs-hat/Makefile3
-rw-r--r--devel/libole2/Makefile3
-rw-r--r--devel/liboop/Makefile3
-rw-r--r--devel/libsoup/Makefile3
-rw-r--r--devel/libsoup22/Makefile3
-rw-r--r--devel/orbitcpp/Makefile3
-rw-r--r--devel/py-orbit/Makefile3
-rw-r--r--devel/py-orbit2/Makefile3
-rw-r--r--devel/silc-toolkit/Makefile3
-rw-r--r--devel/soup/Makefile3
12 files changed, 24 insertions, 12 deletions
diff --git a/devel/getxml/Makefile b/devel/getxml/Makefile
index f7259d09ecfd..2300164b1317 100644
--- a/devel/getxml/Makefile
+++ b/devel/getxml/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
post-patch:
diff --git a/devel/hat/Makefile b/devel/hat/Makefile
index 58056e220ab6..140c6477ee27 100644
--- a/devel/hat/Makefile
+++ b/devel/hat/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
.if !defined(WITH_GHC) || defined(WITHOUT_NHC98)
ALL_TARGET= hat
.endif
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 58056e220ab6..140c6477ee27 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
.if !defined(WITH_GHC) || defined(WITHOUT_NHC98)
ALL_TARGET= hat
.endif
diff --git a/devel/libole2/Makefile b/devel/libole2/Makefile
index c38053b7bfc7..4b05983a7d7e 100644
--- a/devel/libole2/Makefile
+++ b/devel/libole2/Makefile
@@ -14,7 +14,8 @@ MASTER_SITE_SUBDIR= unstable/sources/libole2
MAINTAINER= gnome@FreeBSD.org
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/devel/liboop/Makefile b/devel/liboop/Makefile
index 4583ab750161..2591c1b2b1cc 100644
--- a/devel/liboop/Makefile
+++ b/devel/liboop/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= adns.1:${PORTSDIR}/net/adns \
wwwcore.1:${PORTSDIR}/www/libwww
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index fb5d022dd73e..7dd00661a1d2 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
diff --git a/devel/libsoup22/Makefile b/devel/libsoup22/Makefile
index fb5d022dd73e..7dd00661a1d2 100644
--- a/devel/libsoup22/Makefile
+++ b/devel/libsoup22/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index 67151454fce5..1f573f08e567 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -17,7 +17,8 @@ BROKEN= "Does not build"
LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/devel/py-orbit/Makefile b/devel/py-orbit/Makefile
index 10d8fbdf4d81..125cdd783ef0 100644
--- a/devel/py-orbit/Makefile
+++ b/devel/py-orbit/Makefile
@@ -19,7 +19,8 @@ MAINTAINER= wjv@FreeBSD.org
LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
USE_PYTHON= yes
diff --git a/devel/py-orbit2/Makefile b/devel/py-orbit2/Makefile
index 10d8fbdf4d81..125cdd783ef0 100644
--- a/devel/py-orbit2/Makefile
+++ b/devel/py-orbit2/Makefile
@@ -19,7 +19,8 @@ MAINTAINER= wjv@FreeBSD.org
LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
USE_PYTHON= yes
diff --git a/devel/silc-toolkit/Makefile b/devel/silc-toolkit/Makefile
index c335c86aafc0..bdbff9b15b22 100644
--- a/devel/silc-toolkit/Makefile
+++ b/devel/silc-toolkit/Makefile
@@ -26,7 +26,8 @@ RUN_DEPENDS= silc:${PORTSDIR}/net/silc-client
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME} \
--with-docdir=${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX} \
--with-etcdir=${PREFIX}/etc/${PORTNAME} \
diff --git a/devel/soup/Makefile b/devel/soup/Makefile
index fb5d022dd73e..7dd00661a1d2 100644
--- a/devel/soup/Makefile
+++ b/devel/soup/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc