aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-07 23:10:33 +0800
committerpav <pav@FreeBSD.org>2006-05-07 23:10:33 +0800
commitdfd8e2825f75460ecaa3313ed05db565af19ae19 (patch)
tree246a4f34e8eb1810031c5d3e28d4273c0956748a /devel
parent6b74991d98b67182072ebb74e7f4758bf2335779 (diff)
downloadfreebsd-ports-gnome-dfd8e2825f75460ecaa3313ed05db565af19ae19.tar.gz
freebsd-ports-gnome-dfd8e2825f75460ecaa3313ed05db565af19ae19.tar.zst
freebsd-ports-gnome-dfd8e2825f75460ecaa3313ed05db565af19ae19.zip
PDCurses is a Curses and Panel implementation for Microsoft Windows.
This port compiles it using MinGW32. WWW: http://pdcurses.sourceforge.net/ PR: ports/96459 Submitted by: Ed Schouten <ed@fxq.nl>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mingw32-pdcurses/Makefile41
-rw-r--r--devel/mingw32-pdcurses/distinfo3
-rw-r--r--devel/mingw32-pdcurses/pkg-descr4
-rw-r--r--devel/mingw32-pdcurses/pkg-plist7
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e9fb8c491796..40fafa94e21f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -614,6 +614,7 @@
SUBDIR += mingw32-bin-msvcrt
SUBDIR += mingw32-binutils
SUBDIR += mingw32-gcc
+ SUBDIR += mingw32-pdcurses
SUBDIR += mips-rtems-binutils
SUBDIR += mips-rtems-g77
SUBDIR += mips-rtems-gcc
diff --git a/devel/mingw32-pdcurses/Makefile b/devel/mingw32-pdcurses/Makefile
new file mode 100644
index 000000000000..7a43277adced
--- /dev/null
+++ b/devel/mingw32-pdcurses/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mingw32-pdcurses
+# Date created: 28 April 2006
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdcurses
+PORTVERSION= 2.8
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= mingw32-
+DISTNAME= PDCurses-${PORTVERSION}
+
+MAINTAINER= ed@fxq.nl
+COMMENT= Curses and Panel terminal library for Windows
+
+BUILD_DEPENDS= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc \
+ mingwm10.dll:${PORTSDIR}/devel/mingw32-bin-msvcrt
+
+USE_GMAKE= yes
+
+PDCURSES_LIBS= pdcurses.a panel.a
+
+do-build:
+ @${GMAKE} -C ${WRKSRC}/win32 -f gccwin32.mak PDCURSES_SRCDIR=.. \
+ CC=${PKGNAMEPREFIX}gcc LIBEXE=${PKGNAMEPREFIX}ar \
+ SHELL=${SH} ${PDCURSES_LIBS}
+
+do-install:
+.for f in curses.h curspriv.h panel.h term.h
+ ${INSTALL_DATA} ${WRKSRC}/$f ${PREFIX}/mingw32/include/$f
+.endfor
+
+.for f in ${PDCURSES_LIBS}
+ ${INSTALL_DATA} ${WRKSRC}/win32/$f ${PREFIX}/mingw32/lib/lib$f
+.endfor
+ ${LN} -sf libpdcurses.a ${PREFIX}/mingw32/lib/libcurses.a
+
+.include <bsd.port.mk>
diff --git a/devel/mingw32-pdcurses/distinfo b/devel/mingw32-pdcurses/distinfo
new file mode 100644
index 000000000000..91146104cec6
--- /dev/null
+++ b/devel/mingw32-pdcurses/distinfo
@@ -0,0 +1,3 @@
+MD5 (PDCurses-2.8.tar.gz) = cd3a67c94cfa6686678058f18bf87982
+SHA256 (PDCurses-2.8.tar.gz) = e288ac5191de78c31635372f7cd31676561f5a9588258f41dac771ee9248b095
+SIZE (PDCurses-2.8.tar.gz) = 325074
diff --git a/devel/mingw32-pdcurses/pkg-descr b/devel/mingw32-pdcurses/pkg-descr
new file mode 100644
index 000000000000..bbe53fa91951
--- /dev/null
+++ b/devel/mingw32-pdcurses/pkg-descr
@@ -0,0 +1,4 @@
+PDCurses is a Curses and Panel implementation for Microsoft Windows.
+This port compiles it using MinGW32.
+
+WWW: http://pdcurses.sourceforge.net/
diff --git a/devel/mingw32-pdcurses/pkg-plist b/devel/mingw32-pdcurses/pkg-plist
new file mode 100644
index 000000000000..88bc86ce5f13
--- /dev/null
+++ b/devel/mingw32-pdcurses/pkg-plist
@@ -0,0 +1,7 @@
+mingw32/include/curses.h
+mingw32/include/curspriv.h
+mingw32/include/panel.h
+mingw32/include/term.h
+mingw32/lib/libcurses.a
+mingw32/lib/libpanel.a
+mingw32/lib/libpdcurses.a