aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-21 12:03:18 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-21 12:03:18 +0800
commit077ddf78bba80655d848ef8fb709aeaefbdb865a (patch)
treeb94b00c87f314b661ed240c41d7c3f1fb8b5ee5f /devel
parent69a41a4f080d5eaa83d18ae04aafe81da9dd1a69 (diff)
downloadfreebsd-ports-gnome-077ddf78bba80655d848ef8fb709aeaefbdb865a.tar.gz
freebsd-ports-gnome-077ddf78bba80655d848ef8fb709aeaefbdb865a.tar.zst
freebsd-ports-gnome-077ddf78bba80655d848ef8fb709aeaefbdb865a.zip
Oogly is a different approach to data validation, it attempts to simplify
and centralize data validation rules to ensure DRY (don't repeat yourself) code. It is not the intent of this module to provide validation routines but instead to provide a simplistic validation flow-control and promote code reuse. WWW: http://search.cpan.org/~awncorp/Oogly/ PR: ports/153315 Submitted by: Grzegorz Blach <magik at roorback.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Oogly/Makefile22
-rw-r--r--devel/p5-Oogly/distinfo2
-rw-r--r--devel/p5-Oogly/pkg-descr7
-rw-r--r--devel/p5-Oogly/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f2d06e74681d..2c0e71924e37 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1996,6 +1996,7 @@
SUBDIR += p5-Object-Simple
SUBDIR += p5-Object-Tiny
SUBDIR += p5-Olson-Abbreviations
+ SUBDIR += p5-Oogly
SUBDIR += p5-PAR
SUBDIR += p5-PAR-Dist
SUBDIR += p5-PAR-Packer
diff --git a/devel/p5-Oogly/Makefile b/devel/p5-Oogly/Makefile
new file mode 100644
index 000000000000..df968348911d
--- /dev/null
+++ b/devel/p5-Oogly/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Oogly
+# Date created: 20 Dec 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Oogly
+PORTVERSION= 0.31
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/A/AW/AWNCORP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= magik@roorback.net
+COMMENT= A Data validation idea that just might be ideal
+
+PERL_CONFIGURE= yes
+
+MAN3= Oogly.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Oogly/distinfo b/devel/p5-Oogly/distinfo
new file mode 100644
index 000000000000..dbf5a68da4d2
--- /dev/null
+++ b/devel/p5-Oogly/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Oogly-0.31.tar.gz) = bb2690871ac5702cdd1e2139774796663fc423ecc91a82ac28e98230c00a631b
+SIZE (Oogly-0.31.tar.gz) = 17418
diff --git a/devel/p5-Oogly/pkg-descr b/devel/p5-Oogly/pkg-descr
new file mode 100644
index 000000000000..f184f4eb33d5
--- /dev/null
+++ b/devel/p5-Oogly/pkg-descr
@@ -0,0 +1,7 @@
+Oogly is a different approach to data validation, it attempts to simplify
+and centralize data validation rules to ensure DRY (don't repeat yourself)
+code. It is not the intent of this module to provide validation
+routines but instead to provide a simplistic validation flow-control and
+promote code reuse.
+
+WWW: http://search.cpan.org/~awncorp/Oogly/
diff --git a/devel/p5-Oogly/pkg-plist b/devel/p5-Oogly/pkg-plist
new file mode 100644
index 000000000000..baf9cf013845
--- /dev/null
+++ b/devel/p5-Oogly/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Oogly/.packlist
+%%SITE_PERL%%/Oogly.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Oogly