aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-15 23:38:55 +0800
committerclsung <clsung@FreeBSD.org>2006-08-15 23:38:55 +0800
commit2ae441c15d3f639477ef6a91e460bbc6c8d3abec (patch)
treedc4a1f3be9335b3a34f84e985302927524ce7550 /devel
parentc9876c1f42b4c3d58c1856f81b060282425aec69 (diff)
downloadfreebsd-ports-gnome-2ae441c15d3f639477ef6a91e460bbc6c8d3abec.tar.gz
freebsd-ports-gnome-2ae441c15d3f639477ef6a91e460bbc6c8d3abec.tar.zst
freebsd-ports-gnome-2ae441c15d3f639477ef6a91e460bbc6c8d3abec.zip
Add p5-Hash-Case 1.003, base class for hashes with key-casing
requirements. PR: ports/102062 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Hash-Case/Makefile33
-rw-r--r--devel/p5-Hash-Case/distinfo3
-rw-r--r--devel/p5-Hash-Case/pkg-descr7
-rw-r--r--devel/p5-Hash-Case/pkg-plist11
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e74b74aaca86..32f7104cdf9b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1085,6 +1085,7 @@
SUBDIR += p5-Gnome2-GConf
SUBDIR += p5-Gtk2-Spell
SUBDIR += p5-Hash-AsObject
+ SUBDIR += p5-Hash-Case
SUBDIR += p5-Heap
SUBDIR += p5-Heap-Simple
SUBDIR += p5-Heap-Simple-Perl
diff --git a/devel/p5-Hash-Case/Makefile b/devel/p5-Hash-Case/Makefile
new file mode 100644
index 000000000000..4d371c2a1936
--- /dev/null
+++ b/devel/p5-Hash-Case/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Hash-Case
+# Date created: 2006-08-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hash-Case
+PORTVERSION= 1.003
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Hash
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Base class for hashes with key-casing requirements
+
+PERL_CONFIGURE= yes
+
+MAN3= Hash::Case.3 Hash::Case::Lower.3 Hash::Case::Preserve.3 \
+ Hash::Case::Upper.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\W\w+);/use vars q($$1);/o;' \
+ -e 's/^our\s+(\W\w+)(?!;)/use vars q($$1); $$1/o;' \
+ -e 'undef $$_ if /^\s*(no|use) warnings/o;' \
+ ${WRKSRC}/lib/Hash/Case.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Hash-Case/distinfo b/devel/p5-Hash-Case/distinfo
new file mode 100644
index 000000000000..1d0a757f49fd
--- /dev/null
+++ b/devel/p5-Hash-Case/distinfo
@@ -0,0 +1,3 @@
+MD5 (Hash-Case-1.003.tar.gz) = 3cf179f0730b3e3651eb7e270aed2dac
+SHA256 (Hash-Case-1.003.tar.gz) = 78099c6e1bf95f390ffa8e7e276bf44d0c906babbd37210ee528cc61661622f0
+SIZE (Hash-Case-1.003.tar.gz) = 4683
diff --git a/devel/p5-Hash-Case/pkg-descr b/devel/p5-Hash-Case/pkg-descr
new file mode 100644
index 000000000000..7c53d9a346e2
--- /dev/null
+++ b/devel/p5-Hash-Case/pkg-descr
@@ -0,0 +1,7 @@
+Hash::Case is the base class for various classes which tie special
+treatment for the casing of keys. Be aware of the differences in
+implementation: Lower and Upper are tied native hashes: these hashes
+have no need for hidden fields or other assisting data structured. A
+case Preserve hash will actually create three hashes.
+
+WWW: http://search.cpan.org/dist/Hash-Case/
diff --git a/devel/p5-Hash-Case/pkg-plist b/devel/p5-Hash-Case/pkg-plist
new file mode 100644
index 000000000000..26758b66d846
--- /dev/null
+++ b/devel/p5-Hash-Case/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/Case/.packlist
+%%SITE_PERL%%/Hash/Case.pm
+%%SITE_PERL%%/Hash/Case/Lower.pm
+%%SITE_PERL%%/Hash/Case/Preserve.pm
+%%SITE_PERL%%/Hash/Case/Upper.pm
+%%SITE_PERL%%/Hash/Makefile.PL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash/Case
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hash
+@dirrmtry %%SITE_PERL%%/Hash/Case
+@dirrmtry %%SITE_PERL%%/Hash