aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-10-14 17:21:46 +0800
committertobez <tobez@FreeBSD.org>2005-10-14 17:21:46 +0800
commit30c13462772164724f22de78a329aceb0e0aaf29 (patch)
tree7f00a2a2a56504e1c799db8fc38616f4de2f5eed /devel
parentb49d65cf45addf4aeaefbbb96fb3534f7fcdee36 (diff)
downloadfreebsd-ports-gnome-30c13462772164724f22de78a329aceb0e0aaf29.tar.gz
freebsd-ports-gnome-30c13462772164724f22de78a329aceb0e0aaf29.tar.zst
freebsd-ports-gnome-30c13462772164724f22de78a329aceb0e0aaf29.zip
Add devel/p5-Sort-Key 0.14, a perl module that sorts objects by one or
several keys really fast.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sort-Key/Makefile30
-rw-r--r--devel/p5-Sort-Key/distinfo2
-rw-r--r--devel/p5-Sort-Key/pkg-descr4
-rw-r--r--devel/p5-Sort-Key/pkg-plist10
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 35fc970ac2c2..e19667f36b46 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1102,6 +1102,7 @@
SUBDIR += p5-Smart-Comments
SUBDIR += p5-Sort-Array
SUBDIR += p5-Sort-ArrayOfArrays
+ SUBDIR += p5-Sort-Key
SUBDIR += p5-Sort-Tree
SUBDIR += p5-Sort-Versions
SUBDIR += p5-Spiffy
diff --git a/devel/p5-Sort-Key/Makefile b/devel/p5-Sort-Key/Makefile
new file mode 100644
index 000000000000..e5f473ecbc14
--- /dev/null
+++ b/devel/p5-Sort-Key/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: devel/p5-Sort-Key
+# Date created: 14 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sort-Key
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sort
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Sort::Key - sorts objects by one or several keys really fast
+
+PERL_CONFIGURE= yes
+
+MAN3= Sort::Key.3 \
+ Sort::Key::Maker.3 \
+ Sort::Key::Register.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sort-Key/distinfo b/devel/p5-Sort-Key/distinfo
new file mode 100644
index 000000000000..80d21ba344eb
--- /dev/null
+++ b/devel/p5-Sort-Key/distinfo
@@ -0,0 +1,2 @@
+MD5 (Sort-Key-0.14.tar.gz) = 0d5e85052b35b7ba7f66f0b9db2a8bcb
+SIZE (Sort-Key-0.14.tar.gz) = 19428
diff --git a/devel/p5-Sort-Key/pkg-descr b/devel/p5-Sort-Key/pkg-descr
new file mode 100644
index 000000000000..322acfcb0837
--- /dev/null
+++ b/devel/p5-Sort-Key/pkg-descr
@@ -0,0 +1,4 @@
+Sort::Key provides a set of functions to sort object arrays by some
+(calculated) key value.
+
+WWW: http://search.cpan.org/dist/Sort-Key/
diff --git a/devel/p5-Sort-Key/pkg-plist b/devel/p5-Sort-Key/pkg-plist
new file mode 100644
index 000000000000..b476a632e56a
--- /dev/null
+++ b/devel/p5-Sort-Key/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Sort/Key.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Sort/Key/Maker.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Sort/Key/Register.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Key/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Key/Key.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Key/Key.so
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Key 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Sort/Key 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Sort 2>/dev/null || true