aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-03-02 03:23:04 +0800
committervs <vs@FreeBSD.org>2005-03-02 03:23:04 +0800
commit32b7a7cba3535583737f633784f2ac1b825eb027 (patch)
tree38e48e2d3db80cf36c68bdb06d73497ad33e6789 /devel
parent3c8b13d865fabae85919fbc5cc6285537b6461a7 (diff)
downloadfreebsd-ports-gnome-32b7a7cba3535583737f633784f2ac1b825eb027.tar.gz
freebsd-ports-gnome-32b7a7cba3535583737f633784f2ac1b825eb027.tar.zst
freebsd-ports-gnome-32b7a7cba3535583737f633784f2ac1b825eb027.zip
Remove some patches in favour of USE_LIBTOOL_VER=15
Diffstat (limited to 'devel')
-rw-r--r--devel/jclassinfo/Makefile1
-rw-r--r--devel/jclassinfo/files/patch-ltmain.sh15
-rw-r--r--devel/sdlmm/Makefile1
-rw-r--r--devel/sdlmm/files/patch-ltmain.sh28
-rw-r--r--devel/shmap/Makefile1
-rw-r--r--devel/shmap/files/patch-ltmain.sh42
6 files changed, 3 insertions, 85 deletions
diff --git a/devel/jclassinfo/Makefile b/devel/jclassinfo/Makefile
index 5d57f57e9687..6b59eacb20c4 100644
--- a/devel/jclassinfo/Makefile
+++ b/devel/jclassinfo/Makefile
@@ -18,6 +18,7 @@ COMMENT= Shows information about Java class, dependencies and more
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
USE_GNOME= pkgconfig gnomehack
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/devel/jclassinfo/files/patch-ltmain.sh b/devel/jclassinfo/files/patch-ltmain.sh
deleted file mode 100644
index 74ae099b3e91..000000000000
--- a/devel/jclassinfo/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Wed May 5 09:16:19 2004
-+++ ltmain.sh Wed May 5 09:16:29 2004
-@@ -5528,10 +5528,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/sdlmm/Makefile b/devel/sdlmm/Makefile
index d3b3c5db8db6..d4232a6e6dfe 100644
--- a/devel/sdlmm/Makefile
+++ b/devel/sdlmm/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ Wrapper for the SDL (Simple DirectMedia Layer)
USE_SDL= sdl
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/devel/sdlmm/files/patch-ltmain.sh b/devel/sdlmm/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/devel/sdlmm/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/shmap/Makefile b/devel/shmap/Makefile
index f1a69b189353..1afad1decb4a 100644
--- a/devel/shmap/Makefile
+++ b/devel/shmap/Makefile
@@ -18,6 +18,7 @@ COMMENT= Shared-memory-based hashmaps
LIB_DEPENDS= mm.13:${PORTSDIR}/devel/mm
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/shmap/files/patch-ltmain.sh b/devel/shmap/files/patch-ltmain.sh
deleted file mode 100644
index e5d2d744a6ec..000000000000
--- a/devel/shmap/files/patch-ltmain.sh
+++ /dev/null
@@ -1,42 +0,0 @@
---- ltmain.sh.orig Thu Sep 20 11:29:54 2001
-+++ ltmain.sh Thu Mar 21 04:16:02 2002
-@@ -1040,7 +1040,7 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
-@@ -1048,7 +1048,7 @@
- fi
- if test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2439,7 +2439,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
-@@ -4208,10 +4208,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"